LayOut Portal not matching SketchUp model scene after changes to scene

Hello, again.

I am having a strange issue with Layout.
Several of my portals aren’t matching up with my model. I have saved my model after making changes and several portals aren’t updating. I have updated the link and re-rendered the model in LayOut with no luck. I have also opened the model from inside LayOut to make sure I am working on the correct model.

I must be missing a step or something. Does anyone have any advice on to fix this?

It would help if you share the LO file so we can see exactly what you’ve got setup. There’s certainly a simple explanation but I can think of a few different reasons for what you are seeing.

It’s a full 40-page set of plans and 165 MB. I would rather not share them with the world with client info and such. I know you’ve been around forever and are always a great help. Can I share it with you privately?

Yes. You can share it privately. Upload it to DropBox and share the link. I’ll look at it ASAP although my wife just informed me we’re going to a holiday party in a few minutes.

LOL. Same here. My Wife just gave me the T-Minus 1 Hour to leave for a party as well. Let’s chat tomorrow.

1 Like

I don’t know about the ones you pointed to, but the entries that are in red are ones where the only copy of the file is the embedded one inside the LayOut file. For example, 1675306563_exteriorwall_27028.skp was originally connected to a file named exteriorwall_27028.skp. If you can find that SKP you can select the entry in the References list and use the Relink button to connect it back to the actual external file.

Maybe we can work on it today?

Hi, I am interested in how this is resolved.
Similar issue

  • update scene in su
  • save su file
  • layout already open, update reference su file
  • select viewport, render it
    but, viewport shows scene other than one selected

any ideas…

what am I missing?

Share your LO file so we can see what you’ve got.

Okay, here’s link to the files:L

on sheet S-1, the viewport to the left of the ‘sheet’ was intended to show scene ‘1 walls new’
so I could overlay it on the sheet just to add some lines.
I can get elevation scenes, but not the first or second floor plans…

Neither of those is the LayOut file.

Should be there now, thanks.

Yes it is. I’ll look at it ASAP.

OK. So you have modified scene properties in the viewports (or at least many of them) which overrids the properties you set in the scenes. Example:

This viewport shows you’ve modified Camera, Effects, and Style. That means that any changes you might make to those properties in the SketchUp model will be ignored because you’re telling LO you don’t care about those settings from the SketchUp model. The modification to those properties means that LO will ignore those properties when you select a different scene. If, for example, you chose an elevation scene for this viewport, you’ll still see a plan view because your decision to modify the Camera properties in LO overrides those in SketchUp. You would need to Reset the properties to go back to the settings you’ve made in Sketchup.

Best practice is to avoid doing anything in LO that modifies the Camera properties because this creates a bunch of problems. It can create even more problems for you if you modify Camera postion in LO, then add a bunch of labels, dimensions, etc. and then later press Reset.

By the way, I looked at one of the SketchUp model references (there are four in thhis LO file) and noted incorrect tag usage, which I fix …
Screenshot - 1_7_2023 , 8_06_57 PM

… and you seem to be hoarding a lot of unused stuff …
Screenshot - 1_7_2023 , 8_08_31 PM

Purging the unused stuff reduced that particular file’s size by 53%. It wouldn’t surprise me to see similar reductions from your other .skp files.

Edit: I looked at the other large .skp file reference, same sort of fixing as on the first one. Lots of incorrect tag usage and I purged unused stuff. This reduced that file size by 71%.
Screenshot - 1_7_2023 , 8_23_25 PM

The LO file itself could do with some purging as well.



Okay, so I had mucked up the viewport settings.
What is the simplest way to create new viewport in LO? File Insert?

And to assess and purge the files, is there a good explanation you can refer me to?

Thank you very much!

If you already have a viewport from the SketchUp model in the LO document, you should copy a viewport from that model and paste it elsewhere in the document. Do not insert a SketchUp file more than once into a given LO file.

I used a plugin called Default Layer Geometry by TIG (from Sketchucation) to fix the incorrect tag usage. Without the plugin you would need to either manually go through all of the objects in your model, select their geometry and set the tag to Untagged or you could delete all of the tags which would give Untagged to everything in the model.

For purging the unused stuff I used TIG’s Purge All (also from Sketchucation) because it gives a nice report showing how much stuff was removed. If you don’t care about the report you can go to Model Info>Statisitcs and click Purge Unused. It does the same thing without the report.

It would be best to stay on top of all this stuff as you go. Make sure that you are keeping all geometry (edges and faces) untagged. Only objects (groups and components) should get tags. And regularly purge unused stuff from your models. Keep in mind that any components you might add to your model and later delete from the model space remain in your model file. That can be a benefit in some cases but mostly it’s like stuffing all those windows, doors, pieces of furniture, appliances, cats, etc. up into the attic of your house. You gotta get that stuff off your property to really be rid of it. Materials that belong to those components are also kept as well as all the different styles you might sample and decide not to use.

Good luck with it all.

Thank you.

Might as well ask this too, since I’m new to the program and the forum.
Is there a forum to find someone to assist with taking jobs to Layout?

You’re welcome.

You could post in the Commercial and Collaborative category. Don’t provide any contact information in your post. Let people contact you by private message. Also be aware you are likely to be contacted by people who aren’t qualified (SketchUp Free/SketchUp Make users) and’or scammers from India or elsewhere.