Layout not recognising Sketchup file when imported or inserted

Hi, 1st time posting here. Landscape designer using Sketchup and Layout for design and documentation work. Just upgraded my old license to subscription. Running a new MacBook Pro, 36 gigs of ram, Sonoma 14.3.

I (now) know there are compatibility issues with the new Macs. I did not know this when I bought my new computer and upgraded to the subscription. My old Macbook died so I had few options.

I am expereincing a very strange problem. When I send a file to Layout, it shows up on the page I’ve created, but it is not “active”. If you click on it, nothing happens. It’s a mirage. I’ve also tried opening a new file with a blank page and inserting a sketchup file into this new document and the same thing happens. In a couple of instances, the imported/exported Sketchup file is active/clickable, but as soon as any change is made (raster to vector, scale) the model disappears and the page is empty.

I have been using my new setup for a few months now and this has never happened before. Lots of other issues (Sketchup crashing everytime you try to open the Paint Bucket, an issue I’ve since realized is ubitquitous until the software and OS get aligned) but this is a new one.

I’ve tried restarting the computer. Have not yet tried reloading the software.

Any help would be immensely appreciated. Pulling my hair out.

Share the LayOut. I expect there’s a simple solution for it but seeing the file will help.

Are you still using SketchUP 2016 as your profile indicates?

Apple fixed this in a recent OS update.

No, brand new subscription, so SU 2023. I’m not sure how to change my profile info. I see that it is out of date.

Forgive my ignorance but I do not see an attachment option. Here is a Dropbox Link though.Dropbox - Helms Site Plan.layout - Simplify your life

The Paint Bucket issue is fixed?!? I had given up and was waiting for the SU 2024 update. Thank you for letting me know.

Yes. Apple caused and Apple fixed it.

Yes, I knew the issue was on there end. Was the file viewable?

The model was located at a fair distance from the model origin and the Camera properties weren’t saved with the scene so there were camera issues. Did you import from Revit?

I fixed the scene in the SU model and also purged unused stuff from the model.
Screenshot - 3_19_2024 , 9_18_05 PM

I’ll upload the file and share the link shortly.

Looks like you got your profile sorted out.

1 Like

Here’s the link: Dropbox - Helms Site Plan dr.layout - Simplify your life

Wow. Thank you. That is very generous.

I imported the original CAD survey into Sketchup and then traced it. I often discard the CAD layer once I do this but did not in this instance.

Is there somewhere (other than kindergarten) that you would refer me so that I could better understand the mistake I made and avoid repeating it?

I’m not sure where this sort of thing would be addressed specifically. It’s stuff I figured out from years of seeing problem files from others.In general, keep the model close to the origin. Don’t hide the axis lines as that tends to lead to problems. Definitely before you go to LayOut you should allow Camera Position to be saved with scenes. This is important in the viewports in LO. And also don’t allow the camera to get placed at a huge distance from the model. This can happen if you do your modeling with the camera set to Parallel Projection. Do your modeling with the camera set to Perspective and save Parallel Projection for scenes.

Although I don’t think it’ll cover what you had going on here, it would be good to go through the tutorials at

Oh yea. And you’re quite welcome.

I may be reading this wrong as I haven’t looked at the file but, if you were expecting to be able to edit the Sketchup model within Layout this way, they have changed the default setting to stop people from doing this without understanding what they are doing. You can turn it back on but it is generally better not to.

Actually, due to the way the the camera was positioned in the scene, it was difficult to select the viewport in the LayOut file. I was able to select it with a right to left selection window and get the model opened to fix it.

Good point to not modify the camera properties in LO though.

1 Like

DaveR - I went into 3 related SU files (different design iterations of the same property) and saving the camera position with the scene seemed to be the key fix. I’m not sure why I hadn’t encountered this before.

I had a few follow up questions. Totally understand if you don’t have time to answer these.

I’m curious - why is it better to model in Perspective, particularly with respect to LO? I spend a lot of time working on 2D site plans in SU and just assumed it was better to be in Parallel Projection. When I do 3D modeling, I usually switch to Perspective.

I didn’t realize the camera was positioned so far from the model, as it looked normal in my SU view. Was there something else happening that I wasn’t seeing wrt the camera position?

Also, did you use an extension to purge those unwanted elements (likely relics from CAD import)?

And yes, I try to never modify the SU model from LO, including camera properties.

Thank you again. I really appreciate the help.

It’s not “particularly with respect to LO”. SketchUp is designed to be used with the camera set to Perspective, whether you go to 3D or not. It’ll be easier to ensure that edges remain on axis and plane. It also prevents getting the camera accidentally positioned out in the Kuiper belt.

This is a consequence of working in Parallel Projection. You won’t see the camera moving farther from the model in Parallel Projection. I fugured it out by switching the camera to Perspective.

I used an extension by TIG called Purge All. You can do the same thing with Purge Unused in Model Info>Statistics. I used the plugin because it gives the report I showed. If you want that plugin you can get it from Sketchucation.

Good deal.

1 Like

Hi There,
I’m back with problems relating to the same site model crashing repeatedly. I have been using it for some time without problems but now it crashes every time I open it. It even into full black out mode! I’m sure there is a lot of “junk” in here but the model is not sooo huge (92MB) and at this point I can’t even keep the model working long enough to strip it down a bit. It’s too big to upload here is a DropBox link. Any help is greatly appreciated.
MacBook Pro Apple 3 Max, 36 GB RAM

What’s the name of the file? All I see in your link is a PDF and about a dozen .skp files. None are 92 Mb.

Sorry. Wrong link. Here it is. Dropbox

Curiously the thumbnail shows black as you reported but it opened just fine for me on my PC. I wonder if this is somehow related to your M3.

See if this copy of the file plays more nicely for you.

It seems to be working better, though I won’t be working in it again until tomorrow or Friday. Thank you so much for looking at it.

Did you use the same Purge extension by TIG that you referred to previously?

And, I’m embarassed to admit, I never purge my models. Is this a regular part of your workflow or only when you are having issues?

You’re welcome.

Yes. Before I purged, I corrected the tag usage.
Screenshot - 7_3_2024 , 6_33_38 PM
Then purged quite a bit.
Screenshot - 7_3_2024 , 6_34_16 PM
And then I checked the sizes of the remaining materials. Some are excessively large.

Resulted in a 72% file size reduction.

I purge my models regularly. I set up a keyboard shortcut to run Purge All so there’s nothing preventing me from doing. Leaving loads of unused components, materials, and styles just invites problems. All that unused stuff becomes 100% liability and 0% asset.