Layout Model Style Control Issue

Following on from this post…

I continue to have occasional issues with viewports changing from set conditions.

I’m not sure if my original problem was with tags resetting themselves, at least I haven’t noticed that issue since I posted the above.

My current workflow is to have one scene per section in SU and I have four styles that correspond to four stacked viewports in LO to control line-weights, etc…

So, I’m back to work on a Layout file this morning after leaving it on Friday as it should be - viewports and corresponding styles set up and behaving, and one style over all pages that have the corresponding viewport is not the style it should be.

I have to do a style reset for those viewports and then chose the required style again - tedious.

In SU I’m thinking I’ll go back to for each elevation or plan having a scene per style which (for sections) is going to quadruple the number of scenes that I have in the model!

As Nick Sonder said:

I might have a play around with Curic’s Scene Manager and turn of the scene tabs…

I’ve been working on a Layout file today.

One that has been in progress.

One scene per floor / section / elevation in SketchUp and stacked viewports in Layout for presentation control.

I’ve just gone into the SketchUp model to change the Shadow dark setting and in Layout all stacked viewports linked to the SketchUp model which have styles assigned have reset themselves to the style that the actual scene has in the SketchUp model.

Another super annoyance in Layout!

So, as I mentioned above, it’s back to one scene for each viewport in a stack quadrupling the number of scenes in SketchUp

:sob:

Had you changed the style selection for the viewports in LayOut? I haven’t seen this reset thing that I think I understand from your description in any of my projects. I’ve been experimenting just now to see if I can get it to happen and I can’t unless I reset the viewports.

Maybe my understanding of how it works is wrong…?

In the SketchUp model I have, say, one scene and four styles - a Section style (thanks @Matt), a Linework style, a 2D Objects style and a Shadow style. The scene needs a style so I just assign it to the Linework style.

In Layout I’ll have four viewports stacked referencing the one scene. In Layout I’ll then assign three of the viewports to the styles 2D Objects, Section style and Shadow (one of the viewports has the scene assigned style Linework).

Much of the time this works but more frequently than I would like it behaves as I described above.

So it might be some other change in the SketchUp model that causes this - it seems random. It just so happened that I noticed immediately that the change in the shadow setting seemed to cause this problem.

Does the scene in SketchUp have the shadows displayed or not?

The behavior I see (and the way I understand it is supposed to work) is that scene properties that are set in LayOut will remain set that way even if you make changes to and update the scene in SketchUp. So any of settings in the sub-sections of the SketchUp Model panel in dark gray should remain as they are set there even if the settings change in the scene in SU.

This is a screen shot from the file I’ve been experimenting with this morning trying to get the result you described.

Shadow and styles don’t change for this viewport even if I change those settings in SketchUp.

Interestingly the settings in the various sub-sections remain changed if I select a different scene, too. This snagged me once until I understood what was going on. Now it makes sense to me that it should do that and I know to hit Reset.

That’s how I understand it and how I believe I’m implementing it…

Interestingly, the Layout file / SketchUp model in question, I changed the shadow setting for the existing conditions floor plans but looking into the SketchUp file I haven’t changed the shadow settings for the proposed conditions floor plans and the stacked viewports in Layout representing those scenes have not been affected. Yet…

How many viewports do you have from the “exisiting conditions” scene?

Four, exactly the same as for all the floor plans I shown in Layout

And the shadows are displayed in all four viewports from the beginning or just in one viewport?

:thinking: standby…

Can I sit down while I’m standing by? :smiley:

ok

The Layout file in question, all the viewports in every stack have the Shadow checkbox ticked so really only the viewport that is assigned to the Shadow style should have this checkbox ticked…

I’ve checked another Layout file that I had problems with and the Shadow checkbox was not consistently checked.

Anyway if this has been the cause of my problems I shall scream very loudly!

I’ll be more diligent with these settings and see what happens.

Thanks Dave.

Yes.

Hmmmm…

…maybe it’s time to start your weekend. :smiley:

Do keep an eye on things.

As for the shadow settings, you might consider setting the time, date and light dark settings where you want them for the scene but turn off the shadows in the scene in SU. Then only turn the shadows on for the one viewport in which those shadows should be displayed. Since the shadows are sort of an exception to the “rule” as far as what is shown in the viewports, it would probably be easier to manage them that way.

1 Like