Layout viewport style changing unexpectedly:

Continuing a discussion here, still no solution - Layout Model Style Control Issue (still no solution that I’ve seen posted): Whoever is in charge of forum management, why close the post I’m referencing above, or the post that this was orginally continued from if an issue hasn’t been solved? Please keep the posts open until an issue is solved.

Hi everyone. I have seen a post recently between two people I’ve chatted with, seems like from what I read there was no solid resolution or anything solved as to what the problem could be with styles changing on preset viewports in layout seemingly randomly.

I setup a custom viewport overlay, for example I make a layout viewport set to only show the roof above in dashed red, once I overlay that onto the primary layout viewport that represents the main sketchup scene back in sketchup, I go to work on other things. Sometimes when I come back into layout, usually I’ve seen things change when I open layout again, the viewport that I’ve set to show the roof above in dashed red lines in the wireframe style, the style changes. It changes where I see everything as it should be, but instead of looking like a total wireframe, it creates a white fill in everything, dashes stay the same, colour, etc, but now it’s not true wireframe anymore because the contents has a white fill in it making it so that I can’t see the viewport below it (the style on that viewport is different than what I’ve originally set it to).

@DaveR mentions to untick the checkbox for the shadows setting on the effects of the layout sketchup model window. This is not a solution so far for me in my experience or from what I’ve read. Does anyone have any info on this problem? This is a big time waster. While we are at it, layout, it would be great if we could rid of this link between tag visibility and edge styles sometime this year? (Hopefully the next release)…

@paul.mcalenan, has what dave has said in the last referenced above post of yours fixed this issue for you?

Tucker, I should have posted an update to that discussion I had with DaveR.

That specific issue has not occured since, but it wasn’t specifically to do with the shadows settings, i.e. it wasn’t a workaround - it was (as I understand Dave - and do understand) about inconsistent settings across my scenes and not applying one consistent style across all of the scenes in the SketchUp file that I use for Layout presentations.

Doing this does not prevent the ability to use stacked viewports for presentation - it means that all viewports have a default style that is the one set across all the scenes in the SketchUp file… and therein lies the cause of an occaasional viewports changing issue that I have (??) but is probably to do with me being sloppy with my viewports as was the issue I reported in the post you refer to.

(this occasional issue is seemingly random and I haven’t been bothered to note what is happening or if there is any pattern and it happens so infrequently that it’s easier just to fix the specific viewport and move on)

Oh okay! Good to know and I appreciate your reply.

For some final clarification:

So it sounds like you’re still not sure about what is causing a layout viewport style to change and have the results I’m talking about or something similar? I have unticked all the shadow settings for all my layout viewports except for the main primary ones linked to sketchup that show the native sketchup scene. Every other overlay I use I have unticked the shadow setting to off. Do you think this makes a difference? Do you have any other possible solutions? I imagine it won’t be a huge pain for me as well regularly, however just curious if you have any other possible solutions or hunches.

Thanks.

As I see it, it’s not about ticking or not the shadows toggle, it’s about having consistency.

When Dave mentioned about shadows I checked my Layout files and found that my SketchUp scenes were not consistent, i.e. one scene would have one style and no shadows, another would have another style and shadows, and so on.

When I applied the one style to every scene in the SketchUp file and then applied my style overrides as required on the particular stacked viewport in Layout, the specific problem I had disappeared.

To add to this…

It may well have been the case that it was my viewport and style sloppiness that was my problem and that one doesn’t necessarily have to have all scenes in SketchUp have the same one style for insertion into Layout - just that it should be logical and consistent…

I notice that: When I change the style of a viewport in LO using a default style that is NOT in my model, the viewport eventually reset. For example: In my model, a scene is set to HIDDEN style. From LO, I have the viewport from the scene, but I over-ride it with a WIDEFRAME style that I pick from LO which is not available or loaded in my model. Eventually, the viewport style will reset to HIDDEN. (After a reopen perhaps) To fix the problem, I just need to be sure that the style WIDEFRAME is loaded (used or not) in my model. This way, I notice, the “reset” does not occur. Hope this helps. This said it’s definitely a bug because if LO offers you to use a different style than the one loaded in your model, it should not reset it. Otherwise, it should not be available to pick.

Great feedback! That sounds like you know what’s going on Joe. Thanks for your feedback guys, I’ll keep all this in mind and do some changes.

  • Tucker

@adam @Mark , any thoughts on this bug?

The problem I was having and occasionally have now involves styles loaded from the SU model.

Actually today I was having some issues: on one page I copied a viewport with an overrided style (loaded from SU), created a new page and pasted the viewport expecting the viewport to be pasted with the override style, but no, it was pasted with the SU scene style.

This happened a few times and LO seemed to have problems letting me re-override the style. One time LO crashed.

This appears to be a new buggy issue that I can’t recall experiencing before…

@adam @Mark . Speaking of bugs, and maybe not best to go into this on this thread. Layout crashed on me almost 30 times in one day using a brand new laptop and my powerful desktop (specs are not updated on my profile).This all had to do with unticking the auto render box to off, when the auto render is set to off layout would crash repeatedly, the problem of crashing was only fixed when I turned auto render back on. This is a huge problem because layout is extremely slow when auto render is set to on, so I’d like to have it off most of the time but don’t now because I worry layout will crash again during important work. This needs to be addressed and hoping this can be fixed before next update.

Paul:

Yea looks like there are some bugs with this. This is not the end of the world when you only have to update a few viewports, however it’s very annoying and with a larger project it could be a huge pain. I hope this is fixed soon…