Model Styles in Layout not always rendering correctly

Hello,

I keep running into an issue which is causing me a lot of headaches and I hope somebody can help me find a resolution. I’m using Layout and have many pages where I’m referencing my Sketchup model with a custom style. I’ll right click on my model reference in Layout and select my custom style to display the model and that works fine for a while. But while I’m doing this I’m also making various changes to my Sketchup model and re-save it from time to time. For some reason, Layout keeps reverting back to the default style on all of my model references even though my custom style is selected and has a checkmark next to it. When this happens, the only way to get it to display correctly is to right-click on the model reference, select a different style from the styles menu, then right click again and select the style that I want. This forces it to reload the model reference with the correct style. The problem is that if I have 50+ pages with lots of model references, I waste tons of time going through each and every model reference on every page to force it to display the correct styles, which is obviously super annoying and not the expected way that this software should work.

Does anyone know why this is happening or have a work around for me? I’m guessing this is a bug and I could really use a fix for this soon before my head explodes in frustration.

Thank you so much,

Tommy

What is the name of the custom style in SketchUp ?
Did you purge the styles in SketchUp ?
Do you use different scenes for your viewports in LayOut ?

It does work fine that way until you make modifications in the SketchUp file. By changing the viewport’s style in LO, you disconnect the viewport from the scene in SketchUp. You’ll notice that the scene shows as modified in the SketchUp Model inspector window.

You should be choosing the style for the scene(s) in SketchUp and update the scenes so that’s the style used for them. Then update the reference in LO and the viewports will reflect the change.

Don’t do anything that will make the viewport show as modified and you’ll eliminate a whole lot of problems you’re creating for yourself. So don’t double click on the viewport to zoom or move the camera, don’t change to a standard view, don’t select a different style. Those are scene-specific attributes so make those changes in the SketchUp file.

[quote=“tommytompkins, post:1, topic:48858”]
Does anyone know why this is happening or have a work around for me? I’m guessing this is a bug… [/quote]

It’s not a bug and you don’t need a workaround. You just need the right workflow in the first place.

Understood. Fix the workflow and I expect your head will be safe.

2 Likes
  1. The name of my custom style called “Simple No Background.”
  2. Not sure what you mean by “purge the styles” in Sketchup. How exactly do you purge the styles?
  3. Yes, I use different scenes for viewports in LayOut. But I also change the zoom and pan on in my viewports so they don’t look exactly like the scenes in Sketchup.

This is the basis of your problem.

1 Like

Interesting. I didn’t know that this was the preferred workflow. I was trying to get away from having to create a separate scene for every single viewport that I use in LayOut. If I do it that way, I can potentially end up with hundreds of scenes in my sketchup model. Are you 100% certain that this is how it’s intended to be used? It seems odd since LayOut provides the ability to select different styles from my Sketchup model and it does work most of the time even when making changes to my Sketchup model and resaving. The issue only seems to pop up if I create a new scene in Sketchup that has a new layer, then I have to systematically go through all other scenes in Sketchup and remove the unwanted layer from those scenes and update the scenes. That’s another issue I keep running into. Maybe it’s related?

Thanks for the help,

Tommy

  1. As @DaveR explained well, you are modifiyng the viewports , which causes your troubles
  2. you can purge the whole model for unused materials, styles and components in one action via Window->Model info->statistics
    Purging the styles would force Sketchup to use only the ones intended
    1)just curious,although there have been issues with some naming conventions(special characters)

Yes. I am 100% certain. It may not be the way you’d like to work but it’s the best way and avoids the problems you describe.

As you can see there are other ways as options. They can be useful for quick one-offs where you don’t need to make changes to the model later on. But anything you do that makes the scenes show as modified in LO’s SketchUp Model window will create problems for you when you need to make changes to the model.

You don’t have to use it but the best workflow is as I described. Any changes you need to make to the view of the model get done in the SketchUp file and the affected scenes get updated so the changes show in the viewports. You can use the same scene for more than one viewport so it might be that all you need to do is crop the view by dragging the edges of the viewport.

In the SketchUp files for the furniture plans I create I will show a number of parts as 2- or 3-view parallel projected views in a single scene. I then use multiple copies of the viewport and just drag the edges to crop what I don’t want to show.

As for your thing with adding layers in SketchUp, that is a SketchUp thing and not specifically related to LO. If you need to add layers after you’ve created a bunch of scenes, you either need to update those scenes with the correct layer state or you can use one of several extensions that create scenes that are not visible in existing scenes.

I’m making furniture plans too so I’m interested to see how you do this. If you’re making 2 or 3 parallel projected views in a single scene, does that mean that you’re making multiple copies of your parts and rotating your parts on different axis’ to show the different views within the same scene?

Every project starts with an assembled version of the piece located at the origin. Every part is an instance of a component–no groups are used–and those components get assigned to appropriate layers. On a simple table, for example, there would be layers for Legs, Aprons, Top, and for other things such as hardware and corner blocks or whatever. I make those layers after the assembled model is complete.

Then I copy the model over to the right and back behind the original copy. This copy is used to make the exploded views. Then I place additional copies of individual components, usually above the exploded view, oriented to create 2- or 3-views of the parts. I’d make a 3-view of the table leg, for instance, but probably only 2-views for aprons. These parts can all be laid out and shown in a single scene if you want. For more complex models I would use multiple scenes mostly to make it easier for me to know what’s shown in the scene.

I would generally have the following scenes: 3D, 2D front, 2D side, exploded, 2D parts. Again, for more complex models I would have more scenes. There’d be scenes for exploded views of sub assemblies such as drawer and doors. There might be detail views of complex joinery or other things. Even in the very complex models I’ve done, I’ve never found a need for anything close to a hundred scenes, though. 25 is probably about the max.

Important note about creating scenes. Use Zoom Extents or Zoom Selection to get the stuff you’re interested in showing to fill the drawing window space.

When adjusting the apparent size of the model in the LO views, you can drag the edges of the viewport but there should never be any need to double click on the viewport to use Zoom. If you want to crop a view of the model, tick Preserve Scale on Resize and the drag the viewport edges.

In case it got missed, every single part in the SketchUp model is a component. This means that when the inevitable changes are made to the model, I only need to edit the assembled model. The same changes will be made throughout the model space so all other copies of the parts will get updated, too.

Thanks Dave. That’s very useful information. I do use components for everything as well but it looks like I need to make some changes to my workflow in regards to how I lay out my parts in different scenes with viewports in mind in LayOut. I think part of my problem is that I just recently started using Layout, while I’ve been doing things in Sketchup a certain way for a long time. Thanks again!

1 Like

You’re quite welcome.

If you’d like, sometime I could show you an example of a plan I’ve done using a screen share. Might provide more clarification.

Thanks Dave, that’s very nice of you to offer a screen share. I’d like to take you up on that if you wouldn’t mind! :slight_smile:

Is Dave grooming again. Thought we’d broken him of that.:laughing:

We’ll have to work out a time when I’m not at my day job. I’ll send a PM later.

@Box, it’s hard to break old habits. :smiley:

2 Likes

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.