Layout Scene Styles lost when updading reference model


#1

Hi,

I am running Sketchup / Layout Pro 2016 and having trouble with my Layout Scene Styles when I re-link the Sketchup File (i.e. when I make updates to the file and save it as a new file, needing to re-link it).

Our models are huge (600meg!) and the layout is around 20 pages so while updating scene styles on a small model with not many pages may not take long this is actually a massive waste of time for us (with big models and lots of pages).

Has anyone come across a solution to this?

Or perhaps, is there any way to make all scenes in the multi-page document the same style (Shaded with Textures)?

Looking forward to hearing from someone smarter than me!

Thanks in advance,

Joe


#2

So it sounds like you have changed the style for the viewports in LayOut instead of making those changes for the scenes in SketchUp. While it can be done, it’s not a good practice and your problem shows one reason.

Go back to the current SketchUp file and make the changes there. Choose the right solution from the following.

All of these assume your viewports do not show the scenes as modified. If the viewports do show modified scenes, you’ll need to reselect the scenes.

A. If your SketchUp model has only one style but it needs to be changed, make the required edits and update the style. Save the changes and update the reference in LayOut. With only one style to use, the viewports will show that style.

B. If you currently have multiple styles in the SketchUp file and want only one you can delete the other styles leaving only the one you want forcing SketchUp to use that style in all scenes. Of course save the changes, update the reference in LO and you’re good to go.

C. In SketchUp select the desired style. Then select all of the scenes that need to be updated. Select the first one, hold Shift and select the last one. Then click on the circular arrows in the top left corner of the Scenes window. Another window will open asking you what properties you want to save. Untick all but Styles and Fog. Then click Update.
Screenshot%20-%203_2_2018%20%2C%205_55_29%20AM
Then in theScenes window, open the Details menu by clicking on the arrow that points out to the right on the far right of the window. Click on Purge. Save the changes and update the reference in LayOut.

It might seem like a shortcut to make changes to the viewports in LayOut instead of changing the scenes in SketchUp and it can be if you never need to go back and make changes to the SketchUp model or change the SketchUp reference file as you’re doing. But it generally ends up making more work and taking more time than you saved by changing the viewports in LO. Avoid doing anything that makes them show as modified.


#3

Thanks Dave,

Yes you’re spot on, I have been trying to change the scene style in layout.

I will give it a go in Sketchup as you describe and see if that solves this unnecessary re-work, by the sound of your post it should.

Thanks again.

Joe


#4

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.