Layout Styles Issues after Update or Relink Model References

Hoping to get some help with an issue I recently had with a Layout file. I modeled in SketchUp using just four styles in my In Model collection (color texture, monochrome 1,monochrome 2, and monochrome 3) . In Layout, I used 2 additional styles in a style collection I call woodworking (hidden line and wireframe-dashes styles). That collection is located in a folder beneath the SketchUp default styles location at this path: ~/Library/Application Support/SketchUp 2023/SketchUp/Styles/woodworking.

In Layout I relink the SketchUp file using File->Document Setup-> References->Relink.
(References->Update has also been know to have similar results.)
After the relink completes and examine the pages, the viewports which had been modified using the woodworking styles collection revert to displaying the SketchUp In Model styles. Furthermore, selecting one of these viewports, the SketchUp Model Tray->Style which highlights the style of the viewport in gray, shows the style name is actually the correct style from the woodworking style collection even though the displayed style is one of the the original four SketchUp In-Model styles.

Here is a screenshot where the style being displayed is one of the SketchUp In-Model styles (color texture style) but the SketchUp Model Tray->style indicates the viewports are Hidden Line Style from the woodworking style collection. Prior to the Reference>Relink these viewports all had been set to Hidden Line style.

I have read a number of posts with issues on Layout styles but failed to see a resolution to something as I have described.

Some initial basic questions:

  1. If a Layout viewport is modified to use a style from a Non SketchUp In Model style collection, should I expect it will be locked and display that style after doing a References->Relink (or Update) of the of that Sketchup file ?

  2. Looking at the screenshot, I was surprised Styles shown under In Model Styles includes the original four SketchUp In model styles plus the two other styles from the woodworking styles collection. Those two styles appear both in the In Model Styles and when I select the woodworking styles collection. Is this correct that once a style that is not one of the original SketchUp In Model styles is used in Layout it shows as In Model when the viewport is selected ?

I would appreciate any help to complete this project.


What happens when you hit the ‘Reset All’ button in the SketchUp model tool pallet? If you change things in LO often when re-linking / updating things don’t all go back to the way you had it in the model…

Thanks for your reply.

I typically fix this issue one Viewport at a time by clicking the “reset” in the styles section of the SketchUp Model pallet. While not shown in my screenshot, in many viewports the Tags are also overridden from the In Model setting. Tags stay unchanged after a Relink , so I prefer to reset only the styles which are incorrect. After the style reset, the list shows a gray highlight of the SketchUp In Model style, than I select the style from my own style collection. This can be tedious for many viewports in a Layout document.

I can understand if I change the size of a component or a camera position in a scene in my SketchUp model that a Relink or Update will change things in Layout. My expectation was choosing a Style (or Tag) in Layout from my own styles collection would not change after a Relink. If this is not the case, I have to reconsider other approaches, like more scene captures and carry more In Model styles in my SketchUp Model to avoid the tedium of resetting every affected Layout viewport.

I do as much as I can in SKP, even if it means more scenes in order to avoid having to mess with LO. The exception is dashed lines and the rare layer over ride.

If any scene properties are modified for the viewport in LayOut (there’s a visible Reset button in the SketchUp Model panel) relinking or updating the SketchUp reference should not change those settings back. I have seen the styles get reset once in a while.i know the developers are aware of this and should hopefully have a fix soon.

Fortunately it doesn’t happen that often for me so I haven’t felt the need to go back to creating more scenes and my SketchUp models almost always have just one style. I choose other styles in LO.

1 Like

Good to know and answers question #1 in my post.

If I bump up a version of my Sketchup file and Layout file, they get renamed and moved into a new folder with the new version number. When the Layout file is first opened I need to relink to the new Sketchup file. Thats when I typically see this issue.

This is an older design where I tried first tried to minimize styles, but didnt get down to just a single default style. Last night I tried a fix where I moved the two styles used only in Layout from my own styles collection back into the SketchUp model. So I now carry 6 styles in the SketchUp model. I am not willing to go back to the old ways of creating a separate scene and style for each layer of a stacked viewport so within Layout there are still viewports where the reset button appears in the SketchUp Model (styles) panel. This seems to be working better running a couple of tests so far. Will look for a fix by the dvelopment team in the future.

I only create one scene from any given camera position in the model except in cases where I need multiple parallel section cuts through the model.

This is a screenshot from a LayOut file I use with some of my students. Both of the viewports come from the same scene. The one on the left uses the sceene directly out of SketchUp with no modifications. The In-Model style has sections turned off so the active section cut is not displayed. The one on the right uses a style with sections turned on.

If we could choose which section cut is active in a viewport, it would make it possible to have many parallel section planes and still use just one scene. Imagine what you could do with that, especially connected with stacked viewports and clipping masks. Something like this is trivial to set up in LO.

Or making what look like stepped section cuts would also be simple.

You know this already but I’ll stick it here anyway. I never modify Camera properties in LayOut. If I do need to modify the camera position I do that in SketchUp. As a reult I never have problems with label leaders pointing off to nowhere or dimension positions getting screwed up.

1 Like

What a unique “office chair”.

You are a dreamer Dave! It would be a great feature so I hope it is not too far off in the future.

WRT to decreased scenes in the SketchUp model, the screenhot I showed was done with another designer who was less comfortable deferring some scene creation until Layout viewports. Capturing many SketchUp scenes was useful during the design process rather than waiting until construction documentation. For some, it helps provide confirmation of certain items all within a self contained file. It may not be the most efficient, but there is a level of comfort after clicking thru the scenes that one can feel ready to move to the next phase. Different people different methods.

Yep. I was only relating what I do.

1 Like

I avoid this by using ‘Save A Copy As…’. My current SKP and LO file is always the one without any appendages, dates, etc. I don’t often need to re-link.


That looks like a clever way to save SU and LO versions while also minimize Document Relink. I’m going to give it a try. Thanks for sharing.

A couple items to update.

First the Layout file using only the 6 In Model SketchUp styles continues to behave with no further problems after many Relinks. I didnt use any styles from my custom collection. Not sure exactly if I can offer a workaround but I did reset and re-select the correct style in every viewport using Layout’s Sketchup Model panel.

Second, I finally tried @DaveR 's approach and converted the SketchUp model to use only a single default style: Shaded with Texture, Section Cuts, Section Fill, and No Section Planes. The Layout file was modified to use the default style and my styles collection plus careful use of tags. It didnt take long and the the Layout file looks good. The document can be Relinked without styles reverting. A very good thing. The number of In Model Styles and scenes both went down to more manageble levels.

The only item I ran into was how to display the Section Planes in the Layout document. I have a thumbnail size viewport with a front and side elevation showing the planes. Below those I display the actual section cuts. Since Layout cant selectively hide individual Section Planes, I did this in the SketchUp Model by making seperate scenes for the front and side elevations and used the outliner to shut off visibility for some Section Planes. That works fine.
The problem I have is since the Default SketchUp style doesnt display Section Planes, those scenes dont convey the purpose of having them in the first place. The section planes are there but not visible unless I toggle them On within Sketchup (but not saved in a scene or the default Style will need to change). The Section Planes will be displayed in Layout using a style from my styles collection.

Is this the best approach for using just a single default style ?

The new scene in SketchUp with the default style that has Section Planes Off:

Section Planes temporarily toggled ON (default style not changed)

Layout Viewport using new SU scene and style from local collection with Section Planes On.

The way I handle that is still with just a single style in the model. I have a style in my collection that has section planes displayed but not section cuts. In the example, below, the left hand viewport for each view uses the style in the model. The right hand viewport uses the style from my plans collection with section planes displayed.

Again, no need for lots of scenes in the model. With two horizontal section cuts in this model I do need a second plan view scene for the second viewport. The five viewports across the bottom, though are created from a single scene in the model.

Thanks so much for helping with the pictures. It looks like I have a solution where a problem doesnt exist. In your examples (2nd row showing plan view and front elevation) you have the section planes displayed, and a gray area, the horizontal or vertical section plane which is parallel to the view. I thought this needed to be suppressed from view, as shown in my last screenshot above.
Turns out no need for that. Actually, everything was already OK, using a style in my collection which displays Section Planes applied to my front and side elevations as shown in the first screenshot. No need for the extra scenes I show above in SketchUp with some of the section planes turned off in outliner.

So far, even though I start to think otherwise, the single default style really is enough. While the SketchUp file size didnt get smaller as I was expecting, to repeat , the real value to this approach is manageability of the design because there are fewer scenes and styles.

I suppose you could suppress it but I don’t see much point. In reality I would most likely use those displayed section planes as references for drawing in section indicators with LO’s tools and text (or use the section indicator from the scrapbook. I would do that for a few different reasons. One would be to have better control over the appearance of those section marking as well as being able to match the font to the one I use for all the other text in the document. And they will just look better, in my opinion. Still, it works as shown and you could leave it at that.

Unless you are using sketchy styles and/or watermark images, styles don’t add a whole lot to the file size.

Exactly this. Anything you can do to make managing your models easier will pay dividends. Fewer styles, fewer scenes, etc.

There is one more item about use of the single style that I wanted to mention, section fill.
In the design above, the default style uses Section Fill On, with a gray fill color. Other times I use TIG’s Section Cut Face and apply a hatching pattern as my poche. In that case, the style will use Section Fill to Off so the SCF hatching is not obscured. If I stick to a model that uses only a section fill, and other models that only use only hatching with SCF, I can still use a single default style in each case (one style has Section Fill On, the other Section Fill Off). So two different default styles but only one is used per SketchUp model.