Sketchup Styles in Layout


I’m trying to use a simple style with a solid fill (no sky, no ground).
This seems to work in Sketchup, but as soon as I cross over to Layout the background colour fill disappears and is replaced with a no fill/white background.

Any ideas?

I have tried different SketchUp/Layout files, as well as different back ground fill colours, but same thing happens each time.

Share your LO file so we can see what you’ve got and how it’s set up.

Are you still using SketchUp 2018 as indicated in your profile?

Well, I think my issue is resolved, I understand how I just don’t understand why!
(I use Sketchup 2022 Pro Subscription).

For ref, it seemed to be a problem specifically with the viewport itself, rather than either the style or the template.

After deleting the viewport saved to the template, and inserting a new one it resolved the issue.
I don’t understand why the old viewport developed this issue, but hey, Problem solved!

Thanks for asking me to share the LO, it indirectly solved the issue!

With the LO file in front of me I could probably have told you why.

23 Layout A3 Visuals Template V01 Test.layout (779.4 KB)

I’ve attached the file with the old viewport.
If you are happy to have a look and find out what is causing it, I’m always happy to learn!

In the LO file you attached the style has been changed from the one you set for the scene. That setting overrides the style in the SketchUp model so changes you make to the style in SketchUp will not carry over to the viewport in LayOut.

You also have the background set to not be displayed.

Resetting the style so that the style from the scene is used and turning on the background yields this:

Note you also show that the camera position has been modified in LO. This also overrides the Camera properties for the scene. That can cause you problems if you add dimensions or labels in a viewport and later reset the camera. It also means that if you change the sene for this viewport (or copy this viewport and change the scene) there’ll be no change in the camera position.

I probably changed over the style when trying to figure it out, but I wasn’t aware of the background toggle box! That was the thing I was missing!

Much appreciated!

1 Like