LayOut crashes when trying to open

Hi there- Yesterday I tried to open LayOut like any other day and it would not open. I tried downloading the installer and reinstalling it with no luck. Obviously restarted my computer and that did nothing. Tried to send a model from sketchup to layout with no luck as well. I’m running macOS Monterey with the new Apple M1 Max Graphics card. Please help I have deadlines I need to make!! :slight_smile:

Hello - i’ve got the exact same problem, except that is stopped working just now. I had opened and was working in layout 2022 fine. I closed a file. Went to open a different file and then it wouldnt open.
Running 12.6 monterey on apple M1. Tried reinstalling etc, the other threads seem to be at windows users with no mac work around. Was there a resolution to the problem?

Me and others are using LayOut 2022 with an M1 Max MacBook Pro. Not seeing a crash, so it may be a document specific issue.

If you see a bugsplat report when starting a new document after restarting LayOut, can you send it in?

If you find that the crash only happens with specific documents, can you send one to us to check?

I initially thought it was file specific, but the program will not open at all with any files, including just a general click to start from apps (not opening a specific file).
Most of my files are contained within google drive, although I’ve also tried with desktop files.

From the initial click, it wont open anything and goes


straight to crash, without bugsplat. Skp files open fine, the issue is contained to layout.

Can’t tell much from that. Maybe @Adam will know what’s happening.

New day here in Aus, and layout is still not opening, tried restarting on the M1 mac.

I have an old mac 2015 laptop which is barely functioning, but ive managed to open files in 2022 sketchup/layout and its opening OK.
There is one file that I think must be corrupt - ive sent two crash reports, #7675 and #7676 in relation to this file, the last one with my email and some details about what was happening. That is the file that I was working on before I closed it to move to a different project and then layout stopped opening all together on the M1 mac. Might be a connection?

Hopefully that assists in solution, using sketchup professionally for architecture work so a bit stumped without layout.
Thanks, Bee.

Other users have reported that turning off “work offline capability” of Google Drive has fixed this issue for them:

We will be investigating this moving forward.

Adam

Thank you for this Adam! Unfortunately, this function is already turned off on my machine.

Yes - mine is also already offline.

What are the next steps to take to resolve this issue, I’m now 3 days behind in work as I use layout professionally for architecture, and clients are starting to have melt downs.
I cant open any of my files in an earlier version, my computer mac is only a year old iMac (24-inch, M1, 2021).
What can be done - do I need to reinstall OS??

You need to use SketchUp 2022 to open that file

You are trying to open it in SketchUp 2021.

If you are a subscription user, you can download this from here
Download All | SketchUp

Remember though that the main problem trying to be solved is that 2022 crashes when trying to open it.

@bee_n50 something unusual about your file is that you are trying to open a temp file, that should not exist while LayOut is not open. It will continue to exist if LayOut has crashed though. Somewhere there is a file named “TopleyPH_20220429_Concept-Documentation.layout”, see if that one opens.

I think that it won’t. Do you know anyone else with LayOut working ok, who could save it as a 2020 file for now?

Thanks for the fast response.

The file isnt a temp file, that’s my filing number system (project 321 in 21, 32121), but I can confirm no other files are opening either.

Unfortunately I’m a lone sketchup user in a landscape of archicad, rhino and revit. It’s likely one of the bigger local firms will have sketchup 22 for concept work, but I’m running 40 projects simultaneously (and frequently have to open older files for reference and minor builder changes) and I think that would be a bit much to ask of another company, none of my close architecture friends work in firms that have updated to 22 (have checked).

What are our next steps to work through this - If this isnt resolved by this week I’m under enough pressure for Christmas deadlines to have to just go and buy a new computer and hope it doesn’t get the same problem, which is ridiculous.

Can I reinstall OS? Delete some files somewhere? Send you the file that I think went corrupt when it stopped working to see if that is some catalyst?

Thank you.

Yes upload to the forum.

https://drive.google.com/drive/folders/10dpFda3hZ2Nchrcuv9dWxZsU_bpwwN5d?usp=sharing

File enclosed. Larger than 16mb due to some large historic images within the file, probably part of the reason for the crash. Sometimes I would keep a seperate layout for historical research, but in this case I didn’t.

That file is completely filled with zeros. You can try zip-compressing the file, and it comes down to 59kb.

Thanks Colin, compressed file noted and for future.

What are the implications of it being filled with zeros?
Ultimately I can re do this project from an earlier version that isn’t crashing so I’m less worried about its content, - but in order to do that I need to get layout 2022 opening. Is it possible this file is corrupting layout, is that even possible? Whats next?

33422_SohoPizza_20221021_Concept-Documentation.layout.zip (57.9 KB)

That the file is completely unusable and unreadable.

It could possibly happen if the file is not saved on a local drive. Cloud or non-local storage has been known to corrupt SU files.

Ok thanks.
Ive now saved on an external hard drive that file and completely deleted it from my desktop and google drive. Ive emptied my rubbish bin, restarted the computer - but still layout will not open.

Whats next.

Try renaming the working directory in this location to something like working_old:
/Users/<username>/Library/Application Support/SketchUp 2022/LayOut/working

And see if that allows you to launch LayOut. We’re still trying to determine what is causing LayOut to crash immediately. It might be that a working file (aka a recovery file) is also corrupted and that’s causing issues when we try to get information about it to display in the welcome window.

Hope that helps,
Adam