Layout Pro 2020 crashes instantly when opened

Hi all -

Can anyone out there help with this problem? I routinely use Layout to produce drawings for contractors, and now I can’t even open the program. I recently updated my operating system to Mac OS Catalina, and updated Sketchup to the most recent version. After a few days of (largely) problem free use - there were a couple of unusual hangs/crashes - I now am completely unable to open Layout. When I click on the Layout icon, I instantly get a bug splat pop-up. So far I have tried some system maintenance with CleanMyMac X, a OS update, and finally removed and reinstalled Sketchup with no change in the result.

Any ideas or suggestions?

Did you reinstall with the latest version of SketchUp?

Hi Mike,

Yep - installed the same version (2020 Pro). I have also downloaded and installed Sketchup 2019 since posting here to see if I could save my current 2020 files as 2019 versions and continue working in Layout 2019 to get my work done. Sadly exactly the same happens - an instant bug splat when trying to open Layout.


I’ve been struggling with this for the past 2 days. Hours on the phone with Sketchup and Apple.

I am getting Apple crash reports relating to Chrome, but I uninstalled Chrome and Sketchup and reinstalled and still the same.

Now I can open layout when double clicking a Layout file directly, but not through the app icon, and when I try to click File>New, it crashes with no Bugsplat.

I’ve ended up creating a new admin user on my Mac and it works fine there. So now I have to migrate all my user data and preferences :frowning:

Apple are blaming sketchup, Sketchup are blaming Apple and I’ve lost hours. I know they’re trying to help, but great to hear I’m not the only one with this problem.

You are so correct, it happens to Windows users also.

@mattclubb -

I’m willing to try anything if it’ll get my work back on track - except spending hours on the phone to ‘customer support’. Can you explain in a little more detail about how you got it to work with a new admin user?

By the way, if we are paying for ‘maintenance and support’, is it acceptable to not receive any response to an email sent requesting help?

Go to User and Groups in System Preferences.
Add a new user to your system, make sure you set it to type: Administrator.
Give the new user a password.
Then log out of MacOS and log in with the new user.
Go through the normal setup stuff, then try running it from there.

Something that would cause the symptom you’re describing is if a recent file you worked on has some serious issues. Either it’s corrupt, or it’s on a drive that is giving errors.

The difference between opening a file direct, or opening LayOut, is the welcome screen. That shows thumbnails of your recent files, and if one of those has problems, LayOut could crash.

One way to test the idea would be to successfully open a file, then open the Welcome to LayOut window from the Help menu. Does LayOut crash?

Hi Colin -

It seems to be the same regardless of how Layout is opened. Whether I try to launch Layout directly from the dock, from a Layout file, or from the ‘Send to Layout’ toolbar icon in any of my Sketchup files, I get the same instant bug splat message. It never gets as far as the welcome screen…

Thanks - its worth a try I guess…

That makes it be different to Matt’s case. Did you submit some bugsplats?

Yes. Quite a few in fact. Would it help if I send another - pasted in here, or attached perhaps?

No, I would just need to figure out how to find the bugsplats. I tried search for your name and what might be in your email, but if you didn’t fill in those fields, tracking them down becomes harder.

I shall generate more bug splats - and include my email (which includes my whole name, Daniel Richards)… I get the same result with every attempt, so the key information should be in there somewhere…

I’ve now sent 3 bug splats generated by different routes in an attempt to open Layout.

Hi Colin -

Did you have time to look at the bugs splats I submitted?

Regards, Daniel.

Got it now. The search used to let me find an email across all products, but this time I had to select LayOut Mac 2020 in particular.

There is mention of get OS language in the report, I’m going to get some of the dev ops guys to take a look.

They will ask, what language packs have you included when installing SketchUp?

There was enough information in the bugsplat to give us something to investigate. At first it seems to be on the lines of misreading your language or region. Doing a test where you set the region in Mac OS to somewhere else would be worth a go.

For anyone coming here with similar symptoms, we found that with the computer being physically in Norway, but the system set to say that it is located in the US, that triggered a problem in LayOut and Style Builder. The thing it triggered will get improved, in case this happens again to someone else. I don’t know if it has happened before now, but no harm in taking care of the combination even if it is unlikely!

So, check if where your system claims your computer is located is the same as where it is actually located.


I’m running into the same issues. I am on the most recent update for Mac OS. I installed the new Sketchup 2020 update, and it lasted 36 hours before I ran into the same issues Daniel’s having. I can’t open a file. I can’t start a new file. I can’t go through the Welcome Screen either. It’s meant that many files are now inaccessible. I read through this thread and checked my system region and language, and both are correct. I’ve sent in a couple bug splats now and am still without a solution or response. Any other thoughts on what this could be?

If you are in SketchUp and seeing problems, that makes it be a different issue. Daniel was getting crashes.

What stops you from going to the welcome screen? Are you able to choose Sign Out from the Help menu? If you can, try that, and sign in again, and show whether you get any errors.