LayOut crashes on opening new page from template

When opening LayOut 2021 for the first time, it crashes choosing a titleblock template. But not always, sometimes after opening a few different templates, sometimes on pressing command+N. It makes it impossible to work in LayOut (or in my case start working, cause i’m new at this) Sketchup 2021 works perfectly. I am a new pro user, only worked occasionally in previous free sketchup version. Working on iMac 5K 2017, 4,2Ghz Intel Core i7 with Radeon Pro 580 8192 Mb graphic card. I don’t think it’s the computer configuration. Any suggestions?

What version is the operating system?

Please correct your profile?

Yes sorry, Mac OS Mojave 10.14.3
Profile adjusted

Is it crashing and giving you Bug Splats? If so, are you sending those in?

Are these native templates that you are opening or your custom templates?

@colin might have some thoughts although it’s still quite early for him so we might need to wait a bit.

Thanks for updating your profile.

Yes I get bug splats. The first few times i sent them in, but got ‘no result’. I tried again right now and got this info. (sorry forgot to add my name to the form).

Crash #10741 contact technical support or visit forum …

I tried re-installing from the .dmg file the seller sent me, after deleting the programme sketchup, layout and style builder from my program folder on my hard drive + emty trash + restarting the computer. No result.
In the folders ‘caches’ I can’t find a file linked to layout (or sketchup), in the folder preferences I found following file ‘net.vectorworks.vectorworks.2020.plist’. I didn’t delete it yet, because I am afraid of losing my downloaded extensions and my own template setup that way.

And answering your question about the template. These are native templates (I just wanted to start working with LayOut after following an online course, so haven’t worked in LayOut before). I was browsing through the templates, opening the A3 landscape of all the available titelblok templates, to see which one I preferred, which one to start from making my own. But it ended there, after opening a few templates it crashed and on reopening LayOut i get a bug slat notice. I tested if it was possible that only 1 template had a bug, because at first it seems that the 'paper templates worked fine and the problem occurred only with the titelblok templates. But after a few tries, it also crashed on typing command+N, or sometimes clicking on the word ‘more templates’ or clicking on the word ‘titelblock’ …

OK. If you sent the splats with something to identify them as coming from you, @colin should be able to look them up when he gets a moment. That splat report will likely give some idea of what is failing in the start up process.

Oké, done. @colin i’ve sent you a splat with name ‘Chantal’ en my e-mail adres linked to this profile. Till later!

I went over the crash logs with a couple of the developers who work on LayOut. What may be happening is that you are picking a template while the welcome screen is still filling in the details of your recent files. That is still something that shouldn’t cause a crash, but at least there is something you can try, to see if it helps.

Get into LayOut, with any template, then choose File, Recent Files, Clear Menu. That will clear out the recent files, but the list will fill back up as you work on various files. You may also see a few recovered files, and some of those may be haunting you. If you are sure that you don’t need those auto save files, you can go into this folder to remove them:

~/Library/Application Support/SketchUp 2021/LayOut/working/

Each of the folders in that folder are LayOut files that were open when LayOut had crashed.

With your nice clean welcome screen, which you may notice lets LayOut open quicker, you can then try different templates, and see if the crashing has gone away. If it has, and if the issue comes back again, try to note which document is now back into the recent files list. See if that file has any issues.

HI Colin, cleared alle recent files (which were only 2) and there were no files to delete in the folder you suggested. Which was not odd, because I haven’t worked in LayOut yet. Brand-new user over here :slight_smile: The only documents I have opened were 2 files I got following a LayOut course. Will see if this will do the trick. I’ll keep you posted. Thanks for the advice.

Hi colin,
Clear all in recent files, didn’t work apparently. Although I cleared all in the menu ‘file’> open recent > clear all. I still get a ‘recovered’ image below ‘recent files’ in the ‘welcome to Layout’ window (the window that opens when i press command+N. So deleted that file in the window, still no change. Deleted the program from my desktop. Looked in folders HD > library >Caches and Preferences, but I found no files, linked to LayOut or sketchup, to delete (This advice came from my hardware dealer, also my Apple IT-guy. Are there files stored on my computer somewhere while installing or working with Skp en LayOut? If yes can you tell me what to look for?) Downloaded the .dmg file again. Installed sketchup 2021 again, still doesn’t work. It opens 1 (native) empty template and when I want to open a second one it crashes, it is impossible for me to work in LayOut like that, I can’t enter the program. Any other idea’s? I don’t know how many files sketchup and layout share, but could there be a problem with uploaded extensions in sketchup? (although it’s not a long list, i only started using extensions from Thomthom and fredo6. I got a message while trying to download the ‘eneroth texture position tools’ that it wasn’t compatible to my version of Skp. So i clicked ‘no’ on the question, would you like to download anyway. But maybe I also clicked yes (not sure anymore), could this be the cause? … Does trimble has anything to do with it? do I need to logout from that to install? Could there be a bug in the .dmg ? … Is the 2021 stable yet? or is it better to install the 2020 version? (and can i open my files in an older version?)

In my last message I said that the recovered files are in this folder:

~/Library/Application Support/SketchUp 2021/LayOut/working/

You can get there by going to Finder, choose Go to Folder… from the Go menu, and paste in the path I gave. Then you will see some folders, and if you are sure you don’t need those recovered file versions, delete the folders, and they will go away from the welcome screen.

One of them may be causing the crashing problem.

Hi Colin, is it possible you didn’t see my first answer to the mail you are referring to? I did go to that folder as you suggested, but there was (and is, just checked again) no folder named ‘sketchup 2021/Layout/working/’ in my ‘application support’ in the ‘library’ folder or in the ‘bibliotheek’ as it is called in Dutch on my computer. Should this map be there, and how? If it only appears when files crash, then it is not strange, I have never worked in LayOut before. And I haven’t got the chance yet to save a document because of all the crashes at startup. So no saved documents= no saved recovered files, I suppose?? (and then I did some extra testing, as I said in my second message to you…) any thoughts from there?

oké wait a second!

It’s important to be looking in ~/Library and not /Library. The working folder would only be in the ~/Library path.

There is a slower way to get rid of those recovery files. For each one that appears in the welcome screen, go ahead and open it. As you do that you may see a choice to ask you if you want to open the recovery file or the original file. Open the original one, and that will delete the recovery one. You could make a minor change to the file, and do a Save, to make sure that the recovery file is bound to be gone. Close that file, then open the next one of the recovery files.

Yes! found them, I was not searching on ‘user’ level. But with you ‘go to’ tip it worked, thanks.

I deleted them, emptied trash folder, restarted, reopened Layout, and by my 4th ‘command+N’ it crashed again. Grrrrr

Let’s see if @trent has ideas. Pretty sure he’s not working today, so I’ll check in with him on Monday.

and as I found the right library, i also found the caches and preferences folders
and deleted the layout files… restarted … opened layout… it still crashes!

oké thanks, i hope we’ll find an answer soon. I cannot keep my client waiting for long. Have a nice weekend. Kind regards,