Lag / delay selecting tools, moving lines after windows update 1903 - 18362.295

SU seems to be very slow and laggy after running a windows update on Monday. Selecting tools takes a couple of seconds (I click M for move and 2 seconds later the move tool icon appears). Same with moving lines; I click on the line, wait for the move tool icon, click on the end of line and it doesn’t move. Also, if I click on control to duplicate, it takes a few seconds. Really frustrating, feels like Im fighting Sketchup.

Anyone else had this or can anyone offer any solutions?

Thanks

Sam

What version of SketchUp? Please complete your profile.

There have been a number of reports of issues caused by this Windows update. Not just with SketchUp. Might not hurt to roll back Windows to before the update.

Hi @DaveR,
I’ve updated my profile now so graphics card info and SU version should be visible.
I did’t realise there was a time limit on rolling back to a previous version but am only just at a point with projects where I can uninstall and have discovered that Im past the 10 day cut off.
That being the case, what can I do as SU and LO are both very laggy with delays on tool selection, actions and deletion. In LO when I hit delete I can see each item disappearing at a rate of just over 1 per second, so if its a busy page it can take a while.
Any help appreciated.
Thanks
Sam

This seems the same as what I am still experiencing as I explained in this post…

I’ve just now tried to delete about 40 or so elements in LO and it took 30 seconds to completely delete!

@samyell and @paul.mcalenan

1. Check to be sure the update did not reset any of your graphics settings.
Be sure SketchUp is using your high performance GPU.

2. Check to make sure the update did not set Windows to allow it to turn off your pointing device to save power.

3. You can try the slow selection patch … close any and all open SketchUp applications first.
from Older Release Notes: 2018, section Miscellaneous, first bullet point

Added a preference to workaround an issue in which selection could be very slow on some Win 10 systems. To set this preference open Command Prompt and enter:

"C:\Program Files\SketchUp\SketchUp 2018\jsonpatcheditor" Preferences WorkaroundDrawXorRectUseGLFlushNotFlushDraw b true

Note: If you installed SketchUp in a non-default location you will have to update the location above.

The jsonpatcheditor.exe is still available in the 2019 program folder. (Adjust pathname as needed.)

Checked 1. and 2. :white_check_mark:

  1. I think I did this. Ran cmd as admin. Navigated to …/sketchup 2019 and entered jsonpatcheditor Preferences WorkaroundDrawXorRectUseGLFlushNotFlushDraw b true at the cmd prompt. There was no confirmation that the command ran successfully :thinking:

Anyway I saved a few LO files as 2018 and opened then in LO 2018 and no lag :grinning: The multiple deletes happened in a second or two and not half a minute or in the case of one file causing a crash.

If LO 2018 is working with my Windows 10 then there’s something up with LO 2019? At least on my system :cry:

Hi @DanRathbun,
How do I check steps 1 and 2? I’ve run the jsonpatcheditor.exe and will have to wait till next week which I’m back to working on live projects to see how SU and LO perform.
Thanks
Sam

  1. Check in Nvidia Control Panel: via right-click on desktop
    Verify in SketchUp: Window > Preferences > OpenGL > Graphics Card Details
    If it got set to use the Intel integrated GPU you’d see Intel as the vendor, etc.
  • Whilst there, realize that very high anti-aliasing an maximum texture sizes can slow down SketchUp modeling. (You can always set these higher for presentation and restart SketchUp.)
  1. Right-click Start button on taskbar (or WindowsButton+X) > choose Device Manager from the “Win+X” menu
    • If your mouse is bluetooth, then check the Bluetooth receiver …

… I just noticed mine is checked … ( so I unchecked because if it sleeps I need it to awake when I move the mouse.)

If you have a wired mouse the “save power” option may be enabled (clickable).

Hi Dan,

I followed through your instructions and the problem now seems to have gone. Im not sure which part resolved it as I did all of them in the end. I also I went into the Nvidia control panel and reset to default.

Thanks as always for you advise - much appreciated!

1 Like

So, the issue came back. I have now full uninstalled and reinstalled as it was totally unworkable having a 3-5 second delay when selecting tools. Weirdly, the issue only seemed to be present when I had one of the pallets open (entity info, components etc). When all the pallets were closed the issue wasn’t there? Very odd but hoping this has re-set everything - will post back any updates.

Thanks again @DanRathbun for you advise - I learnt some new stuff which is always good.

2 Likes

After reinstalling it transpires that there was something in my template file that must have been the culprit - have now rebuilt my template and the problem seems to have gone…

2 Likes

If you have some of the inspector panels set to display thumbnail images (instead of text names) the rebuilding of thumbnails has been known to slow things (but usually only during the startup cycle or when you change folders.)

However, the Ouliner panel is known to cause delay especially if selecting complex group or component instance with many sublevels. It is recommended to have it closed whilst opening model files.
I myself have the Outliner in it’s own tray (I named it “TREE”) and then have this tray autohidden into the left margin so it only slides out into view when I hover the cursor over it’s tab. When a tray is in autohide mode, moving the cursor out of it will make is slide back out of view.

Good news. @Katya hear this? Might be on to something.

1 Like

Thanks Dan,
Yeah, I’ve had trouble with lag when outliner is open so always have that closed - like your autohide idea, I’ll try that out next week. This time around (pre-reinstall / template rebuild) the issue only went away when I closed all the pallets. Annoyingly, I didn’t test the issue on another standard template (one that ships with SU rather than one that I’ve created) so not sure what it was that was in my file that was causing the problem - still, glad its resolved and I think I’ve also sorted another LONG standing issue from this thread in the process but need to run some further tests. Thanks again for your help on this :+1:

1 Like