Issues getting started with Trimble Creator

I’m having real trouble finding a simple enough example to show me how to get started with creating a relatively simple test Live Component.

I’m aiming for a component that will draw wooden shelving, with parameters for overall width, height and depth, and later additional ones such as number of shelves, shelf inset towards the back, plinth height etc.

But to get there, I need first to figure out how to draw a rectangular solid with parameter inputs for width, depth and height - to form the first side of the shelving.

Then do it again to create and place the shelves, plinth, and second side, and perhaps draw a back.

I see one very complicated example of steel shelving with square tube frame and wooden texture shelves. It’s too complicated to get my head round all at once.

At the other end, too simple, is a cubical box with only one input, size - using Uniform Scale.

What’s the simplest way (or an existing simple example) of creating a three parameter rectangular solid with width, depth and height parameters?

I can set up a node of type number, outputting a number.

But when I try to connect it to a ‘box’ primitive I can’t see how to connect it separately for each dimension - if I drag from the output node of the parameter width to the box node, it won’t connect except to Uniform Scale.

Do I need separate steps to first create a rectangle with width and depth parameters and then some version of pushpull to give it height? If so, how?

If not, how else?

And is Creator supposed to work on iPad? When I tried, yesterday, every time I create a node and click on the menu bars on the right of the text box that pops up, the node just closes.

I’m trying again on a desktop today, whiere click on the menu bars gives you options for the type of node. But I’m getting stuck on this issue of connecting a parameter separately to each dimension of a box.

Could someone please point me to a suitable existing component on which to start to learn how to connect nodes to do what I want to?

Have you filled tried the tutorial built into? The little mortar board hat in the top right of the screen

Yes, I’ve been through all of those, thanks.

I’ll look again, but I don’t remember seeing an example of what I’m looking for.

I’ve made a little box example for you here, no doubt there are other ways to do it, but maybe that will help

https://creator.trimble.com/graph?assetURI=whp:9f93f798-3757-4f1d-835a-1e1c6e37244c

2 Likes

Thank you. About to go out for the evening but will look at it as soon as I can.

1 Like

I have put together a few videos in this playlist:

3 Likes

Hi John,

The cubicle box has a few extra inputs that you can inspect by clicking the data input stub. There is a “scale” input that you can use to drive the scale with a vector.

These two gifs show how you can take a number, convert it to a vector, and drive the scale of the box accordingly:

  1. Create “xyz to vector” to convert the number value to vector component ‘x’:
    https://i.gyazo.com/ebdaa99a72fc4359fd474f3b7ce71bb9.gif

  2. Set vector values (other than the connected value to ‘1’), connect to box scale input:
    https://i.gyazo.com/f9eeeec9456efadbb107306415c80dd4.gif

I have to say, iPad is not in a good place at the moment (it is still largely untested, we are still waiting on our test device!). If iPad is your only option, I would recommend waiting for a bit until we support it better.

Hello
Here is a small graph with 5 methods to create a box.
Each example uses more or less nodes, and allows understanding the nodes:

  • Mathematical operation (addition, subtraction, division)
  • XYZ to vector
  • smart size
  • collect
  • rectangle,
  • box,
  • triangle 2d path,
  • copy,
  • group,
  • align,
  • extruded mesh,
  • extrude curve,
  • set color

Hope this helps you!

Update graph with 8 ways to make a box
https://creator.trimble.com/graph?viewLayout=horizontalSplit&assetURI=whp:03e7d23d-f98d-4020-b2ef-a78484194d1d

All roads lead to Rome

1 Like

Fortunately, it isn’t my only option, but I had it conveniently to hand when I couldn’t sleep last night and wanted to try Creator.

I’ll try again on my iMac desktop, but not tonight.

Thank you. Haven’t time to look tonight but it sounds extremely helpful.

Just resuming trying out Creator. And trying to teach myself step by step how to create a set of shelves as a Live Component. Hope that finding answers to my blunders or misunderstandings may help others just starting out.

@simjoubert your examples are really helpful. Thank you so much.

1 Create a parameterised box
I’ve now been able to create a parameterised box in two ways:

  • with three separate number inputs for width, depth and height
  • with one vector number input, with three fields.

Just a Value node or Vector node plugged into a Box node.

2 Move the box Origin from centroid to bottom left
Next challenge: how to move the origin from centre to bottom left.

I think I need to use an Align node. You have one in an example, set as follows:

With x, y and z align all set to min I’d have expected the origin of the box to be at bottom left, but it isn’t.
It’s apparently still centred in all directions,
image
image

When I move away from that Creator window and back again, I suddenly find the min and max options are indeed now working. Not sure why.

Repeat in my own graph - that works.

So that’s part 1 of my project working.

3 Make a shelf
Next step - try to create a shelf in the same graph.

That’s just a repeat - but now I can only see either my upright, or my shelf by clicking on their respective box nodes, but not both at once.

4 Show both objects at once
A Group node should do that, I guess. Yes it does.

Well, almost. It doesn’t keep the shelf as a separate component, but merges it like an Outer Shell in SU.


image

How to keep the upright and shelf element separate, as in SU components? Maybe Collect does it?

No, appearance is just the same as the Group node produces. What’s the difference between Group and Collect? Is there a list anywhere of all the node types, their purpose, and their parameters and meaning of the parameters?

So that’s an unsolved problem for tonight

5. Move the one shelf up
Try shifting the shelf higher up the upright.

No joy. Typing values in either z value or z offset in the Align node Inputs list makes no difference to the shelf position.

Try saving the project, refresh the browser page, and try again. Twice.

Still won’t work. Bug? Is Align not the node to do this with?

Have to stop for tonight.

Here’s my very simple starting stages - one upright, one shelf, and no way to shift position of the shelf.
https://creator.trimble.com/graph?assetURI=whp:d98ea178-9bf7-46c7-88fc-efeb56718e80&viewLayout=horizontalSpli

PS. One of @simjoubert’s other examples uses an Align node, and that does move the object as I’d expect when I type in different z values or z offsets.

Why doesn’t mine, and why did one of his only start to work when I moved away from and back to the browser window in Creator?

1 Like

Hello,

the Align node has different parameters.
The joining order at the input of this node matters. The first primitive serves as a reference for the following ones.
Objects can be aligned relative to the first object: on its min, Max, centroid. Or on a value.

The first object can be included in the alignment, remain in its position or be deleted.

The nide group created almost like in SketchUp. The collect node gathers without grouping as a selection will in SketchUp.

I hope this information will help you move forward.

1 Like

Many thanks. That clarifies things somewhat.

I’ll experiment some more to see if I can get the shelf to move up, and to the right by the thickness of the upright. Last night I couldn’t get it to move at all using values in the x or y value or offset fields.

I may not have remembered to select ‘include in the alignment’.

What’s the difference between value and offset?

I’m just not ‘getting it’. And as well as re-reading the tutorials under the Intro tab, I’ve now also read all the ones under Patterns and Builds. I’m still not finding anything to get me past this block in my understanding.

I have tried setting the Align parameters of the shelf as shown below, with an x value and x offset of 20 in (it’s only 36 in long, so that should shift it more than half its length from either value, let alone both), and it makes no difference to its position.

Its origin has been moved to the bottom left hand corner using the align target - min setting for all three axes, but whatever I type in either offset or value for any axis, it makes no difference to the position of the object.

What am I not understanding or doing wrong?

For the moment, I feel firmly stuck. WHY are the value and offset field values making no difference? I think that they should, but they aren’t. A bug? Feature not implemented? It’s designed to behave this way? If so, what DO these values do?

For the moment anyway, I’m baffled. About to go out for the afternoon, so I have to stop now.

1 Like

Hi John,

I’ll run over a few things you’ve mentioned (Simon has explained things brilliantly, but I’ll add a few more notes).

  1. Group vs Collect:

First off there are three “grouping” nodes (Group, Collect, and Combine meshes), I’ll explain them here,
A group node as Simon has covered, will function similarly to SketchUp where multiple geometries/primitives are ‘grouped’ together to act as one geometry/primitive. This can be undone further down the flow of the graph with an ungroup node.
A Collect node will just bring all geometries/primitives into one node. Other than that, nothing is done to them.
A Combine meshes node will combine all geometries/primitives into one. Unlike the group node, this cannot be undone as they are now considered a singular mesh.

  1. The algin node

You’ve got the align node set up properly, the issue actually seems to stem from the box node before it as you’ve got the uniform scale input set to 1000. Meaning the scale of the box is 1000x larger than you probably want it and the amount you’re aligning the box is very small in comparison.
1000 will be the default value (as mm will be the default graph unit therefore equals 1m), but maybe we need to tweak this.

  1. Value and offset

In this case, value and offset won’t make much of a difference - but semantically, the can be good to define.
value will be the initial algin amount, then it will be offset by the offset amount.

That’s really helpful, both in general outlining the different ways of combining nodes and geometry, and in particular in noting the uniform scale 1000 applied to the box, which I had not noticed.

I wonder either how I put it there, or (if I didn’t - and I certainly didn’t do it deliberately) why it is th default? To get a 1m cube box by default? That sort of makes sense, but it would be helpful if the default took notice of the units - mm or inches - in the model.

I’m working in inches, not mm, and that would explain why my value and offset amounts were making no visible difference in relation to the huge scale of the box.

I still don’t fully understand the difference between value and offset, but perhaps if I play around with different numbers, I may work it out. At the moment, I’m assuming they just add together to shift the position of the geometry relative to the node origin by the total of value + offset.

1 Like

But now I’m asking myself - What size will my live component actually be drawn if I import it into SketchUp.

If the box is scaled to 1 rather than 1000, will my 7/8" (0.875") thick boards (nominal 1" softwood in UK), import as 0.875mm in ‘real life’?

Sadly, I find that they do - when imported into SU with units set in fractional inches with precision 1/64", the thickness is approximately 1/32".

So using input parameters explicitly stating inch values just doesn’t (yet) work.

Parameter values input:
image

The upright is telling me the units are (in) - but I can’t now see where I set that, and it isn’t showing for the shelf units, though the component is actually using mm.

I’m now completely puzzled about where the (in) text in the upright’s parameters is coming from, and I can’t see why it is showing there, but not in the shelf parameters.

I remember there was a dropdown somewhere that offered me a choice of units - at least mm, cm, m, inches, and feet, from memory, but where was it? I didn’t type it in the node description text, and it isn’t apparent anywhere in the options for the node.

Finally, I find it - R-click on a blank section of the graph, and up pops the option list.

But it isn’t actually working. And when I re-set the Graph units to Inch, the app crashes and I get a blanks screen. However, fortunately, refreshing the window gets my graph and model back.

I’m still having trouble with units. I change the units to cm, refresh the screen, and the parameter list is still showing (in) after the inputs for the upright’s dimensions.

Furthermore, although I have clicked on cm, the popup is still highlighting mm in blue as shown in the image above.

Looks as if the units are permanently stuck on mm, despite what the parameter list says, and whatever selection I make in the Graph length units popup.

Maybe you only get one shot at choosing the units, right at the beginning of a new graph, and can’t reset it afterwards?

Result viewed in Creator. Visually, it’s done an Outer Shell and there’s no dividing line between upright and shelf.

When loaded in web or desktop SU the two groups now are clearly separated. (and they ARE groups, not components. Wonder what happens when you copy a node, then? Will try later)

Hmmm. Looks as if I should abandon trying to use inch units - it just isn’t working yet.

I’ll start a new model and see if I can get on better using mm throughout.

Typically with the align node we are aligning one geometry/primitive to the bounds of another, in this case - setting an offset is useful if you don’t want the two geometries to be right next to each other. In your case, we are just aligning to a value. So think of the value as the place it is aligning to, and the offset is an additional distance from that.

As for scale and units:

Correct, 1000 is the default input for that value, so that is how it was when you made the box node.

The unit for a scale isn’t necessarily one that is tied with a particular unit, rather a ratio. So if you had a box of 50" and scaled it by 0.5, it would scale it to 25". However a scale of 1 in regards to the box node will refer to a single unit of whatever unit the graph is currently in (note that changing the graph units is currently bugged, but will be fixed in the next release). So a uniform scale 1 will be 1mm if the graph unit is set to mm.

Also note that there is a difference between a graph unit and a parameter unit. Parameter “units” (one set when right-clicking a parameterized node) are, in essence, visual - not functional. A graph that is authored in a particular graph unit (when right-clicking the background) will be automatically converted to whatever unit the SketchUp file is in when used as a Live Component.

i.e. if the graph was authored in mm, but the SketchUp file is in inches, SketchUp will convert the Live Component to inches.

Changing a graph unit halfway through authoring a graph will have no affect on the model, other than correctly sizing the computed output/Live Component (as I mentioned before it is currently bugged, but will be fixed). So don’t worry about continuing on with your current graph, as you will be able to set the correct unit once it has been fixed.

As for the “dividing line” between primitives, the current 3D viewer in Creator admittedly isn’t so great at rendering distinct unwelded vertices at the moment, but you can be sure they are there.

1 Like

Thanks. That is helpful again.

Added copy nodes and grouped things, and my first prototype shelf unit will now draw. Hooray!

I’m interested to note that in contrast with SU, the number of copies includes the original. My first attempt to Copy the upright gave me nothing - I entered 1 copy, but have to use 2 to get the second one. Another inconsistency between Creator and SU.

Enough for tonight, but I now have to re-do the parameters, rather than input separate calculated values for each individual align function.

Intending to set parameters for, to start with:

  • overall width, depth and height (x, y, z)
  • number of shelves
  • upright thickness
  • shelf thickness
  • shelf front inset
  • bottom shelf raised by

Maybe later:

  • shelf back inset
  • top shelf lowered by
  • draw back?
  • draw plinth?
  • plinth inset

In addition to Copy nodes, I’ll have to explore calculation nodes to do arithmetic to calculate for example shelf width (overall width less 2 x upright thickness), shelf vertical copy interval and others.

Well, I’ve finally got where I wanted to get to for a starting working Live Component to create shelves or frames.

It could probably do with a bit more refinement, but it’s working well enough in metric (mm only) to be useful for the purposes I had in mind.

With different parameters it can also create frames.

And here’s a link to the Live Component in Trimble Creator
https://creator.trimble.com/graph?assetURI=whp:a6fbe96a-3755-41e9-b6a4-ebd317dc63e5&layout=left

Graph

Experts in Live Components, please comment on ways in which I could simplify or improve the graph - this is the first complete and potentially usable one I’ve been able to create. The learning process, and help people have given, have both been enjoyable, and I thank those who have contributed to my learning, and realisation of my original idea for this component.

More difficult than I had hoped, but I think I’ve now got the hang of it much better.

I still tripped up (again) over the default ‘box’ having a uniform scale of 1000 when I got to trying to copy the upright and shelves. It would be more consistent if the box size is always just 1 unit - even if the unit is mm.

When the Unit selection is working properly, I’ll try again with inches as the unit.

1 Like