Inserting dwg in Model Space vs Paper Space & missing parts

Hello All.
Just to get it out there, I have skimmed through the Import dwg posts. I didn’t see an answer.

I am building a set of plans and want to insert some details from Simpson Strong-Tie. I downloaded the 2D dwg file from their website. I have tried several ways to get the dwg file into my Layout page.

Nothing happens when I attempt to insert the dwg and select “Paper Space” when the option box pops up.

When I select “Model Space” the dwg file opens but it is missing parts and some of the arrows are oversized.

I am able to alter the file and rebuild it but I must be missing something because I am unable to just import a dwg CAD file and add that page to my plan set or insert a cad detail and not lose parts of it.

I have also imported the dwg into SU and it also loses parts and comes in huge.

AutoCad Web App - Paper Space

AutoCad Web App - Model

Insert dwg Paper Space

Insert dwg Model Space

Rebuilt dwg

SketchUp dwg Import

The SketchUp DWG importer doesn’t support text or dimensions so that is why you are not seeing them.

Check your import units in the Import Options.
Checking your units also applies to importing to LayOut. In the first screen, did you check that the imported items are not displayed white?
Can you post the DWG?

1 Like

F_SDWC_2DO_Cad_MULT_Instld_Detail-Sheet.dwg (7.5 MB)

The file doesn’t appear to be coming in as white. I laid down a gray layer and attempted to insert the dwg in Paper Space in a layer above the gray background and wasn’t able to see any insert appear.

I also tried to drag-select the area to see if I could highlight anything that I can’ see.

so what’s your intention: is it getting a 2D dwg into Layout?

Not sure it helps, but Simpson has their entire library in SU.


Hi all, when we insert a dwg the file will come in at full scale then is scaled down to fit to the page and placed into a Scaled Drawing in LO. In this case even though the dwg file shows that there is a PS, the user did not assign a scale to the Paper Space and LO needs a scale to import the PS entities. The Model space scale is 1:1 (good) so LO will then scale the info down to fit to the page. When this occurs, some entities (like arrow heads because this is a defined dimscale in Acad) do not get scaled down as the should.

To fix this, select the imported dwg file (single click) then from the Shape Style dialog, select a scale for the Start Arrow:

Hope this helps



also, fyi (you may know this) you can then change the scale of imported dwg from the Scaled Drawing dialog.

1 Like

I appreciate everyone’s input. I am getting a better understanding of the workflow of dwg, SU & LO.

Is there a reason that the Text and Numbers are altered when inserting the dwg into LO?

I’ve gone through picking different Text Settings to see if the text will pop back to the original size, font, and placement but haven’t been able to find the correct setting. I can obviously manually alter them but I am trying to find the best way to use the dwg in LO.

Auto CAD


The texts in your screenshot seem to use AutoCad traditional single stroke SHX fonts. They aren’t supported in other applications and are replaced with Windows fonts.

That makes sense.
Thank you.

Do you have any idea why the upper right section on the CAD drawing isn’t coming through when I insert it into LO?



I wonder if it is an embedded raster image like the Simpson logos in your earlier screenshots.

It seems to be on a different layer in AutoCAD.

I am new to AutoCAD so I am researching Layers and how that may affect what gets transferred when inserted in LO.

The same dwg file doesn’t produce the same product in SU that it does in AutoCAD Web.

I’ll let you know when I find out why.