Import DWG at Correct Scale

import

#1

When I import a floor plan from DWG Viewer, the dimensions showing in sketchup are outrageously different from the DWG file.
For example a simple 5235.00mm in DWG becomes 1578313.00mm in sketchup
What is wrong here?


#2

Look under the Import Options button. Set the correct scale.


Incorrect Sizing, but with proper markup
#3

Hi Geo

You are a great help!!Thanks!!


#4

“Scale” is not a good wording in this context, a unit is something different.


#5

You can also change your units in AutoCAD and skip the options step when uploading to SketchUp.


#6

No. The SketchUp importer loads DWG files using only the unit specified in the Import Options dialog. Thankfully, as I often meet AutoCad files with a wrong Measurement and Insunit values.


#7

Just imported a DWG (AutoCAD units set to “Architectural”) and changed the SU Import option to meters and it came in as the correct dimension in feet…


#8

Thanks for all your input.


#9

in AC coordinates of geometry is in general saved without unit, i.e. is dimensionless. Therefore the resulting size in the importing application (here SU) depends on the unit used for the import.

Some ‘intelligent’ DXF/DWG importers are trying to guess the unit by the appropriate dimension setting saved in the header of the DXF/DWG… which may work but must not.


#10

As does the importer in LayOut, too. There are so many DWG files that have the wrong unit settings (usually metric files that have been started with the standard imperial template) that I would really appreciate the option to set the import unit “manually”.


closed #11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.