Incorrect Sizing, but with proper markup



I have a sketchup file that I apparently made in inches, but it is marked up as “mm.” Is there an easy way to scale these units down to the correct measurements? Or do I need to re-draw everything?

File enclosed:
Control Panel.skp (188.3 KB)


You can change the units in Window>Model Info>Units. If you want dimensions to fall on easy imperial dimensions you will need to do a little more. Maybe not totally redrawing but you will have to see.

On my phone now so I can’t look at the file.


It appears that isn’t actually the issue after all. For some reason the DWG viewer is trying to guess inches instead of mm. The problem is, it’s multiple different viewers I’ve tried, which is in line with the forum post here: Forum Post

I tried finding a specific export function as mentioned in that post, but there is nothing I can see in Sketchup Make 2017.


Do you mean for exporting DWG from SketchUp? That’s a pro-only feature.


Well, I did it somehow?

For whatever reason though it opens up fine in another 3rd party app, but not Autodesk. It assumes it’s inches when I open it in Autodesk.

Edit: WRONG ABOVE, 3rd party app does NOT WORK and Autodesk shows mm.


Problem continues to happen, and now it’s acting the same everywhere else but in Sketchup Make 2017…

Here’s the item in Sketchup:

Here it is in AutoCAD

Notice it’s in mm too…

Other 3rd party reader “DWGSee Pro 2018” also shows the same error:

Here is the .dwg file
Control Panel DWG FILE.dwg (100.1 KB)

And the .skp file:
Control Panel.skp (195.7 KB)


What 3rd party app are you using to get a DWG from your SketchUp file?


“DWGSee Pro 2018” With screenshot shown above.

I fixed the problem I had to export as an AutoCAD file and then I had to select only “edges” as an object type.

closed #9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.