Importing external .dwg files - scales always wrong

I am trying to import a .dwg topographical file so I have a terrain layer. When I import the file, I end up with ridiculous measurements for existing buildings = 128km long shed for example. The file was produced around 2006, so its probably done in quite an old version of Autocad.

I’ve read threads on other peoples problems with this, and I know the solution is to set the units correctly on the import. But how do you know what units to use? I can’t believe its just trial and error. I don’t have Autocad, so can’t view the file or its attributes. I’ve tried most of the metric options, and they all give incorrect results.

I have also tried the option of scaling the imported terrain by applying a known measured length with the measuring tool - but it doesn’t work. I get a message saying imported files can’t be scaled.

I’ve finally tried to use geo location data from Sketchup, but the resolution is far too low to be of any use.

Does anyone have any suggestions on what to try next?

Before you import the file, click the Options button and choose the right scale to match the .dwg file.

Other users who have problems with things coming in at the wrong size are failing to set the scale correctly.

Sorry maybe not clear enough in my question. That’s exactly what I’ve tried - it doesn’t work with any of the units that I’ve tried, and I’ve tried the metric ones. Can’t imagine any UK surveyor would be using anything other than metric in 2007. How do I find out what units the file has used??

Ask the person who created the file?

If you know what some specific distance in the .dwg is supposed to be you can open the component after importing it and measure between the points with the Tape Measure. Then type in what the dimension should be and hit Enter.

There are several installable or online free viewers for AutoCad DWG format files including TrueView from AutoCad itself. That might help you to view the original file, and determine the units.

And as Dave says, so long as you know ANY ONE real length in the DWG file, after import you can use the Tape Measure tool to rescale the whole import.

As I tried to explain in my first post, I tried scaling it with the tape measure tool, but I got an error message saying objects created externally can’t be scaled.

As I wrote:

With the component open for editing it can be scaled as I show in my previous post.

Thanks Dave, I’ll have another go at scaling, but what you’ve posted looks like what I did - except that it worked when you did it.

Because I opened the component for editing.

If you are expecting the shed to be ~128m long but it’s importing at ~128km long there’s a factor of x1000 somewhere…
So instead of importing in m try another unit - say mm ?
Then the dimension will be correct ??

In the UK surveyors usually use m but most other related professionals use mm
So perhaps the survey was changed to mm before you got it ??

If you import it with the correct options there should be no need to re-scale it after importing ???

Well its now working and I don’t know why. It had been 2.5 and various orders of magnitude out. When I started to retry the import to have another go at scaling, I tried measuring again, and found it was suddenly 10**6 out, which made it a lot clearer. I changed the units of my drawing and the import .dwg to mm, and its now correct. But I still can’t get scaling to work on it.

Thanks for all the suggestions and great how to video.

DaveR - thanks, I don’t know if I’m being stupid, but I think that’s what I’m doing. I’ll try to scale it again later, even though the import has now worked.