Scale dwg imported file

No way to scale my imported dwg file as a component (I don’t want to explode it).
When I’m asked if I want to scale the model I answer “yes” but nothing changes, and the ancient dimension remains.
Thank you

Can you share the .skp file?

How are you trying to scale it? Are you using the Tape Measure tool? If so, open the component for editing first.

Why do you need to scale it? Have you set the correct import unit (behind the Options button) prior to importing? The default is Feet, but it should be set to the unit used in the DWG.

1 Like

Ok. The unit prior to importing was feet (I did not realised). I’ve changed to meters and has worked!!

What’s the better: change all the elements to layer 0 in Autocad prior to importing or delete the non zero layers in Sketchup and converse all their elements to layer zero elements once CAD file is imported?
Thank you!!