Re scaling a dwg file using tape measure tool

Hello everyone,

After importing my dwg file and re scaling using the tape measure, sketch up asks and i confirmed to rescale whole model but only the component I rescaled is correctly changed and the others are changed but not correct. Sometimes its 3cm off and sometimes 3metres off (incorrect).

I tried changing the display preference and units (in meters its also incorrect). I tried selecting all and just selecting one component whilst measuring, I also tried exploding first and then also without exploding. Within a group and also then not within a group. And in all of these cases the measurements dont match the actual floor plan.

please help!!

thankyou :slightly_smiling_face:

You should go into the context of the component (edit component) first and then use the tape measure tool to scale it. While in the context of the component, the scaling will only affect the geometry residing in the component.

Here is a video I posted in this forum earlier addressing how to scale an object.

Cheers
CD

Thanks alot for the quick reply! I tried import dwg, (leave as component- did not explode it) then edit component, tape measure change scale , confirm. But still just this component is correct and my other components are off from a range of 2207,0 to 2189 and 285 to 277cm. I know in the video it is sometimes a few cm off but the range i have seems that it could be problematic?

any other ideas :)??

What are the other components? Are they from other .dwg files? If you share the SKP file, it would be easier to give exact guidance.

Are all the components in the file the wrong size?

Hi dave, Thanks for the response. No its all one dwg file. Yes everything is mostly 10, 7 or 30 cm out of accuracy?

I tried trying to re scale as a component and also through edit component and neither of these next tries worked

Can you share the SKP file so we can help you?

no sorry! i wish i could but its confidential.

Can you share the dwg?

That’s why. You edited the component. It’s only going to affect what’s inside the component. If you do the operation outside of the component, the whole drawing will re-scale.

Having a range of off-scale values… You cannot fix them all in one shot. There is something wrong with the import. Maybe this imported file is “paper space” (sorry I don’t use ACAD so don’t know how this would have happened).

Hi Chris
So i have just chabged my edges style to be coloured by the axes and now i can see the majority or the 2d component does not appear to be om the green or red axes. (see image) could this be the reason why my scaling using the measuring tool is inaccurate?

when i try to adjust the componant onto the axes it appears to be infact on the green axes.

I dont believe it should have any impact on using the tape measure tool to scale.

I know you can not share the dwg … but… Can you copy and past a few of the components into another sketchup file and share that skp with us so we can take a look? If you can, be sure to let us know what the measurements for each component should be.

CD

When importing DWG files, the most important thing is to check in the import options (options button is on the import dialog) that the import unit used is the same that the DWG uses. Then no rescaling is needed. Scaling is always prone to user errors.

1 Like

thanks alot for such a quick response! I have now used the dwg as a basis and am reconfiguring with regards to the written measurements i have in another doc.

thanks for the advice