Scale Problem when Importing .dwg to SU


#1

Hi all. I imported a .dwg file to SU 2018 Pro; followed info in SketchU tutorials, selected “model units” from Options menu when importing; tried selecting “feet” instead; still can’t scale the drawing in SU. Scale is wildly different.

Short of asking the Architect who sent the .dwg file to prepare it for SU, is there anything else I should try? File attached.TEST 1.skp (1.1 MB)

Many thanks


#2

To get a DWG to import the right size, the units you select from the Import Options dialog must be same as the units that were used inside the DWG file, irrespective of what units you use to model in Sketchup. Without seeing the actual DWG file it is impossible to say more. Looking at your SKP file it seems to me most likely that your architect has used Millimeters and you have imported in Inches.

You can also scale the whole thing with the Tape Measure tool: Use it to click on two points in the plan that you know what the distance should be, immediately type the desired distance, and click OK in the “Resize the whole model?” dialog that appears.


#3

Thanks Anssi! I will try that. I did select “model units” from the pull down menu but that didn’t work. Maybe this will. Appreciate your reply!


#4

Hi again. I tried it but can’t make it work. I saved it as a new model; entered the group, used the tape measure tool to measure a door I knew was 28", e.g., clicked tape tool on one side of the door opening, then clicked it again on the other side of the door opening, then typed in 28", hit enter, but no dialog appears asking “Resize the whole model?” All it does is place a dashed line at 28" from the first dashed tape tool line.

I’ve tried it about 13 times using different variations - e.g. typing 28" before clicking the tape measure tool on the other side of the door opening, right-clicking before and after clicking the tape on the other side of the door to see if that would give me the option to resize entire model, retrying the same thing over and over (definition of insanity) but no luck.

I’ve searched the forums for “resize whole model” and from what I’ve read it appears I’m doing it right but obviously I’m missing something! I’ve searched the forums for how to change the units from metric to imperial when importing but don’t understand what the replies say (language is too technical for me).

I’ve also tried using the scale tool to bring the entire group of several drawings down to what is very close to the right size but it’s still a few inches off (the 28" door scales at 32+") and some of the other dimensions appear off what they should be so maybe it didn’t scale down proportionately. Any additional advice would be most appreciated.


#5

The dashed line appears when you select on a lined refrence. Make sure your selecting a point and/or remove the plus sign next to the tape measure tool with the Alt/Ctrl tab

Hope this helps


#6

Hi Lulwa. Thanks for taking the time to respond. Unfortunately, I can’t interpret what you’re suggesting. Sorry! Even though I’ve been using SU for 6 years, I don’t have enough of a technical background to understand. Appreciate your time, nevertheless.


#7

I think what Lulwa was telling you was to make sure you change the tape tool mode to not create guide lines. Press and release the control key and you should see the ‘+’ sign disappear from the tape tool’s mouse cursor. Now you can type the new size and press return. SketchUp will ask you if you want to resize the model. Click the “Yes” button.

If the model has been exported as mm and imported as inches, another way to do fix this would be to measure any size with the tape tool, press control to remove the ‘+’ sign then type that same size with ‘mm’ specified as the unit.

e.g. You measure a door with the tape measure tool that you think is exactly 28", but it says 711.2", you could then type 711.2mm and press return. SketchUp will ask you if you want to resize the model. Click the “Yes” button. If you measure again, it will be exactly 28" or 711.2mm, depending on which unit you have set.

It would be better to get the largest size that the Architect dimensioned and use that to scale your model to minimise round-off errors.


#8

If you click on two endpoints with the Tape Measure tool, you can then resize instead of getting a guide line. No need to first change the mode for the tool.


#9

You’re right, you don’t have to change the mode. I don’t know how I got that in my head. I’ll try and get that out of my head now…


#10

Check out this skill builder

https://youtu.be/iQEACzA2fDk


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.