I can't download 3D models from the warehouse anymore

Hi all!!! For an unknown reason I am unable to download any 3D model from the warehouse…my app is spinning and gets blocked every time …

I have to “force to quit” and start all over again…but still can’t download d the models…

Anyone knows what?



Look at this topic I posted:

See if setting the Colors palette to be something other than Colors in Model makes things quicker.

Hi…it does make sense, cause I am working in a model that has a lot o details…but the SketchUp app really appears as “not responding” …like it’s really blocked, even if I wait for a long time.

I tried to open an empty file just to download the models and then copy them in my actual design and it seem to work now.

So i am basically using a “storage” for the 3D models…and move whatever I need in the final design afterward.

thanx anyway…hope this problem will be solved one day


Generally that’s considered the smart way to work. This give you the opportunity to examine the things you are collecting from the Warehouse to make sure they are suitable for your project. You can clean them up if necessary (it often is) or reject them before they get into your project.

Wouldn’t hurt to try purging unused stuff and otherwise cleaning up your model.

Your work around is what is usually suggested. It would be interesting to hear if what I suggested solves the problem as well.

I will try that too…



Actually I used to do it all the time…so I could avoid downloading corrupted files…but the 3D warehouse tools became so efficient, safe and fast that I stopped doing that.

I will start doing it again. It really helps to clean, resize, modifie…and reject the 3D object before importing it in your main design.

I even had a personal 3D “warehouse” full of furniture and objects that I liked to use from one model to another…



My situation is exactly the same–downloading from 3D Warehouse into complex model causes beach-balling and I have to force quit. I also found the same workaround of downloading into an empty model. Interesting that this is recommended practice–I learned something new! However, I’m adding my comment because this behavior is new and doesn’t seem right–regardless if it’s the preferred practice.

The recommendation to download from the 3D Warehouse into a separate file to examine, clean, and repair prior to inserting the component into your project is not new and it’s not intended as a workaround for the beachballing. If it’s a work around at all, it’s a work around for dealing with poor modeling practice by many 3D Warehouse contributors. Too often components are incorrectly sized, overly detailed, and or just difficult to work with. Adding problem components to a project just doesn’t make sense. Personally I prefer to create all of my own components. Even if there is a component in the 3D Warehouse of the object I need, I’ve usually found it’s much faster for me to model it from scratch than to repair what someone else created.


Actually it was the way I was thought in my SketchUp formations since the beginning…and I agree we should always do it this way…which is the correct one. But…but…we always try to save some time by pulling steps…

About creating models of my own for everything I need…well…I guess I still need a bit of practice to get to that level. The 3D warehouse is sooooooooo useful in 90% of the case

Keep up the good work!!


OK, you’ve made an excellent case for doing this, but in my book it doesn’t make it OK that loading directly into my model should crash SU. Whether I’m rushed, or I forgot to load to a separate model, or perhaps I trust the component, it should work. And while I acknowledge all the reasons given and see the benefits of the recommended practice, any reasonable action (which I think this is) that crashes SU is unacceptable. Furthermore, if 3D Warehouse expects to always load into an empty model, then they should put that in bold print, or perhaps automatically open a blank model for us.

Lastly, this has just started happening for me in the last few weeks, after six years of it never happening. What changed?

The beachballing you are talking about means that SketchUp is busy doing what you asked it to do!
That is NOT crashing…

I agree with you on this. It should be made clear that that is best practice, however there are always people trying to skip steps…

probably your model is too heavy allready and thats what’s causing the beachballing…
If that is the problem you would be the cause except if someone else made the model you are working on…


On a Mac, unresolved beach-balling (several minutes) requires a force quit–essentially a crash.

It’s not a required step. And FAIK, it’s only a “best practice” because of uncertainties about the quality of some components. If you already know and trust that the component is fine, then it is an unnecessary step.

You’re making a lot of presumptions about my model. It happens to be the same model I’ve been working on for years and has actually gotten smaller recently as I’ve cleaned it up. I didn’t change my practices, 3D warehouse did. I’m not a programmer or computer tech, but it seems odd that I can copy and past from one model to another, but 3D Warehouse can no longer download directly into my model in one step. I know, probably something about how it uses ram or buffers, or whatever. But I don’t understand why people are making excuses for poor technical performance and trying to characterize it as user error. That’s nonsense.

I don’t know anything about current Macs so a dumb question: Has something changed in the way your Mac uses your Internet connection? Cloud sync? Have you updated to the latest MacOS? I don’t remember other members writing about this so it cannot affect all users. Can you download into a new empty or small model?

I,m curious how other Mac users think about this statement…


That’s why I said probably…

Thanks for your questions. Nothing has changed on my end–same OS, network, internet, SU version, etc. A couple months ago I was downloading components directly into my model without issue. Now, I have to do the two-step process. I don’t have time for a lot of testing, but based on your questions I tried a simple experiment. I opened an earlier version of my current model from 6 months ago and tried downloading the same component that recently required the two-step process. It worked–even though the previous version is 6 MB bigger. So perhaps it is more than just size that affects 3D Warehouse downloads. Perhaps it’s all a fluke and will self-resolve, or perhaps there is something about my more recent model version that is affecting the download. But since my model is not otherwise acting strangely or causing problems, I don’t see any obvious cause for this. I only added my comment above in response because to others apparently having similar issues, and I was curious if something changed with 3D Warehouse.

File size on its own doesn’t say much, it’s more about how many edges and faces…

"On a Mac, unresolved beach-balling (several minutes) requires a force quit–essentially a crash.

“I,m curious how other Mac users think about this statement…”

Well I am on MAC and it is true…beach-balling forever if you don’t “force to quit” the SketcUp app …and then, most of the time, loosing some of your last changes in the model, wasting time opening everything again…it’s really a drag…

It may be that previously you had the Colors palette set to something other than Colors in Model. Try opening Colors and change what it is set to so that it’s anything other than Colors in Model, and see if that speeds things up.

I tried that–still crashed. But when I reopened the model and attempted the same download, it now works.