How to rotate this object


#1

Hi,

Using only the rotating tool I am trying the impossible: make the openening (in the square) to be aligned (dont need to be exact) to the bottom.

I tried everything (using only the rotate tool) but skecthup does not want to allow me to rotate that opening to the bottom!

Try opening the file and try to rotate the “rectangle” stuff in order to make the opening be in the bottom of your screen. Can you tell me how to do this?

File: x.skp (393.9 KB)

I AM COMPLETELY STUPID!!! I DIDNT MEAN ROTATE TOOL, I MEAN ORBIT TOOL!

SORRY REALLY SORRY GUYS!!! I MEAN ORBIT. I thought both tools had the same name, I am really sorry.

SO MY QUESTION RESUMES TO THIS: how can I rotate the view (using the ORBIT TOOL) in order to make the hole in the square point down?


#3

I thought the bounding box should align automatically to the object… I have no idea why the bounding box is not aligned to my object :frowning: Anyway, rotate tool should allow me to rotate the object in any direction I want… why should I use any other tool if this is the exact tool I should use? I want to rotate the view not the object!

I figured it out that using ctrl+rotate tool makes it a little easier to rotate the view BUT as soon as I release the CTRL key and keep rotating the object comes back to its original position. Is this a bug?


#4

I don’t understand what you want it to do.


#5

I opened your file, the opening in the “square” looks aligned with the hole to me. Which is the “hole” you want to rotate? I’ve color coded elements to help conversation, is this what you are talking about?


#6

You sound somewhat confused. The rotate tool rotates an object within the view, that is, changes its orientation with respect to the model axes. The orbit tool rotates the view without altering the objects or their orientation to the axes. The visual effect is sometimes the same, but the action is not equivalent.


#7

@slbaumgartner @endlessfix @box @DaveR SORRY! I Edited the end of the question, really sorry!


#8

No problem, I get what you want now, Orbit tool is the one you want, but actually the rotate tool is going to be part of your solution too. Try: Camera > Standard Views. This is a list of standard views that “look” at your model from square on in different directions. However for this to work efficiently you need to have your model set up relative to the origin axes. I’ve rotated the entire contents of your model and aligned it to the origin axes in this version. Try standard views “front” with this and see if this is what you want.

x.skp (384.7 KB)


#9

Thanks man! Using standard views is a lot easier but is not practical having to go there everytime I need a diferent view.

Could you please try something? Hold CTRL in your keyboard and try to use the ORBIT tool, you will see it work muuuuuch better. REALLY GOOD! BUT IF I release the CTRL and try to orbit just a little bit, the model comes back to its original position :frowning: It’s probably a bug, could you confirm?


#10

Using ctrl with orbit allows you to ‘Roll’ or break gravity. It isn’t a bug.


#11

Go to windows, model info and make sure you do not have angle snapping set .
Secondly, update your profile the generic terms there now do not give info which can help home in on issue. You can now force axis ref by using the arrow keys depending what version you are using??
As an aside it takes 6 degrees of freedom to locate an itme in 3d space, 3 x,y,z for its location such as cg and three for say pitch, roll and yaw.


#12

Thank you but the CTRL bug still affects me. Could you just try it?


#13

I would try but align to bottom does not mean any thing to me. In su there are no real tangents ( In the classical definition sense )unless you mean a line segment, do you mean the flat of the one cog or ???


#14

SketchUp implements a concept of “gravity” which attempts to keep the horizon line oriented level across the view as you orbit. In the early part of the attached animation you can see this happening. You can also see that there is no jump back to original alignment. Then part way through I pressed ctrl (actually option as I am on a Mac) and you can see the horizon starting to tilt. After I release option, the next time I try to orbit the horizon immediately snaps back to level as gravity is reasserted. Is that what you are referring to? If so, that’s just the way “gravity” works in SketchUp, not a bug.


#15

@slbaumgartner you nailed it!!! That’s exactly what happens! Is there a way so I can disable gravity by default so I dont need to deal with CTRL nor deal with releasing CTRL and having my model rotating back do compensate gravity?


#16

So far as I know there is no way to permanently disable gravity by default, only temporarily via the ctrl key.


#17

If you could disable gravity, things would look quit different around here :smiley: Meanwhile, you can activate the instructor tray or pay attention on the statusbar: the different options of the tool which is active are displayed and explained, providing a new user who pays attention a good way to learn the tools.


#18

Thanks, I am not a good learner but I will take more close look to what that status bar says!


#19

Yes it’s not a bug, you’re seeing suspended gravity, the shift key is also a useful modifier when orbiting. Are you using a three button mouse or the trackpad?
You can customize your standard toolbar by right clicking on it and there is an available set of buttons for the standard views which you could place in your toolbar to make selection faster. Or you might want to explore scenes. “Gravity” as it’s called here is actually pretty helpful (in general too ;)) for not getting lost in a bigger model… but something sounds funky about how you are orbiting because you should have no problem getting around to look at any face you want without ever having to turn gravity off, I almost never do and have no problem navigating to any face.


#20

I didnt know I could make a toolbar button appear, I will do that!

BUT I THINK THERE is something very strange… you said I cant disable gravity… open this file please Carrinho10.skp (1.6 MB)

You can orbit it without using CTRL key and you will see you can orbit “without gravit”. WHY? It looks like for this file the ORBIT can go anywhere withougut using CTRL key. Why?


#21

Gravity is still in effect. That doesn’t prevent you from orbiting the camera so you are looking at the model upside down as it was when you saved the file. If you pay attention, you’ll see that the horizon is always horizontal unless you hold Ctrl to temporarily suspend gravity.