Can you lock the origin when using the orbit tool?

howto
orbit
origin

#1

Is it possibly to lock the origin used by the orbit tool, meaning the coordinate within the drawing from which the tool rotates?

Right now, with out knowing how to do this, sometimes when I try to rotate some geometry that I’m working on the orbit tool seems to grab an origin point way off in the distance and the geometry I’m working on flies out of view. I have yet to figure out how it picks the origin or how I can get it to use an origin within my view.


#2

Are you rotating the geometry or moving the camera? If you are moving the camera, the center of the orbit is the cursor at the moment you click to orbit. Are you using the center mouse button for orbiting?


#3

Not using center mouse button. Using orbit. Also, I’m NOT rotating the geometry, I’m rotating the view around the geometry… I didn’t say that correctly. Also, the issue I’m having is the Z axis of the cursor in the view. My part is only 6" think, but if would seem to be rotating on a point 50-100’ deep in the view.


#4

You should be using the center mouse button to activate Orbit. This will give you better control over the center of orbit./ Also center mouse button with Shift to activate Pan. Mouse wheel to Zoom.


#5

That seems to be the same as using the Orbit “O” with the left button, just a different way to activate it… and behaves the same way with the same problem. Also, I don’t really have access to a middle button… on this machine it only works with the touch pad, not the track point… so it’s just not usable.


#6

You really ought to get a mouse with a center button/wheel. As it is you’re working too hard.


#7

It is exactly the tool. The difference is that middle mouse button is very much faster and keeps the previous tool active in the background. This means you an e.g. start draw a line, move the camera so you can see the point where you want it to end, and then finish drawing the line. This can’t be done when activating the orbit tool from “O”.

I don’t really see the problem. You press (either the left mouse button when in orbit tool or the middle mouse button in any other tool) on the point you want to rotate around. If you rotate around a slightly different point you can alternate between orbit and pan (middle mouse button + shift) to de facto rotate around a different pivot point. Once you get used to it you don’t really notice you alternate between orbit and pan, it just comes naturally.

I’d really recommend you to get a proper mouse. SketchUp is designed around a 3 button mouse. You can use a trackpad but it’s a bit like trying to write a novel on a phone. A proper mouse will save you a lot of time and is much more ergonomic.


#8

Is there anyone who can actually answer my question, or does everyone who hangs out here just change the topic to criticize other peoples work habits?


#9

Looking at your original question, Orbit works on the thing you click on. If you want to orbit around the Origin, create something small at the Origin and click and drag on it. Everything else will orbit around that small object.


#10

The question have been answered but maybe you don’t care because you are to keen on doing things the wrong way.


#11

Yes, you can ‘lock’ the origin of rotation, when using the orbit tool. It is set by two things: The position of the camera (zoom level) and if there is something under the cursor. (POI;Point Of Interest)
A small object shouldn’t have impact on that, but likely ‘clipping’ issues can pop up.

This origin can be altered ‘along the way’ by zooming out and in while changing the position of the cursor. Though it will take some time to learn and master those navigating skills with a 3-button mouse, it will take considerable more time with the native trackpad, leaving a frustrating experience.


#12

Thanks Colin, that’s what I would have expected. However, that’s not the behavior I’m getting. The problem is mostly the Z origin in the view. If it’s too far (deep) from the geometry of interest the slightest moment of the mouse causes the whole thing to fly off screen and you have to click the Previous (camera undo) to get back to where you were and try again. Most times the origin seems reasonable, but it is quite variable and I have yet to figure out how SketchUp is choosing it.

This model is not simple, it’s a whole house, and most times I’m zoomed in working on some detail. Sometimes the origin of the orbit will be on the surface I’m working on, other times it will be on the other side of the building, 45’ deep in the view… and other times it seems to be 1,000’ deep and the whole house just flies off the screen with the slightest movement.

I wasn’t sure if there were settings to control this behavior that I’ve missed, or if you can manually set an anchor point.


#13

one way to control those two ‘handles’ is with scenes


#14

So yea, a picture is worth a thousand words… and a video would be priceless. Have a look at what I’m talking about, there’s just no way anyone’s going to get it from my description. Maybe I just don’t know what I’m doing but I kind of would like an explanation if that’s the case.


#15

Try working in Perspective rather than Parallel Projection.
Camera menu Perspective.


#16

I have tried Parallel Projection, in fact I work in that some times, but it dosen’t help, it does the same thing.


#17

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.