Orbit tool

I’ve been away from Sketchup for several months, getting back into it I’m having trouble with the Orbit tool. I know I can invoke the Orbit command using the ‘O’ key on my keyboard. I use a Logitech Trackball and as I’m working I continue to try and orbit by pressing one of the switches on the Trackball but it doesn’t seem to work. Is there any other way to get it, I know I can map one of the switches to the letter ‘O’ but I’ve never done that in the past.

On my Logi trackball I press and hold the scroll wheel; orbit is active while the wheel is pressed. This function came out of the box and I didn’t map it.

You need to map to middle mouse button (scroll wheel usually). Holding middle mouse button orbits.

Thanks! I’m not going crazy, I went back and reset to factory settings and everything is working as I expect.

Good news then!