How to make a concave and convex chamfered edge meet?

Hi everyone,

I have been modelling a table top and come across this situation with chamfers. I am trying to make different chamfers meet, one is concave the other convex like in the image. I would appreciate any suggestion. I have so far been using “Intersect faces with selection” and removing unwanted pieces one by one. Not the greatest of ways I suppose :).

Sadly, you haven’t uploaded the file itself. It’s hard to make out what that is. It looks like you might have a rounded edge meeting a half round groove. Is that right? It’s also not obvious what is wrong (apart from the reversed faces).

Use round corner, then place a cylinder where you want the groove. Intersect the faces, then delete the unnecessary geometry.

P.S. A chamfer is a 45º cut and a fillet is a rounded edge.

1 Like

You didn’t say exactly how you produced the concave shape. I’d make a convex “cutter” and place it into the top so that it extends past the corner. Then do the intersect faces between it and the rest. You will most likely need to scale up before doing the intersect to avoid issues with small edges (search the forum for the “Dave method”). Also, to delete the extra that projects past the corner, orbit so you can see it with nothing else behind and then use a right-to-left “crossing” selection box to grab the projecting end. It will also get the parts that extend from there back to the corner so you can delete with one click.

Hi simoncbevans,
Thanks so much for quick replies! My apologies it is a bit unclear. It is a corner of a table top with a groove. I have tried to make chamfer (white) and groove (blue) meet at 45 deg. angle. First I have created the groove (cut out of the table top with “Intersect face with selection” and removed the excess). Second I used RoundCorner tool on the edges of the table top. The round corner stopped before the groove profile started so I gave selected its edge and pulled over so it intersects (image below). Next I have used on them “Intersect face with selection” and removed manually leftover pieces.

Thanks slbaumgartner!

That’s the image showing the whole table. The line on top is a groove. It involves removing quite a lot of small pieces and I was wondering if there is a way of just making chamfer and groove meet and create a neat corner. Or perhaps there is no easy way? Thank you for your replies so far!

I have just checked out Dave method. Brilliant! Thank you.

This is hard to answer without knowing the exact structure of your model, especially where you have or have not used components. Could you possibly upload your model to a post here using the 00%20PM button on the reply window?

I haven’t used components.
Table.skp (446.7 KB)

As the old quip goes, I would write a shorter letter but I don’t have enough time. In this case, I’d make an animated gif but it’s late here, so I’ll have to settle for a bunch of words. My apologies if you are a visual, not a verbal learner!

I assume you haven’t used components because you are new to SketchUp and not yet comfortable with them? I’d strongly recommend that you study them because a) they will make your table model much easier to manage, and b) they will reduce or eliminate some issues you are having. The SketchUp tutorial videos have sections about components and groups.

Alas, at this stage, it might be easier to start over than to try to separate the bits that compose each such component in your model, as they are all stuck to each other.

One strong argument for using components is that your table has repeated, identical elements. The four legs are the same, just moved and rotated. The two end aprons are the same, as are the two side aprons. The top is logically a central panel with two identical end rails and two identical side rails. The side parts are essentially the same as the end ones, just lengthened, which can be accomplished by making a copy unique and the editing it. Making components and placing instances with appropriate location and rotation will let you edit just one and have all the others duplicate the edit automatically.

For example, if the end rail of the top is a component, you can cut half the groove out of its edge, and the same groove will appear in both instances. When you have all edges of the rail appropriately shaped, you can make a copy of the component, make it unique, open it for edit, and drag the bits of one end out longer to create the side rail component.

Components are also essential for the “Dave method”.

You appear to be using Layers in an effort to sidestep components. But that won’t work! In SketchUp, all edges and faces interact (stick to and intersect) with each other regardless of whether they are visible or not, and all a SketchUp Layer does is to switch multiple components between visible and not with a single setting. To prevent geometry from interacting, you have to isolate it in a separate “context”, which is what components (and groups) do.

When you want to use “intersect faces with” on a component, you need to open the component for edit and put a copy of the “cutter” into the same component as the rest of its geometry, else the intersection faces will not be in the component. You can initially draw the cutter outside the component and place it appropriately, then use copy and paste-in-place to get it inside the component for the intersect. By doing it that way you can use the same cutter for both of the components that meet at each joint, for example, the end rail and the top panel.


Not so elegant, but the gist of cutting out by intersecting. the tube cutter is same diameter as the rounded edge profile.


Great gif. Thank you! :slight_smile:

Thank you Steve for taking the time and explaining everything step by step. Great post! However I have run into these two things:

  1. The vertical corner of the top needs to be chamfered as well. It means that each component needs to be chamfered to its half so that both components would make a full chamfer.
  2. Also when I turned off the edges I can still see the line between components. Despite their endpoints indicating snapping I have zoomed in to check if the components are snapping and the very deep zoom showed they are not snapping.

Looking nice!

Yes. Do it before cutting the groove.

I can’t tell from the image what might be happening there. Could you upload your model again for another look?

Side note: I’m at SketchUp 3D basecamp so my “screen time” is limited right now. Please be patient if I’m slow to reply!

Thank you Steve :). It’s because you gave me such good pointers.
Regarding the chamfer: Please have a look at the model.
Table 1.skp (259.1 KB)

I have just a quick moment between sessions. The dark lines along the joins are because the active Style has Profiles turned on and set to 2. Those edges are at the boundary of the curved groove, so they are getting handled as profiles. To make them go away you can edit the active style and either reduce profiles to 1 (same as regular edgs) or turn profiles off.

It probably would have been easier to run the edge chamfer down the vertical edge first before doing the groove. Starting from where the model is now, you can create another cutter with a concave inside face (like a triangle with one side curved in) and use the same intersect technique to cut the sharp part of the corner away.

1 Like

if each section is a component, the only way to get rid of that line would be to edit the component and "SHIFT/Click with the eraser tool, this will not delete the line but hide it. YOu can globally hide edges but then you wouldn’t see any.

1 Like

Looking good now. What material will it be made of?

Thank you. Dark brown cherry wood.