How to install sketchup make 2015


#1

I downloaded SketchUp 2015 make. When I started the program it said SketchUp Pro, 30 days trial. when I started the program later in the day it said License expired and I can only exit.
I downloaded Trimble SketchUp a year or two ago but never used it. I don’t know if this is related to the “expired” thing after 2 hours. but I don’t want Pro, just Make.
what could be going on?
How can I install make?


#2

Make has always had a 30-day trial of Pro.
But be sure you downloaded and installed Make. The installer should have “Make” in the file name.

For forcing the end of the trial, and “Make” mode, See:

Also other topics:


#3

Thanks.

I think when I downloaded I mistakenly clicked on the Pro download link.

I downloaded again and I now have Make running.

I wonder if I can try Pro at some point (30 day trial)? Since I accidentally downloaded Pro and it said trial expired. I guess that was a result of having downloaded it (but never run) a year or 2 ago.


#4

HI

Downloaded SketchUpMake for ‘Personal Use’

Downloaded file was SketchUpMake-en-x64.exe and installed in Wine 1.7.44 on Linux Mint 17.2 Cinnamon 64Bit

Had to move a DLL but after that it started and worked fine.
Have been using SketchUp for many years on Linux and I am a big fan.
I hope one day to be able to install it Native on Linux :smile:

However now it says ‘Keep modeling for free by clicking “I agree” below.’ in Firefox when I start it.

And there is no ‘I agree’ link, only the ‘Buy Sketchup Pro’ link.

in fact there are no working links in the html source they are all prefixed with ‘skp:openExternalUrl’.

I use the latest verson Firefox browser

I read your post and updated
Program Files (x86)/SketchUp/SketchUp 2015/Support/SketchUp.lic with ##NoTrial
I found it is the Support folder. There is no other file of that name.

However no change has occurred.

I also tried copying the file to
Program Files (x86)/SketchUp/SketchUp 2015/SketchUp.lic
Again no change

I cannot afford to buy and would like to keep using Sketchup Make.

Do you have any further hints

Regards


#5

You have used the incorrect license path. For Windows v6.x+ (Vista and higher):
%PROGRAMDATA%/SketchUp/SketchUp 2015/

… or for older Windows versions 5.x (XP and older):
%ALLUSERSPROFILE%/Application Data/SketchUp/SketchUp 2015/

  • Note: SketchUp 2015 does not support Windows XP. This is just for backward reference

The %var% identifiers are environment variables. You can see all of them by opening a command shell, and typing set [with no parameters,] at the command prompt.

… or you can see single values by typing echo then the variable name enclosed in % delimiters:
echo %ProgramData%


On an unrelated issue, you installed a Windows 64-bit application.
They should get installed to "C:/Program Files"
When you install a 32-bit application, onto a 64-bit Windows edition,
it should get installed to C:/Program Files (x86)

But when you install a 32-bit application, onto a 32-bit Windows edition,
they get installed to "C:/Program Files"
and there is no C:/Program Files (x86) directory structure.

So does WINE emulate a 32-bit or 64-bit Windows edition ?


#6

Wine is 64 bit windows. It is not an emulation the libraries run native on Linux x86 platforms.

I have both C:/Program Files and C:/Program Files (x86) and Sketchup installed to the x86 directory

I did finally find a cure which was to remove c:/users/myUser/Application Data/SketchUp directory and clean the registry of all SketchUp data

That enabled me to Agree to the license again. It may be fine for another 30 days now. If not I will look elsewhere for the lic file.

I can now see the %ALLUSERSPROFILE%/Application Data/SketchUp/SketchUp 2015/Sketchup.lic and I will try updating that.

When I searh for *.lic I get:

./users/Public/Application Data/SketchUp/SketchUp 2015/SketchUp.lic
./users/Public/Application Data/SketchUp/SketchUp 2015/EW.lic
./Program Files (x86)/SketchUp/SketchUp 2015/Support/SketchUp.lic

EW.lic contains '# DO NOT EDIT - Intentionally blank.'
SketchUp.lic contains:

‘##NonCommercialUse
’# DO NOT EDIT - Intentionally blank.’

Thank you for the reply.

Regards

Stuart


#7

But you specifically said, you downloaded and installed the 64-bit SketchUp Installer.
Only the 32-bit installer would ever install into the 32-bit “Program Files (x86)” directory.


#8

I see your point!

Maybe I am confusing with it with linux which puts 64 bit apps in lib64 and 32 in lib32

I have checked my download and it is definitely SketchUpMake-en-x64.exe

There is no trace in the ‘Program Files’ only in ‘Program Files (x86)’.

Perhaps Wine is the culprit.

Regards

Stuart