How does LayOut show a transparent viewport background in Raster mode?

Rendering the viewport in Vector mode allows the image “background” to be removed (ie become transparent)…which is good.
But I need this technique to apply the same when it’s rendered in Raster and Hybrid modes.

As soon as I switch a Viewport to Raster, the background of the viewport becomes white and unchecking that Background checkbox doesnt do anything.

I do not have “Ground” or “Sky” ticked within SketchUp.
I have reset styles & tags in LayOut.
I do not have a Fill applied to the viewport object.

I feel like i’m either making a dumb mistake, or something has changed…or something is broken in my install?

Either way I totally need to show raster images, and I need them to NOT be on a white/coloured background.

I’m using 2021.1.279, and Nvidia Geforce 1070 with recent drivers.

Cheers

Was having issues where .299 simply didn’t launch at all.
When did 332 come out?

Anyway I think issue is related to Styles.
I have a number of Styles in my model that are called [SimpleStyle]1 , [SimpleStyle2] …etc…

Simple Style seems to apply the colored background - there’s no way to change or override this that I can find. Sometimes the background is green, sometimes grey, or white.

Some other default styles like Sketchy Edges will show the background as transparent (but, of course, I don’t want sketchy edges…)

Hmmm… I’m not having any problem with showing no background in the viewport.

Edit the background color to white. Remember to update the style after making changes.
Screenshot - 10_8_2021 , 5_44_03 AM
Simple Style with white background and no sky.

I was glad to learn about this from @DaveR during @TysonK’s livestream on LO, tried it out and I saw it work. Now today it won’t work for me. The check box for “Use Background Color” is checked and greyed out so I’m not permitted to uncheck it. Strangely, if I check Fog, I can then uncheck background, but it doesn’t work. Am I missing something, or am I looking at a bug? I’m still on 2020, BTW. I have 21 install, but haven’t switched daily use yet.

That Use background color check box is specifically a Fog setting. It doesn’t have anything to do with back color/transparency otherwise.

Your screen shot shows that the "Starting Style2 is selected but it isn’t the one used in the scene. What is the style actually used in the scene? And what happens if you untick Background at the bottom of the Scenes section?

1 Like

Doh! Now I see the other check box. My eye stopped looking as soon as I found that one.

1 Like