Viewport transparency and the "background" setting

TLDR for those looking for a solution: Uncheck ‘Background’ in LayOut’s style settings.

I finally figured out something that’s been troubling me for a long time, but I’m still wondering if I’m missing something, or whether a feature request is in order. When creating condocs, I frequently stack one viewport on top of another, so that I can show different layers of a building, or show some elements in a different weight/color, etc. But at some point (last year?) this stopped working for me – the top viewport would block the other one, even if it is set to ‘vector’ rendering. I checked all the SketchUp style settings, to no avail. Then I noticed in LayOut’s style settings, a little “Background” checkbox. That fixed my issue – now, the top viewport is transparent, as long as it’s rendered in Vector.

It seems like this should be a setting in SketchUp? But maybe not, since that setting wouldn’t affect working in SketchUp – only background color matters there. It was just weird for me to need to change it in LayOut, since I try to make all style settings in SU – set it and forget it.

LayOut’s settings for the SU model style:

SketchUp’s settings for a particular style (that’s not a checkbox, it’s a color selector):

example of stacked viewports.

  • Bottom viewport: hybrid, hidden line. shows walls and appliances, with gray lines, black section cuts, and gray section fill.
  • Top viewport: vector, shaded. shows electrical with black lines.

Also… shouldn’t the top viewport also be transparent if I render it in ‘hybrid’? Right now it’s only working in ‘vector’.

You need to have Sky turned off in the style in order to have the transparent background.

Hmm… I already had sky disabled. And enabling sky (in SU) for both viewports doesn’t cause an issue with viewport transparency. Just that ‘background’ checkbox in LayOut.

Do you have fog on by chance? Background won’t be transparent if you accidentally have fog on. I skimmed your post so apologies if that’s not helpful.

Fog isn’t on, in either viewport. And it’s disabled in SU.

Sky will prevent the background transparency from showing even if you untick the Background box.

The only difference between the two viewports is the scene for the top one has no sky enabled in the style. The bottom one does.

If the background is set to white and Sky is not enabled, the background will be transparent by default when you send to LayOut.

As @nmason points out, Fog could affect the background, too.

Interesting – I think we’re talking about a different types of transparency – With Sky enabled, I can’t see the LayOut background (the “paper”), but I can see through one viewport to the other (if I uncheck ‘background’ in LO). I had to give the background some color to realize this. So, the Sky setting isn’t relevant to the problem I was having, but it’s good to know.

It’s possible since version 2022 to manage line weights, styles and colors on a single viewport for different tags of your sketchup model, you can tag the elements you want to show on a different line weight and color then on layout on the sketchup model tray go to tags and edit the style there without having stacked viewports, you can also hide different tags directly from layout, it’s one of the best features added recently. You must set the line scale to 1x to be able to see the changes you do to the tags, if the line scale is too small will be hard too see the line weights.

1 Like

I forgot about that feature – guess I reverted to old habits. I was very excited when it was introduced. And yeah, it would have been a good method to use in this situation.