Stacked layers block layers below -- and 'background' is turned off, and scenes are correct in Viewport

I have a Layout file with two stacked viewports, each on their own layer. One is for linework and the other is for color. I am unable to view the viewport underneath. Styles and scenes were set up in Sketchup.The styles were not changed after bringing into Layout. I have checked two known reasons this problem can occur: ‘background’ being turned on, as well as making sure each model points to the correct scene in Viewport (and is not accidentally pointing to, say, ‘last saved Sketchup view’). I have also reordered the layers just in case that was the problem. I have even just completely recreated the Layout file, just in case there was some irreparable issue with the first Layout file. Still no luck.

Thanks for any assistance.

Why do you separate line work and the colour, Is that not just the regular sketch up look?

Which one is for the linework? It should be the one on the upper layer. And the style should be set to Hidden Line and Background turned off so when it is rendered as vector there’ll be no faces or background then the one underneath should show just fine.

Hi, Dave.

I have the linework on the upper layer. I have the style for that layer as a pencil sketchy edges style. Background turned off. Basically, I’ve done what they do here but it’s still not working. I wonder if it’s not working because I currently have it in raster mode. Could that be it?

Yes. The faces are rendered in Raster mode so they are occluding the viewport beneath. With the style set to Hidden Line and the rendering to Vector there will be no faces. Rendering in Vector, however, will remove the sketchy style because sketchy edges are raster entities.

If you really want the sketchy edges and the stacked viewports, render the sketchy viewport as Raster and explode it. Then edit it in your default image editor to remove all of the faces leaving just the edges. Keep in mind, though, that exploding the viewport means that changes you might make in the SketchUp model later will not translate to that image. If you need to update the SketchUp model you would need to replace the image with a new one. Not all that difficult but not automatic.

Unfortunately, even in Hidden Line mode and hybrid I cannot see the viewport underneath. I definitely don’t want to explode it, and in all of the instructional material I’ve watched on stacking viewports (it’s really common in interior design) there is no mention of having to be in vector mode or exploding it (in the video I posted, for example, they use hybrid mode and have one of the sketchy styles selected). That’s what made me think this is a bug.

Right. And, like Vector rendering, Hybrid results in vector linework not sketchy edges.

What video? I don’t see a video that you posted.

I doubt it. Again, sketchy edges are a raster thing. Vector and Hybrid render edges as vector lines.

I wonder about this too. Why?
Why don’t you just turn the lines, with their sketchy edges, on in a single viewport?

The video is linked to in the word ‘here’ in a previous post, but I’m posting it here as well: Stacking Viewports - Let's Talk LayOut - YouTube

The beginning of the video explains why this functionality is needed. Basically, interior designers use it as a way to mix line styles with color-rendered portions of the model.

Ok. I’m watching the video now. Paused to make this comment. When he switches to Marker Thin with his viewport rendered as Hybrid, he’s actually not getting the Marker Thin style. Here’s an example using one of my sketchy styles that makes it more evident.

In SketchUp:

In LayOut, rendered as Raster:

Switching to Hybrid:

And in Vector, although the faces aren’t displayed, the lines are also not sketchy.

The edges turn into Vector lines and the only thing coming over from the sketchy style is the extensions. You could get that by using the normal style and turning on Extensions in the Edge settings.

Adding a side by side comparison and showing that all three viewports have the same style in use.

1 Like

That’s interesting. Thanks for finding that, Dave. I guess what I’m trying to do may not be possible after all.

I think not with stacked viewports, anyway.

Is there something wrong with just using a single viewport that is raster rendered? It would give you the sketchy edges and textures, both of which are raster anyway.

Yeah, that may be the best possible option in Sketchup for now.

Thank you for your help!

1 Like

Thanks for the link, I can’t say I entirely follow why this is necessary - I guess there are circumstances where you might want to use multiple types of sketchy lines?

There are some line style override options added into SketchUp in version 2020 which allow you to change the color and appearance of specific lines for any tagged object.
That might be of use for you - you could for example have no lines on the background geometry, but apply the sketchy style line to just furniture - all within a single viewport.

This could be done by hiding the edges in the background objects with a sketchy style applied to the scene however you can’t select sketchy styles for only specific tags in SketchUp or LayOut.

The only way to make the stacked viewport thing work for sketchy edges would be to use Wireframe for the Sketchy viewport but then you’d see edges you probably don’t want.

So it is. I had wrongly assumed you could adjust “line” width on sketchy styles, but it appears there is a separation between “sketchy” styles and standard styles in how you control it.

With a Sketchy style you can change the Line Scale for the entire viewport but not for just specific tags. You can change the color for sketchy lines by tag, though.

It would be nice to be able to control line weight by tag in LO. It would also be nice to be able to use the dashes by tag with sketchy styles.