SketchUp layers set in Scenes not showing correctly in Layout

layers

#1

I created a few scenes in SketchUp that just show a hatch layer so that I can show wire mesh screens on top of my elevations in Layout. This is my workaround to the problem that I need to set my style to Hidden Line for construction drawings, but that means the screen texture disappears. So I am trying to layer two viewports - 1 with the scene that just includes the wire mesh hatch, and 2 with the scene that has the full hidden line elevation. Unfortunately, the entire shaded texture elevation shows up even though the scene is saved with only the one wire mesh hatch layer turned on. I have gone back and forth between SketchUp and Layout, saving and updating multiple times and in multiple ways.
So them I decided to just draw a rectangle hatch in Layout and overlay it on my elevation viewport. That works fine for the elevation where the wire mesh is actually a rectangle. But for the mesh that is a polygon, I have no way (that I know) to create that shape in Layout.
Another problem I find, is that the hidden line style in SketchUp is actually much more detailed. I can see transparency and set it to “Nice,” which helps the drawing read better. But in Layout, all transparency is lost, no matter whether I am set to Raster, Vector, or Hybrid. I don’t understand why styles read so differently between SketchUp and Layout.


#2

So I figured out that I can actually draw the irregular shape with the pencil tool. So I have solved my problem for the meantime. I still would like to know why the layers are not showing correctly in Layout. I definitely am saving the Scene each time with all the boxes checked.


#3

Would you be able to share the LayOut file so I can see what you’ve got going on? That would make it easier to help you sort out the problem. If you don’t want to share it publicly, click on my name at the top of this post and then ‘Message’ and either attach it to a private message or upload it to Drop Box and send the link.


#4

I just figured out that turning on shadows in layout helps add detail to transparent areas. The only problem with this is one of the elevations is in shadow all day.


#5

Here is a screenshot of my attempt to use viewport overlays, but the layers would not turn off correctly so I would only see the wire mesh hatch.05%20PM|368x500

I guess as a newbie, the forum won’t let me post more than one image.


#6

I think I’d need to see the LayOut file itself.


#7

I have to say that ever since I installed a trial version of Skalp, both SketchUp and Layout are randomly crashing or freezing. I can’t get the cut hatches to show up correctly in my sections or plan either. They will show up in one view at a time - disappearing in others. It is so buggy. I have given up on trying to show hatches in the sections and plans. Notice how there is a hatch in one section and not the other…


#8

I decided to draw the hatches over all the viewports so that sections read correctly.


#9

Well, as long as you have it sorted out.


#10

This appears to be a recurring theme with Skalp and SketchUp 2018. Is anyone else having these issues or maybe found a solution to them? I was about to buy Skalp but am now not so sure.


#11

You’re right. I don’t have any use for it myself so I haven’t tried it. I don’t know if there’s a bug in the way Skalp works or users reporting these problems are doing something incorrectly. It seems enough of an issue that’s it would be worth a close look before buying.


#12

Issues do appear but the Skalp guys are savvy enough to solve them. I would not give up buying it if I was you. Skalp is unbeatable when you need to show different materials in sections and plans. Besides, no other plugin allows you to use a black and white drawing while the cut parts are in color.


#13

I don’t disagree, the benefits are why I was so interested, but when there is an obvious programming issue that will cause SU to crash and there has been zero communication from the Skalp team, (I’ve posted here, in extensions warehouse, emailed, tweeted and even FB messaged them without any reply) then it appears they have zero concern for their customers. Which is a huge shame.

My take FWIW, is that after the intro of native (basic!) hatch fills in SU, Trimble have made Skalp an offer they can’t refuse and have bought the software rights for intro in SU 2019. It’s the only reason I think of as to why Skalp would be no negligent on sorting a known major issue and also be avoiding communicating at all with their customers. If not, they need to get their act together. Comms are everything.


#14

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.