No styles in layout

I’m running the trial version of SketchUp 2019 on a Mac running Mojave 10.14.3. I created a simple 2-D drawing in SketchUp using the Construction Documentation Style

I sent the model to Layout so I could do some annotation. First, I want to crop the image and then add dimensions and notes. However, when I go to the SketchUp Model window in Layout and hit the Styles tab, no styles show up.

What am I missing?

You don’t have the viewport selected.

If you use the correct work flow, you don’t need to select a style in LayOut anyway. You do that when you create the scene in SketchUp.

To crop the viewport, drag the edges. If you don’t want it to change size, make sure Preserve scale on resize is checked on under the View tab in the SketchUp Model panel. Don’t let the scene associated with the viewport show as modified in the SketchUp Model panel.

Also, it looks like you have a 2D drawing so make sure the camera is set to Parallel projection in the scene you create in Sketchup. Always remember to update the scene after making changes you want to keep and then make sure you save the whole drawing before expecting any updates to show in Layout.

1 Like

Dave,
Sorry about not including the viewport in my screen shot. I get the same result (i.e. no style) when I select the viewport. So even if I don’t need to select a style, why doesn’t it show up?

With regard to dragging the edges I can’t because the drawing is scaled. If I select no scale, I can drag edges but I cannot select the “preserve scale on resize”, it is greyed out. Matter of fact, everything in the view tab is greyed out.

Do I need a scene to make this work? I have no scene.

Upload the LayOut file so we can see your entire setup.

The correct work flow is to set up a scene in SketchUp for each view that you want to show in LayOut and then select a scene for the viewport in LayOut.

almoncbevans,
Yes it is a 2-D drawing and the camera was set to Parallel projection in Sketchup. And I did modify the Sketchup drawing (removed dimensions) and saved before sending to Layout.

Dave,
When you say “upload” do you simply mean a full screen shot or something else?

So the answer to my question about scenes is that I DO need a scene for this to work. Correct?

Save the LayOut file and upload it into a post so we can open the file ourselves.

You should be making scenes in SketchUp so that your LayOut file has fixed references for the viewports. Then, if you have need to revise the SketchUp model, you get predictable results in the LayOut file when you update the reference.

Dave,
Bear with me, I’m trying a few things, like adding a scene, before I upload the file.

Okay, suddenly the whole world changed. I decided to turn off auto-save and no backup on Layout. Then I trashed all copies of the LayOut file and basically started over with a transfer of my SketchUp model to LayOut. Now everything seems to be working. I have a scene and a style on the SketchUp model in Layout. I’m able to preserve scale and resize. I’m also able to edit the model in SketchUp and upload the changes via Document Setup in LayOut.

And just to test the water, I went back to the SketchUp model, deleted the scene, saved and then updated LayOut. Lo and behold, the view and style tabs in LayOut are still populated (i.e. not empty or greyed out) and the scene shows simply as “last saved SketchUp view”. But I’ll heed your warning about “predictable results” and remember to always create a scene.

So…it looks like things are working, problems solved. Thanks for your help.

Don’t delete scenes in the SketchUp file that are tied to viewports in the LayOut file and don’t use the Last saved SketchUp view as the “scene” for a viewport unless you enjoy creating problems and more work for yourself.