Sketchup + Skalp + Layout


I would like some advice on my way of working.
Before, I worked with Autocad for 2D, Sketchup for 3D.
I got tired of Autocad and having to do everything twice, and for a few months I’ve been working with Sketchup + Skalp + Layout.

I’m almost satisfied with it, but I have a rather big issue that remains:

As I mainly work on renovation projects, I have several layer folders (Existing, Demolition, Project), with a loooot of layers and also a loooot of scenes.
Maybe my problem comes from there.

I explain my problem:
On Sketchup everything is fine, the problem is when I switch to Layout.
I have many pages, on which there are my sketchup scenes.
Almost all of my scenes use Skalp.
And in Layout, I regularly have to refresh some scenes, because Skalp is no longer displayed (the scene is displayed normally, but without the hatches).
As soon as I refresh a scene, the hatches of another scene disappear.
And when I export to pdf, some scenes are fine, others without the hatches.

I found the beginning of a solution, but it doesn’t quite work for me:
On the SKP file, I only put a few scenes (plans for example).
Then I create another SKP file, in which the first is in Xref (or component), then I create the sections scenes.
And another for the façades, and another for the details, etc.
It’s a bit better, but I still have the problem of hatching from time to time, so it’s not perfect, and more importantly, it makes my work very cumbersome, very slow.
As soon as I make a modification, I have to save, open the other files, update the Xref, update the scenes, etc…
I work on relatively simple and quite small projects, so I would like to find a solution to make my way of working simple too!

If anyone has a solution or advice for me, that would be really great!

Thanks in advance !


ps : Sketchup 2023. Windows 10.

Please post a Layout file showing your issues, it is possible you will get some tips how to solve the issues.

Ok, here is a pretty good exemple, on this link :

I have the hatches issue on some scenes (pages 5, 10 and 12).
If I want to solve it, I have to go on Sketchup, clic on the scene, update layout, save the scene, save the sketchup file, go to layout, update the scene. It works, BUT first, it’s very long, and secondly, when I do that, the problem appears on another scene.
Its almost impossible to have all the scenes ok !

Thanks for your help !

I have this issue also, if I make any change to the Sketchup model I need to go in to each scene for skalp to update. But to avoid having to do this with lots of scenes you can just click on the manual update button in the Skalp window, which will cycle through all the scenes and update them all. Then save the Sketchup file and go back to Layout where you can update the model ref and all scenes should now show the correct Skalp hatching, cut etc…

I think most of your issues are from the improper use of tags.

They should only be assigned to groups and components. Use only 1 tag per group or component. Putting groups or components on more than one tag leads to disaster. Do not tag faces or edges, they should remain untagged. Help article.
Videos from YouTube These are from the SketchUp Channel.

Thanks, I’ll try that.
I tried a lot of things today and the skalp option “export all scenes to layout” seems to solve the problem ! But I didn’t test enough to be sure.

Ok, thank you, good to know.
Just to be sure :
I understand that edges and faces should remain untagged.
But, can I do that :

  • I have 3 tags : A, B and C.
  • I have a group on layer A
  • a group on layer B
  • I make a group with this two groups
  • I put this group on layer C.

Is this ok or not ?

Thanks again !

@benjaminlr you can give tag A to one group, tag B to the second group, and tag C to the nested group that contains those first two groups. Might make model management easier if you skip creating the nested group and Tag C. Instead create a tag folder with Tags A and B in it. Visibility of the groups can be controlled by hiding the tags or the tag folder.

1 Like

Ok, thanks ! That make sense.
So, just to be sure, the only rule to respect is to remain faces and edges untagged, right ?