Skalp sections randomly not rendering in LayOut

Morning wise ones.

Any ideas why LayOut randomly decides not render some Skalp sections entirely of it’s own accord?

Everything is rendered fine in SketchUp, scenes set, updated, file saved.

Go to layout and set up my pages, some scenes decide that they aren’t going to show the Skalp fill.

Often this seems to happen when there are two viewports on the same page. ‘A’ will appear fine, ‘B’ will not show the Skalp fill. So I’ll go back to SketchUp, go to scene ‘B’ that didn’t show the fill, check that it’s all ok in SketchUp, yep all good, save the file, go back to Layout, refresh the viewport.

And here’s where the fun usually starts… scene ‘B’ that wasn’t showing fill might decide to now show Skalp fill, but scene ‘A’ that was fine will now decide it doesn’t want to show the fill.

So we go back to SketchUp and repeat, and back to Layout and repeat the refresh, no you cross your fingers and hope. Sometimes they’ll swap back: ‘A’ is good, ‘B’ is bad, sometimes they’ll both decide to render, sometime neither. It’s Skalp fill roulette.

So eventually they both show Skalp fills nicely, but now there’s now guarantee that another scene on another page hasn’t decided it doesn’t want to play ball, so you click back a couple of pages, and boom, scene ‘C’ that was fine the last time you were on the page has now decided it doesn’t want to show Skalp fill.

What the F****!? How, why? What have I done to deserve this?

Honestly the amount of time I waste going back and forth on this while trying to produce a drawing pack is killing me.

Any ideas? Anything? Please… sobs. :cry:

I’m not a Skalp user, but it sounds like it is either a user issue or a Skalp issue.

If it is an issue with Skalp, you could try Curic Section instead. That’s what I use to make those sorts of figures.

One workaround (until you find the root cause) is to unlink a viewport reference in LO when it looks the way you want so that a future save in SU doesn’t impact it.

Hi, cheers for the reply…

to the best of your knowledge does Curic Section do everything that Skalp does?

Thanks for the Unlink Viewport tip… I did not know that. So basically any update to the model would then need that viewport to be relinked to update, otherwise it remains untouched? Sounds good!

For the most part - there are a few threads on the forums on the differences if you do a quick search. There’s also a free lite version without all the bells and whistles if you want to try it out.

Correct, not ideal if you’re still making model changes, but might minimize the sobbing

1 Like

thanks, I’ll check it out.

And I think I mispoke there on the unlinking individual viewports. Unlinking the reference affects all viewports with that reference. I think I was confusing that with the process of unticking the “Auto” render box. That way you can render viewports individually instead of throughout the entire document.

1 Like

Ah, ok, cheers.
I’ve tried locking them in the model reference window for now anyway, I’ll see if that helps!

Yep, that should do the trick - that will make the yellow caution symbol appear when everything else renders - but you can ignore it.

At first sight I would guess that the section cut faces created by Skalp are on a tag that is turned off in the LayOut viewports, but I don’t use Skalp so I don’t know how it actually performs its magic. Can you post a LayOut file that displays this behaviour?

Hi Anssi, that would possibly explain it if it was consistent, but there is no rhyme or reason to when or which viewports decide to sow the skalp fill or not.

I’ve just saved the file I’m working on and edited it down to just a few sheets including the ones that have been misbehaving today, and sure enough one of the viewports on page 2 has randomly decided not to show Skalp fills. Screenshot below.

The 2d and 3d sections are exactly the same section cut, just different scene views.

I wonder if it will open up like this for you?!

SketchUp and Layout files here: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free


Now, when I look at your model in SketchUp, the two scenes “Section 2” and “Section2-3d” differ from each other. In the latter, a group named Skalp Sections is hidden together with what is inside it… It seems to contain the Skalp section cut faces. How it has got that way, I cannot say. I turned everything on and resaved the scene. It seems I turned on perhaps a bit too much…

That Skalp Sections Group should always be locked and everything apart from ‘Skalp Active Section’ hidden. That’s Skalp’s doing, you don’t touch that group as the user, and they both show as that for me.

The problem’s not inside SketchUp though, the sections never don’t render properly as long as Skalp is running.

The sections all render properly in their saved views, the problems only arise in Layout.

I was wondering if the hiding was Skalp’s doing. If I open your “Section 2” scene , switch to Perspective projection and try to match your “Section2-3d” view the section fills remain visible, but it might be that Skalp is programmed to turn them off? I wonder if @Guy still follows these discussions. Does Skalp have a forum of its own?

Yeah, as I say, I don’t have any issues with Skalp’s fills showing up inside SketchUp, only in Layout.

There’s no Skalp user forum, just their seemingly hit and miss support email.

Maybe Curic Section is the way forward.

Thanks for taking a look though, appreciate it!

I myself use TIGs Section Cut Face. I feel that is quite enough for my simple models. That leaves for me to figure out these scene/tag/hidden issues myself.

1 Like