LAYOUT Vector Rendering a hidden line style displays like wireframe

When I import a section cut view into layout and (vector) render it, it displays like wireframe rather than the ‘hidden line’ style it is created and saved in in sketchup. I noticed this has been discussed in previous posts from 2015 and 2017 but either of the fixes suggested then don’t work or are not possible for me.
One of the fixes was to turn of hardware acceleration in sketchup. I am not given that option. The other option was to update the driver for the graphics card. I have done that and it also doesn’t solve the problem.
Any ideas?

Can you post a LayOut file that displays this problem?

HI Anssi,
Unfortunately (or fortunately) the file has changed too much now! I took some objects out of the scene (furniture etc) and just kept the walls in the scene and I was going to just render that as a raster (the problem I was having was that the stairs behind the walls were showing through when I rendered it as a vector). I put the furniture on another scene (and viewport) and was going to render that as vector. That all worked. But also for some reason the scene (viewport) with the walls in it also worked when I rendered it as a vector and the stairs didn’t show through. The scene styles were the same (I think), so I can’t really work out what the problem was or how I fixed it.
Thanks for the reply though! If you have any ideas on what may have been causing it I would be interested to hear them as I’m sure it’ll happen again one day.

Hi Anssi,
Sure enough, it is still happening.
I have posted the layout file. If you take notice of the beds. When rendered as Rastor, it appears as I had expected. Although, if I want cleaner line work and render it as vector it appears to change style to ‘wireframe’ and shows linework that I would have expected to be hidden.

Example problem.layout (1.8 MB)

That’s actually normal behavior for Vector rendering if you have the background turned off. If you want the faces to show, use Hybrid or turn on the background in the SketchUp Model panel… Here’s an example from one of my files.

Vector rendering:

Hybrid rendering:

Vector rendering with Background turned on:

The same thing happens in your model. Here I’ve added a cyan rectangle bhind the viewport to make it obvious.

Vector without background:

Vector with background:

Might be worth purging unused stuff once in awhile.
Screenshot - 10_27_2020 , 10_00_32 PM

Hi Anssi,
Thanks for looking at this for me, but I don’t think you are having the same problem. It looks as it should on yours with background on and off.

This first image is a vector render (with red background on). It shows parts of the bed in wireframe (which I dont want).

The next is raster with background on.

To make it even stranger. I had this same scene work well in one layout file. I put it in a new file to show you and it wouldn’t work properly in the new one!

Thanks again,

I’m not getting that wireframe thing where you can see through the bed at all even with the background turned off.

Might try updating your graphics drivers.

Maybe you could update your profile, too. It says you are using SU 2018.

Yeah, its strange!
I updated the graphics driver yesterday.
Thanks for trying

Thank Dave - I have been sleeping. He never seems to sleep.

This topic was automatically closed after 186 days. New replies are no longer allowed.