Faces disappearing in Layout vector mode

Just wondering if anyone else has observed this behavior and what to do about it? I made a SketchUp model of some open web steel joists using fairly simple geometry (angles and bars). When I open a viewport in Layout, everything looks fine in raster mode. But as soon as I change the render mode to vector, the horizontal geometry of my two nearest joists turns into horizontal lines and their faces disappear. All the joists further in the background look fine - just the ones closest to the camera fail to render correctly. I tried everything I could think of to get them to display properly but to no avail. The only thing that gets them to render is this: if I bring one or both ends of a horizontal object (bar or an angle) fully inside the boundaries of the Layout viewport, then the object renders correctly. But these are 24 foot long joists and I want to have a view of the middle of the joist. So, my preferred view is not conducive to including the bar ends. I have attached both my SketchUp model and a sample Layout view. Notice on the Layout page, the top viewport is in raster mode and looks great. The bottom one is in vector mode and you can clearly see the problem with the horizontal members. Any thoughts on this?


20011, Rev. 0.skp (3.7 MB) OWSJ closeup.layout (9.1 MB)

P.S. Here’s a PDF of the Layout view if you just want to see a visual of the behavior.

OWSJ closeup.pdf (1.2 MB)

Also, I just noticed that my Layout file is 2.5 times larger than my SketchUp file - is that weird? Since Layout just opens a viewport into my model (where all the geometry is) and this particular Layout file doesn’t even include any annotations, I would have expected the file size to be fairly small compared with the SketchUp model.

1 Like

Same problem here, with much simpler geometry. Only a section cut for a few walls. Either everything becomes transparent either I only see the lines, but not the faces …
Have you found a solution ?
Thank you

Can you share the LO file?

I think the OP was sorted but that was over three years ago and I don’t recall the solution.

this is the file

Your problem is due to the style setting you have selected for the viewport. If you switch to Raster rendering you will see there are no edges to display due to the style. Actually the style you have selected has edges set to white so they disappear into the background. And since you have LayOut set to not show the background color in the viewport, there’s nothing for the white lines to show against.

It looks like this in Vector with your selected style.

Change to Raster and it looks like this:

Change to an appropriate style for showing Vector edges and you get this:

Even just changing the settings for the viewport will get you to what you have set in SketchUp. Background turned on gives you the gray background in the viewport and the white lines appear and choosing Hybrid instead of Vector gets you the section fill.

By the way, you would probably find it beneficial to purge unused stuff from your SketchUp models once in awhile. 32 of the 38 styles in the model are unused.
Screenshot - 6_2_2020 , 7_58_26 AM

You might want to remove the LayOut file from your earlier post. It contains your contact information along with that of others.

Thank you very much for your reply
I’ll try to do these changes right away
And thanks for the purging tip ! I am just starting out with layout :slightly_smiling_face:

1 Like

I hope that helps you.

That’s done in SketchUp. Use Window>Model Info>Statistics and click Purge Unused. You can also purge unused stuff from LayOut in File>Document Setup>References. I did both and it reduced the size of the LO file by about 40%.

Dave, I’m the original poster (from about 3 months ago). It seems to me like Nicoleta’s issue is different from the one I raised. My issue seems like more of a rendering flaw in the software. Any thoughts on my issue? Also, I’m still curious about the file size issue I mentioned - is that to be expected?

Yours appears to be caused by an OpenGL deficiency. I see it on my computer even with LO2020. I reduced the problem by simplifying the viewport rendered in Vector with a bit of a work around but I think this is leaning toward the clipping issue.

It’s still not exactly right.

I did run CleanUp3 on your model and while it didn’t have any bearing on the issue, it did clean up your model.
Screenshot - 6_2_2020 , 1_49_20 PM

1 Like

Okay thanks - it’s good to know it wasn’t something dumb I was doing. Dare I ask what you did to improve things? Or is the wizardry too esoteric and I should just live with it?


I did simplify the zig-zag web a bit. Could have done more actually. I also added a separate tag for the front beam and then did a stacked viewport thing. The top viewport shows only the front beam and that was rendered as Hybrid. The ones in the background were shown in the lower viewport rendered as Raster.

I expect if you really need to show a close up of this beam, it might be workable to only show one of them. Your model does present a good challenge for OpenGL rendering. Not sure where the fix should come from. Maybe in the OpenGL pipeline or maybe in LO.

Even with just the front beam shown the lines show through. It looks like when roof trusses show through the shingles when the view point is far enough away.

1 Like

Okay good advice - thank you. I’m still a rookie with SU/LO and I’ve definitely been guilty of getting a bit too detailed with the geometry (sometimes just because it seems cool). But then when you repeat that geometry over and over again, it would tend to bog things down. For these open web steel joists, maybe I could have used a simplified version for the repeated members and then maybe off to the side, a detailed version for close-in sections and details. It sounds to me like that might have been a better approach.

1 Like

I hear you. It’s easy to get carried away with the detail just because you can. I can show plenty of my own examples of that. But it’s a good idea to keep your models as simple as you can just to make the work easier.

1 Like