Layout 2016 Vector Rendering Problem

Im having a problem with layout viewport of a sketchup model showing ALL GEOMETRY not just geometry in front of camera. This is only happening when i switch to vector (or hydbrid) rendering, raster is fine. I have tried everything already suggested:

  • Tried 2 x different graphics cards (currently using an Quadro 410)
  • Upgraded/downgraded drivers and OpenGL drivers
  • Played around with HLRItemSize registry as per existing Sketchup recommendations
  • Turned off hardware acceleration, same thing happens
  • Same effect even on Sketchup 2015

Why does this not work?
Step 1 : Basic Model, set up camera location to face cube with person at back

Step 2 : Send to Layout : defaults to raster (shown correctly)

Step 3 : Send to Layout : switch to vector, rear geometry shows why???

Typically, when this sort of thing is reported, the culprit turns out to be the graphics card drivers. Quit LO and go to SketchUp. Window>Preferences>OpenGL. Turn off Use Hardware Acceleration. Click OK to get out of Preferences. You may need to quit and restart SU to get the change to take effect. Then try sending the scene to LO and see if you get a change in behavior.

If you do see an improvement, it would indicate that your GPU and/or its drivers aren’t up to snuff. You can start with checking for an upgrade for the drivers and see if that helps.

Hi Dave

Tried that already as per original post, i also have tried 4 different NVIDIA Quadro drivers and even tried out an ATI card pulled from another computer.

I dont think it is OpenGL, have you tried this exact step and does it work? Perhaps a Win7/64 issue

Sorry. Missed that. Reading on phone in a hotel. Can’t try it now but I haven’t had this issue when using LO myself.

Are you creating scenes in SU for these views? If not, you should be.

Hi, yes i am creating scenes, also interestingly if i use the section plane tool it works fine.

Can you post a SKP and LayOut file that shows this behavior ?

The images above show:

  1. no scene in SketchUp
  2. the SketchUp model is not saved
  3. the viewports in LayOut are not even using the model’s default view camera. (They appear to be one of the orthogonal views using a parallel projection camera.) Makes me wonder if the LayOut viewport has become disconnected from the SketchUp model (via double-clicking.)

6.layout (86.1 KB)

6.skp (69.6 KB)

  1. yes scenes have been created. makes no difference
  2. yes it is saved
  3. Im using a parallel projection camera with a specified camera position in sketchup using the little man icon and setting the direction. The issue is the geometry behind the little man pops up only in vector

Your parallel projection camera is placed between the large and small blocks, and the small block is not visible because it is clipped. This is not how things should be done. Parallel projection conceptually uses a camera that is infinitely far from your model, and clipping is treated as a bug that occurs when the camera gets placed inside or behind the model… If you want to hide things in parallel projection use a section plane or just hide them or use a layer.



Yes it appears that clipping planes dont work in Vector rendering mode for whatever reason.

Section planes are cumbersome when dealing with a complex model and lots of elevations/plans. Hiding is impractical also as the object needing to be hidden may be behind/infront of the clipping plane (say looking into a house, require front walls not back walls in elevation).

It would be really good if vector rendering retained the clipping planes!

1 Like