Unable to make background transparent in hybrid mode

I seem to only be able to make the background transparent when my model is set to vector mode in Layout – if I switch to hybrid mode and check/uncheck that box in layout it does not make a difference.

At first I thought it would be something with my styles, so I started a brand new scene, made a box, linked it to layout and tried turning off the background in hybrid mode – same issue. Anyone else experience this?

I am in the latest version of sketchup, got an MSI laptop with a geforce RTX

Can you share a sample LO file that shows this?

What is the background setting for the selected Style?

Attached is my sketchup file. I have a style called Presentation - no BG that has only the background turned on as pure white. That style is linked to scene AXO 2. If I make a page in layout with the AXO 2 scene and make the background transparent, nothing happens.

Thank you for looking into it
Villa Savoye.skp (9.9 MB)

It has to do with your style but I’m not seeing what just yet. When I assign my default style to it with the the same white background and Background unticked in LO, I get no background as expected. This is Vector. Hybrid looks the same.

Interestingly after going back to your style in the SU model the background goes away.

So, to double check, that is hybrid mode, correct? Vector has never been a problem for me.

My default style works fine in Hybrid, too. Yours doesn’t seem to though. I don’t see a difference in the background setting, though

another update, I just made a new sketchup file with the out of the box style and hybrid mode worked OK. I went back to that same model, made a new style that had a watermark in the background and that seems to have “corrupted” the model. Even if I delete the style that has the watermark in it and go back to the default sketchup style that worked prior, the background is now forever white in layout in Hybrid mode – even if I start from scratch in a new layout document.

Do you mind testing this? Thanks again, Dave

I just edited my default style to match yours as far as line color and back face color. No background.

How did you create your style?

No. not corrupted. You have to turn off Display Watermarks even though you’ve deleted the images. I didn’t catch that you had that turned on.

Ah, turning off that checkbox in my dummy model solves that issue. I went back to my main model and made sure that the display watermarks checkbox is off in my WHITE BG style, but no luck. Hmm… trying to figure out what to do next. Going to copy and paste into a brand new SketchUp instance.

Did you update the style after turning of Watermarks? Click on the style’s thumbnail. If you don’t so that you aren’t actually making a change to the style associated with the scene.
style

I did – WHITE BG is updated to not have that checked and reloaded into layout. Just to double check, do you still have the other style that does have a watermark in the model?

First, I untick the box and updated the style in SU as shown above. Then I saved the file and updated the reference in LO.

The one with the graph paper watermark? Yes.

Thanks for your help, Dave – I have gotten it work now. I am not entirely sure where my misstep was, or if there was some sort of glitch but I:

  1. deleted the style that had graph paper watermark
  2. saved a new file that had just the default style and WHITE BG style
  3. duplicated the WHITE BG style and added the graph paper back in. Saved.
  4. loaded that new SKP file into the layout document I had been working on.
  5. WHITE BG is transparent and the graph paper variant works as intended

I think the mistake might have been starting from a style with a watermark and not completely removing the effect of the watermark. Glad you got it sorted though.

For the future it’s probably best if you start a new style from the simplest styles instead of starting from a more complex style.

1 Like