Hidden Layers showing up in Scenes. Help

scenes

#1

I have been working on a model and using/hiding layers for various scenes. But everytime I go to to beginning of the scenes, layers that i KNOW I’ve unchecked to hide show up anyway. I uncheck then update and still they show up.

I did not create the original (training) model but have added to it.

Please help.


#2

check if the geometry within the groups / components (assigned to layers) are on layer0.


#3

Have you set the scene to save layer visibility?


#4

I thought initially the problem was that the items I was modeling were on Layer 0 and so I changed it to the layer. I am trying to upload the model here but it says that the file is too big. Im not sure why, as all the elements drawn are very very basic. A few rectangles and boxes along with some text.


#5

I believe that I have. I will post some screenshots since i cannot upload the file.


#6

This VIDEO may help with your situation.


#7

Try purging unused components and materials.

Or upload it to Drop Box and share the link.


#8

#9

Layer visibility state is a scene by scene setting so turning off the layer’s visibility in one scene does not mean it will be turned off in another scene. As you add layers, you need to update existing scenes with the visibility state for those new layers. After setting the layer visibility for the scene, right click on the scene tab and choose Update.


#10

Here’s what I’m ultimately trying to do besides what Ive stated. I have 3 training modules (that I did not create) that I wanted to merge into one file. The reason being, I thought it would be simpler than having a user open and close 3 files when each file had 5 scenes in each. Since I read up that you cannot merge models, I thought I would just add scenes to the first file that look just like the other files. I can upload the other 2 as well.


#11

Your scene-tabs are set to remember individual layer-sets.
You have assigned layers to individual text objects.
This is correct, BUT you then need to ensure that that text-layer is not switched ON in some unexpected scene-tab.
To check in out scene-tab by scene-tab open the docked layer-browser and see which layers are ON in the scene-tab.
The ones that should be OFF can be reset and that scene-tab’s settings updated [context-menu].
There are several scene-tabs with incorrect layers switched on.

Also some of you layers are named with spaces, and some without - so they don’t sort logically, which would also help you when troubleshooting…


#12

I started to read someone’s reply just now and now it seems like its gone.

It started with " You’re using the layer settings wrong"


#13

I thought I was doing that, updating each scene with layer visibility, but I think I just might be layering wrong.


#15

The first file you posted does show incorrect usage of layers. Edges and faces should all remain on Layer 0 normally. Only groups, components, and text should get assigned to other layers. It’s not clear to me if you are making these files or just modifying files made by someone else. It may be that they are the ones using layers incorrectly.


#16

I did not create these files, although the first one I posted is the one I messed up on trying to expand it. The other 2 files have not been modified by me. But I will check now on how I’ve been using the layers and modify.


#18

I can’t reproduce your issue. If I uncheck layer11 and layer12 then update a scene, they remain unchecked when I revisit that scene. I wonder, do you have any layer management plugins that might be interfering?


#20

I think I’ve got the layer issue mostly resolved. Now to figure out the Style issue with the watermark! LOL


#21

Watermarks are contained in styles. There is always a style associated with a scene. Your problem is that you have more than one scene using the same style, so they share the watermark. You can see this if you open the styles window and watch how the selection changes when you change from scene to scene. For example, scenes Start Here, 1, 2, and 4 all use the style named “Style” and scenes 9,10,11, and 12 all use the style named “Style 8”.

Regarding layers, you have two issues.

First, you have many ungrouped edges and faces that are referencing other than Layer0. That is a risky practice because SketchUp layers do not prevent edges and faces from sticking to each other or intersecting each other, even if all but one layer is non-visible. This situation won’t cause issues provided the edges and faces are always located in different places in the model (so they can’t stick or intersect anyway), but will cause unexpected results when they overlap. Put edges and faces into groups or components to protect them against interaction with ones from a different object.

Second, you have edges and faces inside a group/component referencing the group’s layer instead of Layer0. That’s not usually necessary because when the group’s layer is non-visible, all of the group’s contents will be non-visible regardless of what layer they use. But if you ever get contents of a group using more than one layer, you can get the same issues as described in the first item above plus strange cases in which not all contents of a group become visible when you turn the group’s layer visible.

So, to avoid problems the advice of all SketchUp experts is to draw all edges and faces with layer0 active and to leave them there until/unless you are yourself expert and really understand the consequences!


#22

Thank you, I’ve made great progress this morning. I changed all the edges and faces to layer 0, then made them groups which solved most of the issues with the model! I will work on the style issue next. I seem to sometimes run into hidden geometry as well, when I move certain things around the screen.

I’ll ask for help on Styles issue on another topic if I can’t figure it out myself.


#23

You do have a fair amount of hidden geometry in your model. Most of it is nested inside groups or components. Using the hidden flag is a mixed bag, mainly because SketchUp doesn’t keep a record of successive hide actions, it only remembers the last one. So, the only degrees of “unhide” are selected, last, and all. Furthermore, “all” works only within the current edit context (model, open group, or open component) so you can leave a lot still hidden when you thought you unhid everything. In addition, just as with non-visible layers, hide doesn’t prevent edges and faces from interacting, which can cause strange effects. Most experts recommend to use layers in preference to hide, reserving hide for limited situations such as:

  • To temporarily be able to “see past” something that is in the way of what you want to edit. In this case, immediately unhide it on completing the edit.
  • To cause separate objects to appear to be one by hiding the edge that separates them.
  • To prevent the “bleed through” that can happen when an edge is close behind a face compared to the distance to the camera.