Layers and Saving When unticked and now not visible

Hi To all. God I hope someone knows how to fix this.
I saved a drawing with most layers not visible/unticked.
I then closed the program. I have just reopened the same drawing and when I tick the layers I want to now become visible they do not become visible. This is to say the least a bit annoying.

That is not normal. Could you upload the model so others can see if they reproduce the problem?


Hi Steve
Thanks for the response. This is the first time I have used the Sketchup Community forum. So when you say upload the model do you mean copy the file and past it into the section I am typing into now. ( Why do I get the feeling I’m about to receive one of those thoughtful looks that just speaks volumes)

Let me know if I’m being a bit thick along with killing my drawing.

Click the Upload button and then attach your file.

Thanks Dave
I tried to up load the file but its telling me its to large. Can you tell me how to shrink a SKP file.

Typically you would purge unused stuff under Window>Model Info>statistics as a start at reducing the file size but in this case, I wouldn’t do that. We don’t want to lose important stuff.

You could zip the file and see if that reduces it sufficiently. Otherwise, upload it to the 3D Warehouse and provide the link to the file here.

21 Eugene tce Back fence Pipe (1000.7 KB)

Hi Dave I have Zipped up the file. I hope I have done this correctly?
Thanks for the patients and help so far.

It appears you did do it correctly, Marcus. So what is missing from your model?

It’s unfortunate that the vast majority of your model uses groups instead of components. Components would be more efficient and could be helpful if there are objects missing from the model space.

FWIW, I bet you find it difficult to work on this model and navigate around it due to its orientation.

The solid blue axis is up while the red and green lie on the ground plane.

Yes this model is an absolute pain of my own blundering around. I copied the car park/concrete area, fence and posts out of a much larger model. It was the first large model I had ever done. My use and understanding of groups and components were just starting out. There still not great. From the tutorials I have been watching I thought if I did not want things to stick together I should always make each component into a group and then assemble all those groups into a single grouped component. Like the bollards in the model you are currently seeing. I also made each group a layer. Nuts one layer, post next layer, weld another layer and so on

Not sure if you’re able to have the same access to that file as I do but about half of it is not visible. If you are able to open the layers palate you should see things like turn buckles, UC post, cables and much more. Each has its own layer but I cannot see it even though it is ticked. I’m still not quite sure what I did. I’m very tempted to just delete it and start again. But that means I can then go and make the same mistake again. I would much rather understand what happened than just doing thins parrot fashion.

Sorry for the delay in getting back you. We had a storm roll through and knock out the power for a few hours.

I had a further poke around at your model. I never did find turnbuckles or cables and so on. It appears they were erased.

Frankly, after having an in-depth look at your model, I think you would be wise to start from scratch. It needs to be drawn in the proper orientation, you should be leveraging components which you really haven’t even begun to do in this model and you need to use layers properly. The improper use of them could be the root of your problem. You’ve got base level geometry (edges and faces) assigned to various layers. ALL edges and faces should be created on Layer 0 and should remain on layer 0. Only components and groups should get the other layer assignments.

Another thing I found is excessive nesting of groups. This just tends to make models more difficult to work with.

It may seem like a lot of work to start over but I think it’ll actually be less work that fixing the model you’ve got.

Thanks David. So I don’t drive you nuts with endless explanations can I find all the items you are mentioning in you tube tutorials or is there a better source of info.
I have heard about Sketchup course’s. I’m in Melbourne Australia Can you tell me how I find out more about these?

As to my poor model. I tend to agree with you. Sometimes it’s just better to hit delete and start again.
I’ll try again.

Hi Marcus,

I would start with the basic tutorial videos and the Help Center articles. For example, on layers, look at this.

I don’t really think it would take a great deal for you to get beyond the issues I outlined. Perhaps we could connect for a little online session and I can show you some things that will help you improve your experience with SketchUp.

My guess is that when you get these basics down, you’ll find you can bang through a new version of this model in pretty short order.


Hi Dave

Thanks for the info. I had a look at the tutorial you suggested. I had thought that what I was doing was correct. Although a great deal more complicated as I had so many layers.

  • In my model I drew the nuts the threaded rods, flanges, welds, pipes all on layer zero. As I drew each item I would make it a group and then assign it a layer as listed above. With some items, the threaded rod studs and nuts and washers I would draw each item, make it a group and then combine all the items and make those combined items a group. I would then copy that group 12 times as there are 12 x nuts washers and threaded rods per flange. I would then make that a group. This would mean that my layers were created at the initial individual item level and then combined within groups of ever larger size.

My thought and construction process was that when I was showing this to someone I could remove all the nuts on all 44 bollards at the same time, or threaded rods, flanges posts and so on and so on. This would make it easier for them to understand the fabrication process and what was involved.

I gather I am not doing this quite the right way and can see the complexity between single groups combined with other groups of an ever increasing size and complexity. I gather this is what you were referring to when you mentioned nesting of groups.



Hi Marcus,

I’m not sure where it went pear shaped but as I said, you have edges and faces on layers other than Layer 0. The best process is to keep all edges and faces on Layer 0 and only assign components/groups to other layers. There is a little “gotcha” that you should be aware of. If you explode a group or component, its contents take on the layer assignment. Perhaps that’s how you got to that point.

re: Nesting of groups. Think of making a group (or a component) as wrapping up the entities in a transparent box. This box protects the contents from being modified and prevents new stuff sticking to the stuff inside. To make changes to the contents, you have to open the box and when you are finished, you close the box up again. Nesting is putting boxes inside boxes. If you want to make a change to the geometry inside a group that is in a nest, you have to open multiple boxes. While that can be a pain, if it is done correctly, it’s very powerful.

I suggested that you should use components instead of groups in your model. There are several reasons. The first is that you have many copies of the exact same parts. In the case of your model, since they are groups instead of components, if you need to change them, you’ll either have to change each one (much like you’d have to do in real life) or you would delete all but one, modify the one and redistribute copies of it throughout the model. If you use components, you can edit one instance and all other instances get the same modification.

Another benefit to using components is that the component definitions get listed in the In Model components library. There are several positives for this but one of them is that the component definition remains in the components library even if all instances get deleted from the model space. I don’t know exactly what caused all your groups to disappear, I suppose it could have been some corruption with the file or maybe you intended to hide them and erased them instead. Erase and Hide are next to each other in the Context menu and maybe you “fat-fingered” the selection because you were in a rush. I don’t know for sure. I have seen cases in which users have done that.

Since there’s no group library, deleted groups are just gone. Unless you catch it right away and use Undo. If your groups had been components instead, you could simply drag in new instances of them from the library. As you can imagine, this would save you redrawing all those parts. Over the years that I’ve been teaching SketchUp, I’ve seen a number of cases similar to yours in which stuff disappeared. In one case the user had used only groups and made a nested group of most of the project. He inadvertently erased the big group instead of hiding it and then, instead of hitting Ctrl+Z to undo, hit Ctrl+S and saved his changes. He had to pull an all-nighter to redraw his project so he could show it to his client the next day.

Another fellow I know had used mostly components with only a few groups. He was able to reconstruct most of his model by dragging new instances of the components out of the library.

Another benefit to using components is that you can save them to a local collection or to the 3D Warehouse for reuse later. I draw a lot of furniture and often need drawer pulls, hinges, screws and so on. I save these into libraries on my computer so I don’t have to redraw them later. Even things like vises for workbenches get saved that way which comes in handy and saves a bunch of time.