Hidden layers STILL showing up


#1

Good Morning All,

Yesterday I posted about a file I was working on that was showing hidden layers in scenes when I didnt want them.

Since I was using a file I did not create myself, I decided to just create a new file from scratch.

It seems like Im having the same issues with hidden layers showing up in scenes in which I have hidden them.

I don’t know where I’m going wrong and its really annoying.

I’ve attached the new file.

Also, somewhere around scene 6 or 7 I added an object in Layer 0 so that the user can modify it in subsequent scenes but because of that its showing up in all of the scenes previous to that. Should I make that object its own layer and add keep visible only on the other scnes that I want.

Please help. I spend alot of time on this ■■■■ thing yesterday and ended my day ripping my hair out.


#2

I looked at this earlier and it worries me that you are trying to develop a teaching aid.

You should not need our help to create such things. If you don’t know the subject you shouldn’t be teaching it.


#3

All you have to do is turn off the layers you don’t want on each scene, and then update each scene individually.


#4

I understand your point, but I am not teaching what I dont know. Since you did look at the file earlier, you will see that the materials being taught are the most basic aspects. I am not teaching what I clearly dont understand.

Thank for your help.


#5

I’ve tried that soooo many times and every time I go back to the beginning it gives me the same thing. I will see if I can post a video of what happens when I do that.


#6

I’ve done it in your model and it works perfectly fine. This is one area where SketchUp doesn’t make mistakes.

I recommend learning more about how to use layers correctly. For example, you have the shell of the computer on a layer called computer, but that’s inside another group and that is on a different layer. To make things worse, your layers aren’t labeled, which makes remembering what’s on each one virtually impossible, and would be the root cause of your issue. This is just my perspective though.


#7

The computer layer I admit is flawed. I copied that from another file. I will probably end up scrapping it. The other layers I tried to keep named the same number as the tab referenced. I’ll try screen grabbing the issues im having when I get back in the lab in a few.


#8

I just fixed the scenes in your model. I don’t know why you are having difficulty. It’s surely some step you are missing. I went to each scene in turn, turned off the unneeded layers, right clicked on the scene tab a chose Update.
Project 1-1 scenes fixed.skp (2.0 MB)


#9

If you can’t make the tutorial you clearly don’t understand.

I have spent far too much time helping people who have ‘learnt’ from people who know what they are doing.


#10

Again, thank you for your help


#11

Well, I just opened the file and went through every scene and updated and it seems to work fine now. The only thing I did different this morning is Update Scene through the right click menu option as opposed to the the option in the Scene Tray.

Thank you guys for your input.


#12

Like the others, I have no problem setting layers hidden, updating scenes, and having the changes stay. And, as others have observed, these actions are SketchUp 101 and shouldn’t be causing you so much trouble. There has to be some aspect of your workflow causing the problem that we haven’t surfaced yet.

The pattern of the flaw in your model is consistently that layers used for higher-numbered scenes are visible on lower-numbered scenes, notably layers 8-13. This leads me to think that the problem is related to how you are creating/adding those high-numbered scenes and their associated layers.

One possibility that occurred to me is that you might be creating your high-numbered scenes and associated layers in a second model, setting layer visibility per scene there, and then importing that second model into one that contains the low numbered scenes. There are a couple of ways that workflow could go astray.

  • First, new layers in an imported model are always imported visible in all scenes of the receiving model. Only if the imported layers have the same names as pre-existing ones (i.e. are not really new layers) will the receiving model’s scenes preserve layer visibility settings.
  • Second, scenes are not imported from a second model. So one way or another you have to add those scenes to the receiving model. The order of doing so could mess up layer visibility.

#13

When you were updating through the Scene panel, did you pay attention to the tick boxes in the Properties to Update panel?


#14

The only thing i brought into this file was the computer/screen image layer. Everything else I did from scratch. Although now that I’m thinking about it, I did save some styles from another file in a folder and used those in some of the scenes. I wanted to keep the look of the original file for the new one. I still have more scenes to add today, so I will not use any of those saved styles going forward and see if that might be the sources of the problems.

The file does seem to be working fine now. But we’ll see later.

Thank you Steve.


#15

As Dave pointed out, maybe the “hidden geometry” checkbox isnt checked in the scenes panel?
that panel isnt always visible, so if you check the + in the top right corner (to left of arrow) that menu should drop down. Only the checked attributes will update in a scene.scenes