Layers and Scenes - Visibility Settings keep changing

scenes
layers

#1

Good Afternoon All,

I wanted to use layers and scenes to create a cut list with dimensions which I do not want to see in the main drawing.

When I switch between the various tabs for the scenes I am finding that the visibility settings which I had set before updating the scene get changed to something else.

Please note the visibility setting change dependant on the order in which you navigate through the tabs. Suggesting to me that sketchup is carrying over the visibility settings from one scene to another regardless of how the scene was last updated.

I have reviewed a number of posts which describe a similar issues I have therefore:

  1. Checked that sub groups and components are in the correct layers.
  2. Ensured that the visibility settings are saved when updating the scene.

I original drew everything in layer 0 as recommended. Then to create the scenes copied the appropriate components and updated the entity information to match the layer as recommended.

I wonder if this is where the issue lies. If so I am not sure why. What get switched to visible appears to be dependant on the last scene viewed. Not what was last saved.

Any help would be greatly appreciated.

As this is taking too much time I am currently creating a separate file for each component separate from the main drawing to create the cut list. But this seem like a ham fisted approach.

Sorry I forgot to mention that the thumb nails for each of the scenes correctly show what I expect it to show.Internal Bifold (Based on VuFold Finesse 1.8m).skp (283.2 KB)


#2

How about sharing the SKP file so we can see what you’ve got? I expect you’ve got something messed up with the attributes saved with the scenes.

If you don’t want to share the SKP file publicly, send it to me via a Private Message.


#3

You are probably not updating the style used in the scenes, updating a scene will not update the settings of the scene itself…


#4

Apologies but I am not sure how to do that?


#5

Do what? Upload the file? Or send in a PM? To upload a file, click on the Upload button, 7th from the left in the row of buttons above the message window. If you want to send a PM, click on my avatar or name and click Message.


#6

I was not aware that I needed to update a style. So when I right click the tab and do an update are you saying that that does not update the scene??


#7

That updates the scene but not the style.

Have you defeated the changed style warning message? If so, you need to re-enable it.

Screenshot - 11_5_2017 , 12_04_27 PM


#8

I have updated with the file.


#9

Got it. Hang tight.


#10

No that appears to be checked


#11

I see that you aren’t leaving Layer 0 as the active layer. Beyond that, I can’t tell what it is you actually want to see in your scenes.


#12

Sorry it has all got a bit messy having tried so many things. I want to see 1 component in each scene (other that the main where I want to see the whole thing) . In each scene I would like to add labels and dimensions.


#14

I think I know how to fix it. When in the Scene tray, select the little “right” pointing arrow, then show details. From them, there will be a little menu popping at the bottom with little checkboxes. Make sure to select, Hidden Geometry, Visible Layers, Active Section Planes, Style and Fog…

Each Scene will now retain specific layers you want to hide or show…


#15

I had a similar issue and I resolved mine by showing Layer 0 (even though nothing was on it) in all of my scenes. When I had it hidden I would get layers showing in scenes that I did not want just as described above.

I followed DaveR’s advice above, and added Layer 0 to all my scenes and now it works great.


#16

FWIW, since Layer 0 should ALWAYS be left as the active layer and all edges and faces should be left on Layer 0 and the active layer cannot be made invisible, Layer 0 should be visible in scenes.


#17

Standard advice is that all basic geometry should be on Layer 0. Then you make associated geometry into Groups or Components and assign them to layers. You don’t have to do that but it’s real easy to get in a muddle if you don’t!


#18

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.