2017 SU Scenes overwrite other existing scenes

scenes

#1

Hello all I’m a newbie to SU in general and just downloaded the 2017 version. I have been trolling the net looking for tips and luckily have found many. I have not found the answer to why my scenes overwrite other scenes issue in SU which are translated to LO.
Project is one of modeling for structural architecture plans:
I’ve got multiple groups, assigned to different layers and a few scenes for top and side cut views for dimensioning in layout. My issue is when I setup a side cut scene to show a cut of a foundation wall, the neighboring group (foundation wall ) is hidden so to keep the detail clean. From this point my scene is complete and updated with all options checked. I then turn to the Top View scene previously setup and the same groups that I hid are also gone from this scene. I’ve gone back and forth and both scenes and they are overwriting the other. Both are separate groups and are grouped again together and are on the same layer “Foundation”. So unless I want to further complicate my layering system I think I’ll keep it that way.

I have other side cut scenes that are not having this same issue with my top view. I also have deleted and recreated one of these scenes with no avail. Any ideas? Bad scene/bug?


#2

Sounds as if you aren’t using Update on the scenes, to save their settings. If you aren’t being prompted with a Warning: you are creating or updating a scene and haven’t saved the changes to your styles the you may have turned that Warning option off.

Turn it on again in Preferences/General - check the box Warn of style changes when creating scenes. And choose Save as new style when asked what to do.


#3

Sorry, you ARE already updating the scenes. But unless you are hiding the groups by turning off the layer they are assigned, the hiding of objects is NOT saved in the scene.

EDIT: This statement is WRONG - see later
The objects are hidden or visible for the model as a whole if you just select the object and choose Hide or Unhide.


#4

So what you are saying is use an extensive layering system? That would add to the extensive management list I’m already working with in Outliner. If what you are suggesting to be true then why does the update/Scene menu state, as an option to save “Hidden Geometry” state?
My “All on” scene is not affected by the other 4 scenes state except for these two troubled groups I’m asking about. They seem to affect all the other scenes. Is it because the multi level grouping is on the same layer? All base data faces/lines are on “0”.


#5

When checked, it does indeed seem to save the state of hidden objects - hide the object, check the Hidden… box in Styles, update the style, and the hidden state is preserved. But NOT in a scene where that box is not checked. The object hidden in Scene 1 is also hidden in Scene 2 if you haven’t

  • unhidden the object in that scene
  • checked the Hidden state… checkbox in that scene
  • updated the scene.

It confused me when I tried it in an older model, as I don’t normally have that box checked. And I’m still confused about why it is happening in your model.

Could you upload your model so others can look at it? There may be something in the way you have used layers that is confusing the issue - for example, you may have assigned raw geometry in one or both of these groups to a layer other than Layer0.


#6

I believe it was the layering issue. I went back and started re-assigning everything to Layer-0 and things started to respond better. Others have suggested that all first level line work should always stay on layer-0; it’s the grouping/component and assembly of parts steps where a layer naming convention seems to be used.?
I was also struggling with the styles toolbar and the views it created at the same time. For other users, don’t be confused to click on the icon that shows a refresh symbol. It updates the settings in the active style that is currently set to the view, instead be mindful of the current style you might want to create a new style with the settings you have chosen.


#7

Not sure if that was meant as a question, but…

The key thing to understand is that SketchUp layers do not gather, isolate, group, or in any other way take ownership of entities. They are just a visibility (and optional coloring) property sheet that multiple objects can refer to so that they all get the same treatment. Only groups, components, and non-geometry entities such as dimensions, 2d Text, and images should refer to a layer other than Layer0 because doing so for edges or faces almost inevitably leads to very confusing issues.

Another key thing to understand is that entity hiding affects what you can see and select, but it too does not isolate or protect hidden entities from interaction with others.


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.