Even within SU it is not saving scenes

I am not sure what I am doing wrong but it is not saving scenes properly in SU… I save a scene and update it, switch to another scene and then switch back and the update doesn’t take effect…Watched all of the recommended videos and there is zero troubleshooting or even mention of possible issues like this… I have included my model in both LO and SU and would really appreciate some assistance.(Transfer - Dropbox)

If you’ve been editing the SketchUp file you’ve shared, it isn’t the same one that you are using in the LayOut file you shared.
Screenshot - 1_28_2024 , 8_20_17 AM

Screenshot - 1_28_2024 , 8_19_00 AM

You can update the model reference until the cows come home but the changes you make in that SketchUp will not be reflected in your viewports.

The viewport displayed when the LayOut file opens shows you’ve overridden the Camera and Style properties for the scene. Dark gray background and Reset button are the evidence. Changes you make to the Camera position and/or style for the scene in the SketchUp model will be ignored because of the overrides.

Changes to those properties will also not update if you copy the viewport and change to a different scene unless you reset them.

First, make sure you are working with the correct SketchUp file. If you really have been editing the one with “copy” in the name, relink the SketchUp reference in LayOut to that file. Then reset the Camera and Style properties for the viewports so the changes you made will be displayed.

What changes are you making in the scenes that don’t seem to be getting saved in the SketchUp file?

May I kiss your feet? :stuck_out_tongue: I will investigate and get back to you… I was using section cuts and turning off and on objects and tags but nothing was saving…

Bleah! :stuck_out_tongue_closed_eyes:

Were you actually updating the scenes? Note that changing the state of sectin plane and section cut visibility is a style setting and requires an update to the style when the scene is updated. If you change the visibility state of the section planes or section cuts and update the scene without first updating the style you should be seeing a warning message like this.

You need to make the appropriate choice from the first two options. I strongly recommend not selecting the third one and I also strongly recommend not turning this warning off. It just leads to errors.

I figured out what happened with layout but it isn’t even saving the scenes in SU…

1 Like

not getting any warning message but how and where should I be changing it in style? what are the benefits of this? I am just curious because the process seems a bit convoluted and I am just trying to make sense of it all…

for the record, I mean that it is not even saving in SU… I am literally updating a scene then going to another scene and then back again and nothing saves…

You can change whether or not section planes or section cuts are displayed in the style in the Modeling settings of the Edit panel in Styles.

When you change any style property the thumbnail at the top left of the Styles panel will show the curved arrows indicating that the style has been modified but not updated.

You can also change the section plane and section cut visibility with the Sections tool palette or in the View menu. The effect is the same and it modifies the style. If you are editing but not updating the style and then updating scene the scene and you don’t see that warning, it indicates you’ve disabled it. Then your style update isn’t getting saved with the scene properties. Go into Preferences (Settings in the SketchUp menu to the left of File) and in the General panel click on Reset All Warning Messages.

Here I’m turning off Section Plane and Section Cut display in the View menu. Notice the curved arrows that appear on the style thumbnail. Then when I update the scene I get the warning that the style has been edited but not updated. After choosing to update the style, going back to that scene shows the changes I made have been saved.


what is the best way to screen grab and post like you just did because I get what you are saying but I Don’t think you quite understand what I am saying…

for the record, I am not concerned about it not saving the section plane outlines, I want it to save the settings of visible tag groups and visible objects…I want to be able to click each scene and actually see the floor plans and cycle through with an animation, which I don’t think involves a change in style setting

it is weird because I just made a new test drawing and could easily do exactly what I wanted it to…not sure what I strong and where but I think something is definitely wrong somewhere…

There are a variety of screen capture options out there. I used LiceCap for the one I did.

Updating the scene after changing which tags are visible works for me.
There must be something different about what you are doing.

can you do that with section planes on each floor? even the model I just did as a test won’t let me hide stuff now…it is just bizarre…made three shapes with two section cuts…put the three shapes in different groups and on different tags…shapes don’t disappear with tag visibility…

You can create different scenes with different section cuts.

Share your test .skp file.

TEST .skp (40.8 KB)

First, the only thing you’ve tagged in your model is the surface for the side of the cylinder.
Screenshot - 1_28_2024 , 9_53_59 AM

The rest of the geometry in the cylinder is untagged, as it should be.
Screenshot - 1_28_2024 , 9_54_26 AM
None of the groups in your model have been given a tag.

Here, after fixing the incorrect tag usage and then giv ing the cylinder group and the big brick their tags. I can update the scenes to show or hide the tags as needed. The style could stand to be updated to hide the section planes, too.

I think you may have just cracked the code and that was the step that I was missing…in regards to assigning tags to groups because they were not assigned in my other model, either…I don’t recall them mentioning that in any of the videos…I need to watch a sketch tutorial on just section cuts, I think… :stuck_out_tongue: you are definitely on the Christmas card list, though :wink:
forever grateful!

I’m sure there was something somewhere in whatever videos you were watching that demonstrate giving tags to components and groups. And obviously SketchUp can’t know to which objects you want to give the tag when you create it.

A couple of key points for using tags to make your life easy and prevent errors in your models.

  • Leave Untagged as active at all times. The pencil icon in the far right column of the Tags panel should always be left at Untagged.
  • All edges and faces (geometry) should be created and remain untagged.
  • Only groups and components (objects) should receive tags.
  • Use tags to control the visibility of objects in scenes.
  • Make logical use of tags and collect tags into appropriate tag folders so that you can easily control the visibility of related objects in the model.

You can give tags to objects in the model as I showed by selecting them and changing the tag in Entity Info. There’s also the Tag tool with which you can give a selected tag to objects you click on in the model. The Tag tool is at the top right of the Tags folder or in the Large Toolset.

An important but subtle thing is that if you explode an object that has been given a tag, the contents of that object inherit the tag. This can be very useful if you have nested objects, child objects inside a parent object. If the child objects aren’t already tagged they will get the parent’s tag. If you explode an object to raw geometry, the geometry will inherit the tag.

There shouldn’t be that many cases where you need to explode groups or components to raw geometry but if you do, the very next step should be to remove the tag in Entity Info while the geometry is still selected.

Maybe for later but also consider that you can control the visibility of tags in viewports.That means you can use the same scene for different viewports with different tag visibility options. For example, the top row of viewports is created from a single scene that, in SketchUp looks like the one on the left. The section elevation with the carousel horse uses a different style with section cuts enabled but it is otherwise identical to the first one. In the second row the first viewport shows the model as it appears in SketchUp. The other viewports in that row use that same scene but with different tags or tag folders displayed or hidden.

As for videos, check out the Fundamentals tutorials at learn.sketchup.com and also go to the SketchUp YouTube channel and check out the Square One videos.

Thank you. I’m glad we sorted out what the issue was. Oh, and a Christmas card is more desirable than having my feet kissed. :crazy_face: :rofl:

I didn’t say that feet kissing was off the table… :stuck_out_tongue: Curious though, in terms of efficiency, I don’t see why creating a group wouldn’t automatically assign a tag… Also, I think it would be cool if someone made a page with an index of every action with a gif like you posted demonstrating what each thing does… Tag to me implied naming something and I have watched hours of videos and nobody really gets into the complicated relationship with objects and groups and section planes… I am not trying to hate on the software but I just know that there are a lot of people out there that would also struggle with these concepts… a video about groups and tags and how they interact and how they should be used together would be extremely beneficial…

How would SketchUp know what tag you want to assign to the object?

Oh my! That would be a very long page. The Square One videos and the SketchUp Help files already cover most of that.

Maybe think of tags as a way to categorize objects for controlling their visibility. Groups and components can be given names that identify what they are. Here in this chair model I have a bunch of components with useful names to identify them. I’ve also got tags so I can show or hide categories of parts.

I don’t know that the relationship is all that complicated. I know it isn’t meant to be. I don’t know what videos you’ve watched so I can’t comment on them.

1 Like