Scenes keep changing after updating

Hi, I’m having trouble with my scenes changing after updating them and was wondering how I solve this.

I have set up scenes ie elevations and sections of a simple residential structure. I go through and setup all the scenes, and then when I go back to these scenes after viewing other scenes, they are all changed to match another scene I have just last created or previously clicked on. I have been saving the styles, and updating the scene tabs methodically.

For example, I made 4 scenes of elevations and 2 scenes of vertical sections. After updating my section scenes, I go back into my elevation scenes and they also now have sections cut through them. Also, When I click on my floor plan scene tab and then go back to my elevation scene, they have a horizontal cut through them.

I am lost to explain what is going on here. Any help would be great. Thanks.

It sounds like you have unticked some properties to save when scenes get created and/or updated. Have a look at the list of properties in the Scenes window and see what needs to be ticked.

Hi DaveR, I thought this was the solution after reading your reply, but when I got back into the model, it’s still doing the same thing, after I ticked the boxes which I think need to be ticked.

When I first opened the model this morning, everything seemed to work fine for about 10 minutes. I then sent the model to Layout, and the scenes didn’t look right. I went back into SU and the same issue was happening again.

I restarted SU without saving to get me back to where I was when it seemed to work fine when I first opened it this morning. Now when I click on each scene tab, each scene is different every time I go back to it. It changes style to match the style in the previously viewed scene.

How about sharing the LayOut file so I don’t have to guess anymore at the solution.

Sorry, grabbed the backup file. this is the skp file

Are you seeing them changing in the LayOut file or in SketchUp?

in sketchup

OK. So I was correct that you have some boxes unticked in the Properties to Save list. That means that changes you might make to those sort of properties for a give scene won’t get saved when you update the scene.
Screenshot - 1_26_2018 , 7_09_44 PM

For some scenes you’ve unticked Camera Location, too.
Screenshot - 1_26_2018 , 7_16_14 PM

Correct the situation by ticking all of the boxes. Then go through and set up each scene the way you want it and update it.

I also notice you aren’t using layers correctly. You have all sort of edges and faces on layers other than Layer 0 where they belong. It’s especially easy to tell when you select all connected geometry inside a group or component and the Layer window in Entity Info is blank.

All geometry (edges and faces) should remain on layer 0. Only groups and components get assigned to other layers.

DaveR, I did exactly what you said and it now works perfectly. Thank you very much.

2 questions…

  1. Is there an easy automatic way to know if I have any geometry in the model not assigned to Layer 0 (without having to go manually look for every edge or face etc)?

  2. When setting up my scenes, why wouldn’t I just leave all the boxes ticked? If the scene doesn’t have any say, shadows, by leaving the Shadow Settings box ticked, the scene would just have nil shadows to save, would it not?

Just an aside: In some of the default templates, some of the checkboxes in properties to save with scenes are unticked. The same goes with the PhotoMatch feature, it creates a scene with some of the crucial checkboxes unticked.

Tig’s layer watcher.
https://sketchucation.com/pluginstore?pln=TIG_LayerWatcher

Thank you very much Box. That is great. Works perfectly.

Thank you Anssi

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.