Scenes changing despite previously setting

Forgive me if this has been covered - I’m new to the forum and probably can’t find my way round very effectively! I’m also new to Sketchup, but am finding it excellent after the initial steep learning curve.

I’m using Sketchup Make 2016 on Windows 10 x64. My problem is that I’m preparing a model to see how an extension to my house might look.

To that end, I have set up a number of scenes showing different aspects of it, including some section/plane cuts, and some hidden parts such as roofs to show the internal and external views.

Initially, it worked beautifully but now changing one thing in a scene either doesn’t “stick”, despite updating it, or sticks to other scenes where I don’t want it.

I have tried changing a number of options but none of them seems to help. I have tried changing the scene update dialog box, specifically by unchecking and rechecking the Hidden Geometry box and updating/saving in between, to no avail. I’ve looked at various topics, including [Scenes not changing. Stays on last scene], but either I’m not understanding them or they don’t cover the problem. Can anyone help, please?

Incidentally, although it may well not be related, the warning about updating styles seems to have stopped working. Could that have anything to do with it? Even if not, can anyone suggest how to turn it back on?

Thanks for any responses.

Make sure the tick boxes are all ticked in the Scenes panel and in the Scenes update panel.

These are from 2020 where Layers are now called Tags. Everything else should look the same.

Screenshot - 2_3_2020 , 11_35_19 AM

As for the warning, I expect you disabled it at some point. Go to Preferences>General and tick the box for the warning.

To avoid confusion by any later readers of your post, can you please edit it to change ‘Sketchup Free 2016’ to read ‘Sketchup Make 2016’? The latter is also the name of the version you show in your profile.

Sketchup Free is the name for the Web version of Sketchup introduced a few years ago, and has no version number - it is continually updated IIRC.

FWIW, is there any reason you don’t want to upgrade to the later (and last) version of Make, 2017?

It may be that your graphics hardware isn’t up to it (v2017 required the use of graphics hardware acceleration and at least v3 of OpenGL driver support). At least one friend of mine can’t run anything later than v2016 on his computer.

Thanks for the response, John.

I have changed the reference as you suggested.

Also, I’ve downloaded the 2017 version and it seems to work OK (although the problem remains…).

I think the problem with updating styles has gone away - no idea why!

If you mean you are seeing the Styles warning in SU2017 now after installing it, that’s because it is the default for that warning to show and you’ve installed a new version. That wouldn’t fix it in SU2016, however.

You do understand that in order for different scenes to have different styling, each needs it’s own style object ? (I often suggest naming the scene and the style it uses the same in the model’s collection.)



Many thanks for your reply. No doubt you will see my reply to John McClenahan’s helpful response, so you will see that the warning part of my query looks to have been resolved, at least for now. For what it’s worth, I had that setting as you suggested even before then, but maybe I had just not done whatever triggers the warning for a while. I am a newbie!

In relation to the scenes updating incorrectly, the change to 2017 hasn’t made any difference as far as I can see (I know neither of you intended this as a solution, but thought I’ld mention it.)

You suggested ensuring that all the boxes in the Scenes dialog box were ticked. I was not as specific as I should have been in my original post, but I intended to convey that I had indeed checked that all the boxes were as you have now suggested, and then tried a variety of combinations of turning them off and on. They are currently as shown below, which seems to match your recommendation. Unfortunately, no joy.

Sketchup Update Screenshot

I get the feeling I’m missing something obvious, but I really can’t see what.

(And now the ability to “Show details” on the scene thumbnails looks to have disappeared too.)

This getting very frustrating!

Did you notice my question above? If you purge the model of unused stuff (Model Info > Statistics > Purge Unused) is it small enough to post here so a guru / sage can take a look ?

Thanks Dan

I’ld missed your question, but looking at it now, I really don’t understand about Styles in relation to what you’re saying. The reason I thought the Styles issue had gone away was that the warning had come up, but that was only the once, and despite updating Scenes many times since, I haven’t seen it again.

However, somewhere along the line the problem with seeing parts of the model in scenes when I thought I had set it up without, and vice versa, seems to have fixed itself. I can’t think of anything I might have done that could have had this effect - apart from having purged the model as you advised.

That just leaves me with the Show/Hide details issue.

I would be very happy to let a guru/sage have a look at the file - I’m sure it has failings which would benefit from an expert’s examination! It’s 4.88 MB, although zipped it’s 1.74MB. Is that small enough?

Many thanks again for your help and patience.


I think there is a 5MB limit for forum posts.

Well how many scenes does your model have ?

How many styles does your model have ? (You look at the Styles inspector and click the house button which displays the “In Model” collection. This holds for any the of the resource inspectors.)

It sounds like you only have one style in your model’s styles collection. The warning dialog you saw indicates you keep changing a single style for different scenes, instead of copying the previous style for the current scene and changing it explicitly for that scene. Then repeat for each scene that needs styling changes.

Hi Dan

Thanks for taking the time to reply again, and I’m sorry not to have replied sooner - been busy this morning with household stuff!

To answer your questions first: there are 12 scenes in this particular file, and five styles shown in the “in Model” dialog box, accessed following your guidance. Having said that, they are all labelled “Simple Style”, four with a number after the label. As far as I can tell, they are all identical, although I’m not sure how I would check that? In light of this, however, I’m thinking that you’re absolutely right about there being only one style.

That being the case, can you suggest how I might now go about changing this, without risking damage to the file as it is? Please bear in mind that I’m 70+ years old and getting rather slower at picking things up than I once was! If you don’t have the time, that’s fine - I’ll try to work something out on my own.

Thanks once again.


This means they were copied from one another.
I’d suggest naming them according to something you understand. ie “Simple with Blue Background”, “Black and White for Printing”, etc.

Via the Edit tab of the Styles inspector.
After making any changes in the Edit tab and it’s sub panels, you need to update the style and update the scene(s) that use the edited style.

See this chapter of the User Guide …

I’m sorry, Dan. Your advice is much appreciated, but I am just not seeing this at all. I have spent a lot of time since you posted above trying to work out what I need to do, and why I can’t get it to work.

(For clarity, and as an example, I am trying to show the effects of different types of roof on a proposed extension to our house. I have created hip, gable and sloping versions of the roofs along with the rest of the model, and want to show how each looks. I am therefore creating three scenes where each one of the variations is shown in turn, and want to play the animation. There are other scenes showing further aspects of the model, but if I can understand how to do the roof animation, I hope I can apply it to the rest.)

I have selected a scene and set it to show the roof element of the model I want, changed some (random) properties in the Styles box, updated the style and the scene, and moved on and done the same for the next two.

I must be somehow applying the Style settings from the second scene I have altered back to the first one, because they then both contain the same elements, but I really can’t fathom how to get it to work properly.

I saw a warning dialog box about saving the first few times I did this, but that’s stopped happening any more.

I read the link you provided about choosing styles - do I really have to go through this to make the scene “stick”? I don’t want these changes, so I’ld have to change them back and hope that the scenes ended up the way I wanted them in the first place. I’m sure I’m misunderstanding the whole thing, but despite reading up on it in the Dummies book and searching on the ‘Net, I’m not getting any closer to a solution.

I just feel so thick, and would understand if you just gave up trying to get me to understand.


Sorry, should have added that I “fixed” the Show/Hide details issue - I hadn’t spotted the second scroll bar which allowed me to go below the scenes which were on view! Doh!