2015- Layers and Scenes


#1

Okay, so this was not a problem in 2014, but it is a problem in 2015. In the past, when you created scenes, it would save active layers per scene as well as camera angle. So, for instance, if I wanted to make a plan cut and remove all doors and windows in a scene, I could just put all doors and windows on a layer and hide that layer during the scene. Then, if I ever went back to that scene, or if I went to layout to create a plan set, it would save layer visibility preferences in that scene.

In 2015, it seems that the scenes have become detached from layer visibility selection. Now, whatever layers I have active will stay active, regardless of which scene I select. The same goes for section cuts. If I have a section cut active in Scene 1, then switch to scene 2, none of my layers change and my section cut doesn’t change. So I change it manually, and then I update the the scene. But then I go back to scene 1, and the only change is the camera angle, not the section cut or layer visibility. I

Is there a new option somewhere that I need to be selecting to tie layer visibility to my scenes?


#2

Also, scenes no longer save styles. Is anyone else having this issue? What is the point of the scene anymore if they don’t save styles and visibility preferences?


#3

Is this happening for all your models? Or just one?
What are your settings in the Scenes window? Did you untick any of the checkboxes?


#4

Hi Sam,

Be sure there are no unsaved changes to the active style before creating a scene.


#5

I am having this same issue and I have not may any style changes between scenes. Any other suggestions?

Dave -


#6

I have experienced the same thing today. After closing and opening the file again, I was able to solve the problem. I find SketchUp 2015 not as reliable as 2014 was. I’m on retinaMBP.


#7

I’m having the same problem. I setup a scene, I update it, got to the next scene, which shows additional layers, and when I go back to the first scene I setup, it show the additional layers from other scenes. This is so frusterating. Does anybody a have any suggestions? Is Sketchup aware of the problem? Are they doing anything about it?


#8

Have you checked “Visible layers” in the “Properties to save” section in the Scenes window? It is a per-scene setting.

Anssi


#9

Yes, I have all the properties checked.


#10

Here’s a link to a video of the problem I’m having. Any help is appreciated


#11

I haven’t found the answer (yet) but what puzzles me is why you make some layer other than Layer0 the active layer and then at some point update the scene. Although you can make other layers the active ones, Layer0 should be the active layer. Maybe this is the root of your ploblem.


#12

Thank you so much, Wo3Dan. Using Layer0 fixed the problem.


#13

Hello.
Had the same problem.
Soulution - press refresh button on the Scenes tab.
Then SketchUp behaves as expected.
Checked on Windows machine.


#14

I am having the same issue and have not seen a solution that fixes this issue yet. I have tried everything. If I have all of the boxes checked and I have the layers I want on or off for each scene why does it change when I change from scene to scene.

There is a bug somewhere that needs to be fixed. In Autocad there is a feature called VISRETAIN that either turns this feature on or off with regards to saved views and layers.

Come on guys let get this figured out already.


#15

I’ve never experienced this issue. Perhaps you could share a SKP file that exhibits the behavior?


#16

Figure what out?
Each scene has “Visible Layers” checked (1) or not (2). (Leave the Layer Manager open to see)

(1) these saved scenes each can have their own saved layer sets.
So changing from scene to scene might show you different layers.

(2) the visibility of current layers in a scene depends on the scene prior to the newly selected scene.

Do you experience scenes differently?


#17

I have the same problem.

  • Scene 1 has no layers checked
  • Scene 2 has layer 1 checked
  • Display Scene 1 - everything is OK
  • Display Scene 2 - Layer 1 shows
  • Go back to Scene 1 - Layer 1 is still showing and is checked.

I’ve tried updating scenes, with and without Visible Layers checked and that doesn’t fix it. I’ve tried updating all scenes. That doesn’t work either.


#18

@xjmanchester, please share the LayOut file so we can see exactly what’s happening.


#19

I tried to make it fail on a new sketch and can’t. The problem does exist in an existing sketch. Something must have happened to the existing sketch. I’ve copied everything to a new sketch, created the necessary scenes and layers and it’s working now.


#20

I have the same problem I have attempted all the suggested solutions given here. None work. It is such a shame. It looks like it should be a simple and powerful tool.

I think I would like to turn this thread on it’s head. Instead of asking for solutions to the issue please can I ask if anyone uses layers and scenes successfully as per the older tutorials.

If not problem solved I will just forget this completely and move on.