Scenes are not updating

scenes

#1

When I make changes to a scene and try to save them nothing happens. There should be a pop-up which asks to confirm what attributes of the scene should be updated and saved, but this pop-up is not generated and no change is recorded. This is intermittent. Sometimes if I restart SU it will then work fine.


#2

What changes are you making and how are you updating the scene? If you right click on the scene tab and choose Update, there is no pop up box if you make no style changes or have disabled warning of style changes


#3

Various changes like camera position or visible layers. I am updating wiht the scene manager. A popup should be generated. it seems I may have one or more corrupted files. I moved all of the model to a new SU *.skp file and the problem is gone. But if that bad file is open and the error is triggered, then the update function will not work in any open file. I would like to be able to fix the bad file. It has at least 8 scenes that I would rather not have to recreate.


#4

Like Dave, I’m confused. The popup for a style change is the only one I’ve ever seen. Otherwise you check the boxes you want to preserve or not preserve in the style manager and then update. The ones you checked should “take” but there is no popup.


#5

Actually it just happened to a brand new file.


#6

Could you upload the bad file so we can examine it (size limit 3MB on this forum)?


#7

test.skp (327.3 KB)


#8

I am not sure it is the file. the file test.skp is a new file. maybe it was the style I applied? Maybe my installation of SU is bad.

I may reinstall SU to check

I did reinstall SU and restarted using a file I had trouble with before. This thing happened again when I tried to reapply the style I was using and then update. Perhaps it has something to do with my styles.


#9

I took a look at that file and I see two scenes. I have no problem updating either of them. A new thing for me, though, if I update from the scenes window’s Details menu I get a popup menu with the set of checkboxes for what to save with the updated scene. Had never seen that before as that isn’t how I usually update scenes, but it works as you expected.


#10

It is very cool, because you can in that way update only one item at a time. I use it to copy the camera position from one scene to another. If you go to scene 1 and then right click on scene w in the scene manager and click update, you can choose just camera position. And that setting is transferred to Scene 2.

I don’t now think the problem is with my files. But I am not sure why the popup get turned off. It seems to have something to do with changing styles. Particularly if I have changed something controlled by the style. I get a warning that my scene and the style do not match. When I then try to pick the same style or another style the problem begins. The next time I try to update, the popup does not appear and the scene does not update. and no scenes update in any files until I close everything exit SU and then restart SU.


#11

I also have a problem with scenes. I have cabinets saved on a single layer - I want a simple animation to move between the cabinets. For example I have layers Cab A, Cab B, Cab C up to Cab Z. I create a scene, call the scene tab “Cab A”, make layer Cab A the default, and then do the same for Cab’s B and C etc. Each time updating the scenes (I’ve tried right-clicking and refreshing the scene manager - each time I’ve updated all) When I click back on scene Cab A, depending on the sequence of scrolling between the scenes, Cab B might be the default and perhaps Cab D is active.
Has anyone else had this happen? Have a fix?
thanks for your help!


#12

Why are you updating scenes after you make them? Just do this.

Make the layer Cab A the only visible layer. (Layer 0 always remains active, though). Then create a scene for Cab A. Next, turn off the Cab A layer and turn on Cab B layer. Create a new scene and name it Cab B. Make the Cab B layer invisible and make Cab C layer visible. Create another scene. Rinse and repeat for the rest of the layers. No need to do any updating at all.


#13

Thanks Dave for the reply.
I more or less did that, though I needed some of the cabinets to remain on for certain views, and there were also a couple of other objects (door handles for example) which were imported as a group, so the scenario isn’t quite as simple as I outlined. So in setting up the scene tabs, I did need to do some updating to get the layers I wanted to be visible
My question remains the same though - I’m trying to work out why the scenes don’t seem to update and retain the scene attributes I ascribe to them - any ideas? I’m sure its something forehead-slappingly obvious


#14

For things that you want to display in more than one scene, you need to make separate layers. So maybe you make a layer for door pulls that is displayed for scenes A and B but turn it off for C.


#15

Dave,
I think I have everything set up correctly on the layers - the anomaly that I am encountering is that the updated scene is not retaining my changes. I tried to attach my model but it too large - is there I way I can email it to you?
thanks


#16

Send it to dropbox and give me the link.


#17

Cab AB - I can’t get Cab AB layer to stick as the default.
Cab C - I can’t get Cab TU to stay turned off.
Cab D - I’m happy for Cab C to stay on, but I can’t get Cab D to stick as the default and Cab TU won’t unstick.
Often the changes hold for a little while - eg I changed the default on Cab J to Cab J layer, but when I click on the Cab C tab and then go back to Cab J, Cab C is now the default

thanks for your help


#18

Oh boy! It’s going to take a bunch of fixing but first, you need to learn about how layers work in SketchUp. This is very important. Start here: http://help.sketchup.com/en/article/38572 That fact that you are making layers other than Layer 0 active and that you’ve got edges and faces on layers other than Layer 0 is causing you all sorts of problems related to getting things to show in the various scenes. In addition, you’ve got geometry for the same cabinet on different layers which increases the problems. To be honest, your model would make a great poster child for why the rules given in the link above exist.

I’ll work on fixing your model for you but I probably won’t get it finished tonight. 3:30 am comes too soon.


#19

OK. Here’s the link to a revised version of your model. Sorry it took so long. I had to get a little sleep in there.

I moved all the geometry (faces and edges) back to Layer 0 where they belong. In almost every group, you had geometry scattered between multiple layers. You can tell by looking at the layer assignment in Entity Info and selecting all of the geometry within the group. if the Layer box is blank, there’s more than one layer involved. Only the groups and the few components you have in the model now have layer associations other than Layer 0.

Then I made Layer 0 the active (default, as you call it) layer. You’ll note that as you step through the scenes, Layer 0 remains the active layer and is always visible. The layer or layers for the appropriate cabinets is also visible. Layers for cabinets not shown in the scene are not turned on.

The thing with having geometry on layers other than 0 and geometry in the same group on different layers means that when you turn off a layer containing some of that geometry, part of your cabinet disappears. This is a sure way to madness. If you read the information at the link you sent, you’ll now know that layers do one thing in SketchUp and that is control visibility. They do not provide separation. That must be done by making components or groups. Follow the rules provided in the article and you’ll have a much easier time of it.

I also fix myriad reversed faces and purged unused stuff from the model. In an effort to reduce file size more, I also deleted stuff that wasn’t shown in any of the scenes such as the walls and roof of the building. I understand you may still need those things in your final model but my revision is just to show you how the layers and scenes should be set up.

There are some other things that really ought to be fixed but I didn’t take the time. For example, the drawer and door pulls are handled erratically throughout the model. In some places they are components, some nested components and others, loose geometry within the cabinet group. I don’t see any good reason for doing that. They should all be instances of the same component. If you want to show options for different pulls, you could assign all of the wire pull components to a “wire pull” layer and create another layer for a different pull, say for round knobs. Then you can create a Cab B Wire Pull scene and a Cab B Round Knob scene.

That bench in the first scene could use some adjustment and there are many examples of too many edges used for curves and circles. Way more than are needed to show the surfaces as rounded.

The computer displays shown in some of the scenes suffer the same problems as the pulls. Some are loose geometry while others are groups or components.

All of this stuff leads me to think you are working much harder than you need to be.


#20

Gavin, I am have had SketchUp for many years, but have not used it very much until recently. I have been an architect using cad for about 30 years. I did not really pay attention to the layer “rules” for SketchUp. If some item or group was going to end up on a layer called “second floor walls interior” I made that my active layer and created everything on that layer. I learned, the hard way, that EVERYTHING must be in a group if you don’t want it to “Stick” to everything ELSE. But changing the Active layer does not cause any real damage, particularly if you are disciplined about what goes on a given layer.

I solved my problem with scenes updating by reseting the workspace. Go to Sketchup/preferences/workspace and click on the “Reset Workspace” button. It will close all the open popups, and in my case at least solved some issues including the non updating Scenes. Keep in mind that because the orthodox view of Sketchup is that Layer 0 should always be the active layer, Scenes cannot hold the information that another layer is active. So each Scene must have Layer 0 as active or SU will forget the visible layer information. Also if you make a new layer after making a scene I am pretty sure the system will assume that layer is on in all scenes. I guess because it doesn’t hold the data as these layers on and EVERTHING else off.