Layers doing inexplicably weird things

modeling
layers

#1

The model is in the 3d Warehouse as ‘Molch ready for layering’ - this because mechanism on this forum consistently fails to upload my models at the 10% stage. Anyway, I can’t understand what is going on here. Despite all my efforts, layers: ‘New front end’ and ‘Remainder of front end’ cannot be joined together to produce a simple shell. Not only that, the two layers show contradictory shapes for the portions of the shell they contain. It’s such a pig’s ear I’m assuming it to be another bug?


#2

Are these groups or component instances ?

If so they’d need to be wrapped together in a group, then each exploded within that new group wrapper. Otherwise they cannot come together to form one manifold solid volume.


#3

What was the first bug?

In any event, this model is a layering nightmare. It’s full of raw geometry on layers other than Layer0. It will never behave properly until the layers are restructured to comport with the following:

Does SketchUp support layers?

-Gully


#4

It’s a bug because the author of the model did a lousy job of it?


#5

And the purpose of this model is for fun/learning/presentation or for 3D printing?

I’m wondering about the printing as there is stray geometry that would prevent this model from becoming a solid. For example, this nut/bolt assembly has unneeded geometry inside.

This also is an example of how a component can be used. The nut/bolt should be modeled once and be made into a Face Me component that glues to a surface. To start a simple nut/bolt component could be made and arrayed around the hatch. Then move a copy of that component off to the side, and scale it up (as the geometry is small and there can be issues modeling at a small scale but no issue modeling when the same thing is larger.) In the image, I replaced three loose geometry nut/bolts with components.

It was a bit premature to make the left and right conning and hull unique components. And the raw geometry inside the ‘Right conning & hull oute’ was not on Layer 0. There’s stray geometry to clean up too.

Where the mirrored components touch, use Eraser + Shift to hide those edges.

There’s no rule to only have one model assembly per file. When working with components, you can have a few just a few components positioned together off to the side if you want a clear view all around to see how they work/look together. Some people like to work with section cuts to examine the inside of models too.


#6

The first bug was one directly referenced as being such by a member of the SU team! It concerned the failure of the program to soften lines consistently.


#7

I am always surprised when a novice makes some obvious mistake, and the first thing that occurs to him is that the program must have a bug. That bespeaks such a remarkable sense of infallibility and self-confidence that I can only shake my head in grudging admiration and envy, for, you see, I have screwed up everything there is to screw up at least once each, and some many more. So when I’m learning something new and things go awry, I don’t waste a lot of time on the “this must be a bug in the program” theory. My first guess is that I must have screwed something up again, and I’m usually right.

-Gully


#8

Irrespective, the programme does have bugs in it. That much is unequivocal.


#9

I don’t think anyone has said otherwise but your first post concludes that a bug in SketchUp is to be blamed for the poorly made model you downloaded from the Warehouse.


#10

It’s likely that you’ll have to clean up fifty messes you made all by yourself before you (independently) find your first real bug.

So what is your point here, anyway?

-Gully


#11

I didn’t notice any software bugs while poking around the model.


#12

Getting back to your topic title, the only weird things I can find layers doing in your model are the result of you not using them correctly.

We can’t say it often enough: layers in SketchUp do not isolate geometry from interaction and do not create any sort of model structure.

The correct way to think of them is equivalent to the way you think of a material: it is something applied to an entity, not something that somehow owns the entity. The entities you have painted red will stick to the entities you have painted blue, just as if you hadn’t painted them. The same is true with layers. They are just a way of sharing a visible/not-visible flag among an arbitrary collection of entities. Hiding or showing a layer has nothing to do with what other geometry the currently visible entities will interact with.


#13

Thanks. All I wanted to know was why the two body shells at the front were causing so much bother. I know there are bits and bobs wrong all over the place, but they don’t seem to affect the way the thing comes apart, at least not for my purposes. Most of the problems you have highlighted, and circled, were the result of my exploding the nuts (which were originaly components) and then trying to intersect them. This caused them to throw out connections and random diagonal lines all over. In the end I ran out of patience trying to clear them all out! The model is simply part of an animation for my screenplay bid, nowt else. I appreciate your input here, edifyingly free of the sardonic put-downs so favoured by others on this forum. Guess some folks just don’t get enough attention at home…


#14

You can try to scale down all the geometry by a factor of 10000 and do some follow me action. You might find a problem, even if bug is perhaps a little bit exaggerated for this.


#15

Hah! Folk ‘do’ Sketchup for FUN! Hmm, guess it’s handy to keep something in reserve for when you’re done pushing drawing pins into your eyeballs…


#16

The information on solving your problems with the ‘New front end’ was given above, but here’s an animation illustrating what can - and did - happen when raw geometry is assigned to a Layer other than Layer0 (and why you do not want to mix up Layer assignment on raw geometry.)

TIP: Do your modeling with the Entity Info dialog open (open from Window menu) - do this so you can monitor what’s going on and make changes.

There’s a lot of information in the animation. Keep an eye on the Layer info on the Entity Info dialog as the cursor selects different things.

The raw geometry was assigned to different Layers. Raw geometry should be on Layer0. Assign groups/components to different layers - if needed. Layers controls visibility.

Another issue that needs to be address is how to best model stuff for what you want to accomplish. Lets focus on the nut/bolt discussed above. If you were going to 3D print this model, that complex, detail model of a nut/bolt assembly would be OK (lots of detail will make a nicer/smoother-looking print.) But as you are making a video, excessive geometry - like what’s in the nut/bolt assemble will add a gob of geometry that’s not needed for your movie and will bog down your file with a bunch of overly detailed stuff that will not even be seen in your movie unless you do a close-up of such detail.

If you left your nut/bolt assembly a component, it’s an easy process to replace that assembly with something with less geometry. Even if you want to zoom in to make a closeup of the nut/bolt assembly, you can take advantage of setting up different Scenes with different visible Layers with different versions of that detailed model visible (proxies) in order to avoid having SU render a bunch of geometry that you cannot see unless there’s a closeup view. See the SketchUp Sage on using groups and components for faster modeling. Review the other techniques for faster modeling - as you want to make a video, optimizing your model for speed applies to you.

BTW, a lot of people do this for fun. I think coming to terms with Layers (and how you can exploit them) is a rite of passage. This 3D modeling stuff is a different way to communicate. Once this little issue is resolve, hopefully you will also like the ‘fun’ aspect of using SU.


#17

What a star you are! Thank you so much for taking the time to trawl through all of my ‘debris’ and clarify everything so beautifully for me. I’ll re-visit the tutorial again; it’s the precise function of Layer 0 that still baffles a tad, if I’m honest. BTW: I sussed a while back that it was going to be essential for me to trim the model to the bone in order for the animation not to grind to a buffering halt. That is why the outer skin is continuous yet hollow. Many thanks once again. Not so much a ‘sage’, more of a blossom-laden cherry tree!. Ok, I’m done gushing…


#18

@spogadog, would it be OK if refine my animated tutorial featuring your model for the purpose of adding to the SketchUp Sage site for others to learn from a real example?


#19

Of course! Go ahead and boot it onto the world stage for me - might signal the beginning of my Andy Warhol’s worth! BTW, I had a peek at some of the layering tutorials and I’m still not too sure about the precise function of the little circled dot to the far left of each layer. I can see that it ‘selects’ the layer (and serves to prevent you from closing it), but does it do anything else? Thing is, I seem to have managed to alter (and screw up!) geometry whether or not this dot has been clicked on. Secondly: after you tweaked my model you made the collective a component (or group?). Despite this, I see that it is still possible to open and close all layers contained therein without exploding layer 0. It is also appears that a ‘short cut’ to getting everything off the screen in ‘one hit’ is simply to close layer 0. Is that one of the reasons for Layer 0’s existence? Sorry for the Genie-esque brain-pick!


#20

The circled dot indicates the currently “Active” layer. This is the layer to which any new entities you draw will automatically refer. Every entity always “refers to” or “uses” some layer; it’s a property of the entity that must be set. Due to this automatic action, one layer must always be active. SketchUp won’t let you make the active layer non-visible because then you wouldn’t be able to see what you are currently drawing!

Unless you have some special reason and are fully confident that you know what you are doing, you should never set anything except layer0 active, as that is one of the quick ways to cause primitive geometry to refer to other layers and create visibility confusion in your model (to avoid adding to the confusion, I won’t write about others).

There is no such thing as “exploding” a layer because a layer is not a collection in the first place. You are still confusing Group and Component concepts with layers. What might be misleading you here is a very poor choice of wording in the SketchUp GUI: if you delete a layer via the layers window, SketchUp pops up a dialog telling you that the layer is not empty (the wrong concept! it should say there are entities using that layer) and asking you what other layer to reassign to the contents. This bad wording draws you back to the mental notion that the layer somehow contains the entities, which is false.