Layers Styles and Scenes - what am I doing wrong


#1

I have a model with two groups of dimensions. For left view and front view.

I have associated the group to proper layer. I try to save the view to scene (I hide the front dimensions when I watch left and hide the left dimensions when I watch the right one). But I think it is not saved because when I click on from left to right scene either I see both dimensions or improper.

Now on the image you see the front dimension instead the left ones.


#2

Oh I solved it. Later I have read some dialogue window which appealed me to update changes. So I have used update button, which purpose is different than I originally thought. So now the changes are saved.


#3

I hope by two groups of dimensions you don’t mean two SketchUp groups. Dimensions can only be associated with what they measure from a higher or the same context.
Grouping them would break that spell, preventing them from following changes made to the geometry.
You probably speak of a bunch of dimensions.


#4

Ah so. Thanks


#5

BTW what hotkey to use for Dimension tool?


#6

There isn’t a pre-assigned shortcut for Dimension.

In English, I have assigned the letter key d for Dimension (and Shift + D for Angular Dimension 2 plugin).

Assign your own, to whatever letter or combination of letter with Shift, Alt, or Ctrl you choose and find easy to remember. Sketchup will remind you if that shortcut is already in use for another command.


#7

Thanks. I miss the possibility to save view into Scenes, it seems like it is not possible to save Style of faces or it simply does not work for me. The Style and Fog is checked.


#8

It is possible to save styles as part of the scene. It would appear from your description that you have disabled the warning about changes to the style when creating or updating scenes. Turn it on under Window>Preferences>General.

Users commonly turn this warning off without bothering to find out what it means.

In the future, when you see this message, use one of the first two options, not the third.


#9

I did not disabled it. But when I am in some scene, then I change the view of faces, and then I switch to different scene, so I see the new style instead of the old style. Is feature in SU8?


#10

Each scene inherits the style you have active when you created it. You can edit the style later and update the scene. Yes. These features have been around since long before SU8.


#11

Hi Barracuda

If you create a new scene or select an existing one, On the dropdown, select which checkboxes you want including ‘Style & Fog’, Right click on your scene tab and then click update. That will save the scene with your desired style and any other settings. If you are changing any checkboxes from what you had, it will prompt youth clarify your changes.


#12

Thank you. I also tried your method, and the result is still negative.

Here I upload the screenshot what I did.

On the last scene (red circle 0.) you see the model when it was red. Then I clicked Front monochrome scene (1.) and changed the view style to monochrome. I updated changes as you described. Then I clicked the last scene (2.) and it did not changed to monochrome colors. You see in the thumbnail icon it should be changed to red.



#13

Your changing the view style on the view toolabar aren’t you? Then updating the scene?
This will not achieve the desired effect in scenes in my experience, you need two styles:

One for monochrome (face styles set to monochrome)
One for textured (face styles set to textured)

Change the style for the current scene, then right click the scene tab and click update. Do that for all the scenes, selecting desired style before you update.


#14

I am changing the style from menu View->Face Style …I think I am doing what you describe, but instead clicking on toolbar, I am selecting from the menu.


#15

That’s it, it’s tricky to explain but that’s where it’s going wrong. You need to change the style from the style window then update the scene and the different scenes will show up as you want. I’ve been here before.


#16

Ah so. So this is the icon you speak about. But the monochrome mode is not there.


#17

Upload the model.


#18

police - široká.skp (79.8 KB)


#19

I have added another style to your model, check the in model styles to see the face style settings.

I had to move the scenes for some reason as they were half off screen. I have applied the styles to the scenes, not sure how you want them, but the idea is there.

So, select scene, then change the style, then right click and update.

You may keep this or simply apply the idea to the original, its up to you

Hope this helps.

added style.skp (90.2 KB)


#20

I opened model, right clicked on the scene tab that was selected and updated scene.

police - široká-2.skp (110.4 KB)