Hidden geometry

I have a model with geometry that shows up as hidden but it won’t ‘Unhide’ -‘All’.

Perhaps the hidden geometry is inside a component or group? If that’s the case, you’ll have to open the component or group before unhiding the geometry. If that doesn’t work, share the SKP file so we can help.

I had a similar problem today. A unhide all geometry no matter where it is feature would be nice. Maybe it does exist, at some point I seemed to be able to unhide everything.

There is an older plugin that unhides everything. It is installed on my systems and it seems to work with the latest SU releases including SU2016.

Here is the link:

Are you sure these edges aren’t softened/smoothed? Those represent the boundaries of the actual facets that make up a contoured surface and don’t respond to Unhide but rather to Unsoften. Hidden edges (in Show Hidden Geometry) are made up of very short dashes–dots, really. Softened edges are made up of longer dashes.


I’ve always felt Unhide- All was misnamed. It really only means Unhide all in current context.

This is true. Also, to me the opposite of Hide is Show, not Unhide.

That was it, thanks! As has been stated in this thread Unhide All really isn’t.

It should probably read Unhide all within context.

I’m having a problem with a piece of crown moulding that I can’t unhide the geometry.

Also, how do I install the plugin/extension mentioned above. I’ve downloaded it, saved it to the desktop as a Text Edit, then have gone to Preferences/Extensions/Install, but it’s grayed-out on the pop-up window.

ThanksFachada study.skp (79.3 KB)

That plugin download is an .rb file that should be placed in the plugin folder.
Or you can ZIP it and rename the .zip to .rbz and install it using the install extension button.

As to unhiding in your model, there is nothing to unhide, what are you expecting to see?

Like Box, I don’t see what it is you want to unhide.

This section ought the have some edges softened.

Thanks for the quick response. I’m trying to unhide the geometry on the short piece of moulding that has a return. I did the upper piece using Follow Me. When I do the lower piece, I get the geometry, whether it’s via Follow Me or Push/Pull.

Re the Unhide Plugin, I changed the name by going to File/Rename, but SU says it can’t install it.

If you followed my instruction fully it would work. Sounds like you didn’t ZIP the file first.

Are you using the wrong words, do you mean you want to soften the geometry?
Is this what you want to achieve?

1 Like

I expect Box is correct. You are using the wrong term.

The curves on the profile’s edge were exploded by the Follow Me operation so using the profile again after running Follow Me will result in the appearance you see with that molding section. I can think of essentially 4 ways to deal with this sort of thing.

  1. Think ahead and copy the profile before you run the first Follow Me operation. You’ll be copying the curves before they get exploded.
  2. Soften the edges with Ctrl+Eraser as Box shows. Or select the geometry and use Soften/Smooth from the Context menu.
  3. Use a plugin such as TIG’s TIG-Weld on the copied profile to weld the curves back together before running the Follow Me or Push/Pull.
  4. Make a molding component you can drag in from a collection. Drag in a new instance for each molding run.

That was pretty simple; using the Eraser, I hadn’t thought of that. Thanks

I had tried to Soften/Smooth, but that didn’t work.

Re renaming to ZIP, out curiosity, how is that done? I can .zip it using Finder/File/Compress, but Open With does not give me the option to rename it .rbz.

But thanks again; you’ve both been very helpful.

Craig, it would be easier for people to answer this kind of question if you would bother to fill out your profile to indicate OS, graphics card, and SketchUp version.

1 Like

It would work if you use it correctly. You need to pre-select the edges you want to soften.

Make sure you are holding Ctrl (or Option on the Mac) when using the Eraser to soften/smooth.

What operating system are you using? Please complete your profile.

Rename the file by clicking on its name.

Thanks all for taking the time, and your patience.

I updated my profile.

If you mean ‘rename’ the Unhide file above, I did, previously, by clicking on the name, and the image changed to the Extension logo with .rbz overlaid. But it still will not install, with SU saying that it cannot. FWIW, here it is:
unhide_all-2.rbz (787 Bytes)

Did you just change the .rb file to .rbz or did you first compress it into a ZIP file? the file you uploaded here is just that; the rb file renamed as rbz. You need to compress it first.

After you compress it into a zip file, change the extension to .rbz and follow the next steps.

The correct way on the Mac would be to open SketchUp and go to the sketchUp menu (left of file), pick Preferences>Extensions. Click on Install Extension… navigate to where you saved the file, select it, click Open, then Yes and any other affirmative answers.